cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5036
Views
9
Helpful
17
Replies
aldred.benedict
Beginner

Mobile Voice Access Not Working (CUCM 8.6)

Hello All,

I am trying to configure MVA in Call Manager 8.6 (1 Publisher - 10.0.2.3 with 2 Suscribers - 10.0.2.4 and 10.0.2.5). Call Manager is inactive in the publisher but active in all the suscribers. My gateway is a Cisco 3925 Router (MGCP). I have done the following things:

1. Enable MVA Service in Cisco Unified Serviceability

2. Configure Service Parameters:

  • Enable Enterprise Feature Access - True
  • Enable Mobile Voice Access - True
  • Mobile Voice Access Number - 8000 (Not DID Number)
  • Matching Caller ID with Remote Destination - Complete Match

3. Go to Media Resources > Mobile Voice Access. Set MVA DN to 8000

4. SSH into the Voice Gateway (IP Address: 10.0.2.10) and enter the following configurations:

  • application

          service mva http://10.0.2.3:8080/ccmivr/pages/IVRMainpage.vxml

  • voice service voip

          allow connections h323 to h323

  • voice class h323 1

          h225 timeout tcp establish 3

  • dial-peer voice 8000 voip

           destination-pattern 8000

           session target ipv4:10.0.2.3

           voice-class h323 1

           dtmf-relay h245-alphanumeric

           codec g711alaw

           no vad  

  • dial-peer voice 1998 voip

           service mva

           session target ipv4:10.0.2.3

           incoming called-number 1998

           codec g711alaw

5. Configured H323 Gateway, Route List, Route Group and Route Pattern in CUCM

However, dialing MVA number gives me a fast busy tone. The error shown in RTMT Tool is: (27) Destination out of order

Any help will be appreciated

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi Aldred,

Have you rebooted the gateway?  Sometimes that's required for the vxml application to work properly.  Also, is the call even getting to the H.323 gateway?  Run a 'debug voip ccapi inout' and attach it.  Also, attach a 'show call application voice mva'

From your description is sounds like your ccm server is not running on the pub, try adding new dial-peers for your subscriber servers, this will also add them to the ip address trust list on your 3925:

dial-peer voice 8001 voip

destination-pattern 8000

session target ipv4:10.0.2.4

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

preference 1

dial-peer voice 8002 voip

destination-pattern 8000

session target ipv4:10.0.2.5

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

preference 2

HTH,

Chris

View solution in original post

Hi Aldred,

It doesn't look like you've enabled H323 on the gateway.

Try:

interface gi 0/1

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.2.10

HTH,

Chris

Please rate helpful posts

View solution in original post

17 REPLIES 17
aldred.benedict
Beginner

Anybody?

Bradley Gruesbeck
Cisco Employee

Hi,

I've read over your question and I'm not quite understanding your numbering. The MVA number on CUCM is 8000 however you have your VoIP dial peer with the service listed as 1998 so I'm not sure what is going on there. If you do want to translate that number you'll need a voice translation rule/profile to do that.

If you changed your MVA service parameter to 1998, does that answer or not? It looks like you're close but those numbers don't seem correct.

Good luck,
Brad


Sent from Cisco Technical Support iPad App

Hello Brad,

Thanks for the reply. Well, to be honest, I am still kind of confused regarding the call flow of this method (hairpinning). I was just following tutorials in the internet - one of them is https://supportforums.cisco.com/thread/292868
Could you please verify if my understanding of the call flow is correct (described below)? If not please explain where I went wrong and the correct flow.

1. Remote caller dials to the DID (29391998). The provider passes the last 4 digits (1998) to the Voice Gateway (10.0.2.10).

2. As the Voice Gateway passes the extension (1998) to the CUCM to be handled (as protocol is MGCP).

3. In CUCM, I created a Route Pattern of 1998, which points to Route List, then Route Group and ends in a H323 Gateway (Device Name: 10.0.2.10 i.e. the voice gateway).

4. dial-peer voice 1998 voip will take handle the call which points to the script in CUCM (I'm confused over here too).

5. And then I got lost. I don't understand the significance of the other dial peer.

If I change the MVA DN to 1998, an error will be generated as I have already created a route pattern of 1998

Anyways, I forgot to write down 1 more step (Number 3 in the original post) that I made (

Go to Media Resources > Mobile Voice Access. Set MVA DN to 8000)

Okay I'm beginning to understand the flow after reading the SRND document. It's recommended in the SRND to use different DN for the MVA and the DID if hairpinning deployment model is used. So what you are saying is I have to translate 1998 to 8000 so that the dial peer 8000 voip with destination-pattern 8000 will be matched?

Hi Aldred,

Have you rebooted the gateway?  Sometimes that's required for the vxml application to work properly.  Also, is the call even getting to the H.323 gateway?  Run a 'debug voip ccapi inout' and attach it.  Also, attach a 'show call application voice mva'

From your description is sounds like your ccm server is not running on the pub, try adding new dial-peers for your subscriber servers, this will also add them to the ip address trust list on your 3925:

dial-peer voice 8001 voip

destination-pattern 8000

session target ipv4:10.0.2.4

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

preference 1

dial-peer voice 8002 voip

destination-pattern 8000

session target ipv4:10.0.2.5

voice-class h323 1

dtmf-relay h245-alphanumeric

codec g711alaw

no vad

preference 2

HTH,

Chris

View solution in original post

Hi Chris,

1) I have not rebooted the gateway. However, is it really necessary to reboot the gateway?

2) You mean run "debug voip ccapi inout" and try to call 1998 (the DID)? Will do it tomorrow

3) Tried "show call application voice mva" previously and the application loads successfully. But I will post the result tomorrow anyways.

4) True. 10.0.2.3 (Publisher) has no Call Manager service, only 10.0.2.4 and 10.0.2.5 (Suscribers) have Call Manager service activated. So all the dial-peers have to point to 10.0.2.4 and/or 10.0.2.5 and not 10.0.2.3? How about

"dial-peer voice 1998 voip"? Does it need to be pointed to the suscribers also?

5) Do I need to perform a called number translation pattern in the route pattern "1998"?

Hi Aldred,

It shouldn't be necessary but in some cases I've seen issues with vxml that were resolved after a reboot.  I would attempt to create matching dial-peers for all of your subscribers IP's (including the inbound ones for 1998 which I don't beleive are necessary) as I believe the examples you are working off of have the ccm service running on the publisher as well.  It is not necessary to do the number translation at this point, the documentation states it causes issues in multi-cluster environments.  Right now you just want to make sure you're routing the call to the correct gateway and being able to listen to prompts from the vxml script, you can worry about the call transfer/2 stage dialing after.

HTH,

Chris

Hi Chris,

So what I understand is the inbound dial-peer (1998 voip) does not need to point to suscribers but the outgoing dial-peer (8000 voip) should point to the suscribers. Is that right?

Regarding the translation, from what I understand from the call flow is the inbound call from the remote caller (who dialled 1998) will match the inbound dial-peer in the gateway and be redirected by the CUCM (through route pattern 1998) to the H323 Gateway, which is supposed to match the outgoing dial-peer 8000 voip. Without the translation, the call will not match the outgoing dial-peer, as the criteria to match is destination-pattern 8000. Without translating, the called number will not be 8000, right? Please explain.

Hi Aldred,

Yes, the 8000 voip should point to the subscribers.  The 8000 number will only call out if you attempt to do a two-stage dialing.  For now, once you add the subscriber outbound dial-peers (which is more than likely being blocked by the trust list), you should start to hear prompts to allow you to login with your remote-destination/PIN.   If you're still having issues, post the complete config as well as the previous debugs.

HTH,

Chris

Please rate helpful posts

Hi Chris,

Did what you told me to but still not working

I attached the following outputs:

1) sh ip addr trusted list

2) debug voip ccapi inout

3) sh call application voice mva

4) Gateway configuration file

5) some screenshots of the gateway

Also tried this:

voice service voip
  ip address trusted list
    ipv4 10.0.2.0 255.255.255.240

Same results

Additionally, debug voice application vxml application and debug voip dialpeer shows nothing at all

I don't know whether this matters or not, but the gateway IOS version is Version 15.2(3)T

One more thing, what's the difference between Mobile Voice Access Number (in Service Parameter) and Mobile Voice Access Directory Number (in Media Resources > Mobile Voice Access)? It appears in some tutorials, the Mobile Voice Access Number in Service Parameter is the number which the remote caller dials (in my case, 1998).

Hi Aldred,

It doesn't look like you've enabled H323 on the gateway.

Try:

interface gi 0/1

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.10.2.10

HTH,

Chris

Please rate helpful posts

View solution in original post

Hi Chris,

Ah I see. The tutorials I read do not include that command.

Will try that command later. Anyways, why 10.10.2.10? Do you mean the gateway IP address (i.e. 10.0.2.10)?

Yes, that's a typo on my part, use the gateways IP.

HTH,

Chris

Sent from Cisco Technical Support iPhone App

Create
Recognize Your Peers
Content for Community-Ad