cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
286
Views
15
Helpful
14
Replies
davec4351
Beginner

mwi status light not working with cme 8865 phones

Hello,

 

I have an interesting issue with my sip provider. I received the MWI status in the debug messages, however my phones do not light up for MWI. I have a stripped down configuration attached. I have heard its related to codecs, but I have my codecs in place. So perhaps someone can look at my config and potentially identify an issue that could cause the MWI from not lighting up on my sip phones. I am running CME only not CUCME.

 

Cisco IOS XE Software, Version 17.03.04a
Cisco IOS Software [Amsterdam], ISR Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 17.3.4a, RELEASE SOFTWARE (fc3)

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Change the DN 1002 to complete DID number and see if you are getting  the MWI working..

 

 



Response Signature


View solution in original post

14 REPLIES 14
Nithin Eluvathingal
VIP Mentor

When integrating with CUE, we have to create MWI on and OFF number.

 

I dont think, your Provider can turn on the MWI lights.

AFAIK there is nothing called CUCME, it was always call manger express (CME).



Response Signature


With sip-ua I have configured mwi unsolicited ,in the debug outputs I see the # of voicemails and message waiting set to yes. Sorry, I meant CUCM , I am only running CME

Roger Kallberg
VIP Mentor

Can you please explain what you mean by MWI in relation with your service provider? As @Nithin Eluvathingal wrote there are AFAIK no way that this could be controlled by the service provider for your phones.

If we’re missing the point here and you do have CUE for voice mail in your CME setup please provide us the details on that configuration.



Response Signature


There is no CUE, however my understanding that an unsolicited sip notify sets a flag on the mwi on the sip extension to trigger the mwi on/off status. My sip provider is call centric. 

I doubt that this will work as you have it envisioned. What I do think happens is that CME would consume the MWI info sent from your service provider, but it will not pass that along to your phone devices. It just does not work the way you think it does.



Response Signature


This post might be of help to clarify a few things. Maybe it could be possible to set the command for mwi-server to this to make it work, but I'm only wildly guessing here.

 sip-ua 
  mwi-server ipv4:<IP of SP MWI server> expires 3600 port 5060 transport udp unsolicited

 



Response Signature


I’ve tried with the ipv4 and dns options still no luck.

can you  share the Notify message and your dn ?  I assume that provide might be notifying your DID number.  and you might be using a 3 or 4 digit extensions.

 

 



Response Signature


That sounds quite plausible to me. Try turning on "debug ccsip mess" and see if you are getting NOTIFY messages.