cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1086
Views
5
Helpful
8
Replies
T_Daniel
Beginner

No ringback when transferring calls internally from PSTN, just silence until answered

Having a problem with a lack of ringback on transfered calls from the PSTN

 

Call flow is as follows

 

PSTN > FXO port on 2811 router > SIP Trunk > CUCM

 

when transferring internal calls ringback works as expected

 

when transferring calls from the PSTN between internal DNs the caller hears MOH while the transfer number is entered and then silence until the called phone picks up

 

I have searched the forums for a solution but can only find issues relating to h.323 

8 REPLIES 8
Vaijanath Sonvane
VIP Advocate

Please post the configuration of your router. Also, provide below information:

1. Is this issue happening for both blind transfer and consult transfer?

2. What is the version of CUCM?

3. What is the Phone Model and Protocol used?

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

1. During consult transfer the PSTN caller hears Music On Hold whist the "transferer" calls and speaks to the destination extemsion. I believe this is to be expected.

 

During blind transfer the PSTN Caller hears silence while the extension is ringing

 

2. CUCM version is 8.6.2.10000

 

3 Phone models are 8945 using SCCP

 

Voice Gateway config is attached

Please try any of these solutions:

  1. Configure the voice call send-alert Cisco IOS global configuration command in the terminating gateway/router.

    This command enables the terminating gateway to send an alert message instead of a progress message after it receives a call setup.

  2. Upgrade the Cisco IOS Software on the originating gateway/router to latest Cisco IOS Software Release.

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

Thanks for your suggestions

 

Ive added the voice call send-alert config. As far as I can tell this has had no impact.

 

The IOS version is 15.1(4)M12a. I can't find a more recent IOS.

 

Regards

 

Tom

Once the call is sent to CUCM, it's typically the CUCM that's responsible for providing a ringback tone to the caller on the other end. Make sure an Annunicator is available in the Media Resource Group List of the trunk or gateway. Also, try below configuration changes:

1.  Change the following Service Parameter (for Callmanager service) in CUCM and see if that helps:

'Send H225 User Info Message' parameter and set it to 'Use ANN for Ring Back'

2. Try below configuration:

voice service voip
 sip
  bind control source-interface Loopback0
  bind media source-interface Loopback0
  midcall-signaling passthru
!

If above configuration doesn't work, please post the logs for "debug ccsip messages" and "debug ccsip events"

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

The service parameter was already set to Use ANN for Ring Back.

 

Adding the command

midcall-signaling passthru

 doesn't seem to have made a difference

 

Ive attached the debugs, I've annotated them. with the different call stages (call answered, transfer initated, ect)

 

Thanks 

 

Tom

Hi Daniel,

In your router configuration, you have set up POTS lines cptone to GB (Great Britain). What is the network locale setup under device pool that is configured for IP Phones and Gateway? Can you try to match it and give it a try?

Also, I see that the codec between CUBE and phone is negotiated to G.729. Can you try setting up G711 codec?

 

 

Please rate helpful posts and if applicable mark "Accept as a Solution".
Thanks, Vaijanath S.

Network Locale is already set to United Kingdom on all device pools

 

Ive changed the codec to g711ulaw. That dosen't seem to have had an impact on the issue

 

Regards

 

Tom

 

 

Create
Recognize Your Peers
Content for Community-Ad