cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
1977
Views
5
Helpful
5
Replies
ahmed-hassan1110
Beginner

PCD cluster discovery problem

Dear Gents,

 

I’m trying to use PCD to migrate CUCM cluster from version 8.6 to 11.5, I did it with the same exact versions of all PCD, old CUCM and new CUCM and it worked just fine in one location, but when I’m trying to do the same in the current cluster the first step which is PCD discovery of the old CUCM cluster always fail with an error “login failed” as shown:

 

 

I tried later and installed the ciscocm.ucmap_platformconfig.cop file manually on both CUCM servers but result remains the same!!

 

I check the PCD logs and found the following:

“”””

CALLING ucmapLib::getFile {exp3 install platformConfig.xml PCD IP Address adminsftp /export/platformConfig/temp/}

FAILED ucmapLib::getFile, not valid username/password for sftp

2017-04-16 13:31:15,929 INFO  [DefaultQuartzScheduler_Worker-3] inventory.Migration.nodeDiscovery - downloadFile errorCode 123

2017-04-16 13:31:15,929 INFO  [DefaultQuartzScheduler_Worker-3] inventory.NatAddressHelper.getPublicIP - Application Node private IP Address is : 172.16.65.251

2017-04-16 13:31:15,929 INFO  [DefaultQuartzScheduler_Worker-3] inventory.Migration.nodeDiscovery - Return nodeDiscovery result 123

2017-04-16 13:31:15,929 INFO  [DefaultQuartzScheduler_Worker-3] scheduler.CustomJob.acquireLock - T77:TA78:N71 waiting for DB lock

2017-04-16 13:31:15,929 INFO  [DefaultQuartzScheduler_Worker-3] scheduler.CustomJob.acquireLock - T77:TA78:N71 acquired lock

2017-04-16 13:31:15,933 INFO  [DefaultQuartzScheduler_Worker-3] db.EntityBroker.updateNodeInfo - Updated 71 to v3

2017-04-16 13:31:15,933 INFO  [DefaultQuartzScheduler_Worker-3] scheduler.CustomJob.releaseLock - T77:TA78:N71 releasing DB lock

2017-04-16 13:31:15,933 INFO  [DefaultQuartzScheduler_Worker-3] scheduler.DiscoveryJob.executeJob - discovery node 71 failed with errorcode 123 as it is Failed to download 'PlatformConfig.xml' from the node CUCM_PUB_IP_Address  to sftpServer PCD IP Address

 

“””””

Here is the exact version used:

Old CUCM: 8.6

PCD: 11.5(3)

New CUCM: 11.5(1)SU2

 

So any clues to solve this issue ??

 

5 REPLIES 5
ahmed-hassan1110
Beginner

Just for the record, I have fixed the issue which was very weird.

Simply the password of the PCD was apparently too complex for the application to work properly, so when I re-installed the PCD again using a simpler password (for the admin and platform account) everything went smooth.

Not sure but you could have been running into the following bug

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCva98331/?referring_site=bugquickviewredir

HTH

Manish

Thanks Manish, but the mentioned bug is not related to the issue i have faced.

It was already fixed as described in my previous comment.

This worked for me, running on 11.6.  Literally changed a % character to a _ character in the PCD admin account password and discovery worked as expected.  I guess only certain special characters work.

Just in case anyone else hits this, it's not just the PCD password that PCD has issues with complexity.  It's for sure the ESXi host password as well... I found in 12.1(1) that some complex characters are supported but not all, and I had not been able to find any documentation stating what chars will work... but then today I ran into the following line in a log file:

............. has threat matching pattern .*('|--|;|<|>|\/\*).* returning escaped value: ..............

 

What I found was that any of the characters between the ( and ) in that line above are replaced by an _ by PCD.  So... until I am updated otherwise, there's your list of what characters DON'T work.  I have had a TAC case open on this for a while, with TAC simply advising to try simpler passwords.  Not always possible, when you don't control the ESXi/vCenter you are connecting to.

Content for Community-Ad

Spotlight Awards 2021