Showing results for 
Search instead for 
Did you mean: 
Walkthrough Wednesdays

#### Personal Communicator & CUP problem###


In our lab we have a CUCMv7+CUPv7+Active Directory with DNS.

We have a problem that we do the configuration from the ( Integration Guide for CUP pdf ), but when we open the

Personal Communication the status is offline and we cant do any call, beside that the personal communicator dont register with CUCM.

please its critical to me,,,,,


I have been having fun with presence recently. I found the following were needed.

full DNS name resolution of the cups server need.

Digest credential for the user in CUCM are needed by default(can be disable). Enter anything you like.

LDAP name and Cisco ID need to be the same. If you use the line number for the Cisco ID you need to change Presence to point to ipPhone instead of teh default and ensure in AD that ip phone is teh same number.

I also have the "Deploying Cisco Unified Presence" book. It has lots of useful info for getting Presence working. Worth buying to help get things running.

So I guess you did get it working, in the end.

I'm fighting with a lab setup which is getting my hair sparser :-/

The documentation is light to say the least. I have all greens in troubleshooter, and in CUPC health, but state is stuck at offline. And mode only changes next time you log on. (I.e. you select softphone from desktop and it stays in desktop, but reopen CUPC and

you are in softphone).

Also, using another SIP client to look into the presence info reveals that presence status is being delivered by CUPC, it just is not listening to it somehow. I'll try that book, thanks for the tip.

Md. Mijanur Rahman

Under Cisco UP SIP Proxy, put the correct Proxy domain and also check Federation Routing CUP FQDN at the bottom. Don't forget to edit your host file/add entry at your AD against that FQDN, you can manually ping the hostname.

If you are running VM, a border end solution i can advice (as it worked for me, don't know how!), reboot your server.

Double check your CTI Gateway Profile and users associations.

I'm kind of confused about what is the "correct" domain. But anyway, is there a way to force CUPC not to use TLS, so I can trace the messages ?

I'm not using AD now, but I tried that and I have the same issue. It has to be something stupid, I know.

Like the gateway user not having CTI priv. Is it necessary to associate all devs or the all devices priv will do ?



Content for Community-Ad

Spotlight Awards 2021