cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
10319
Views
0
Helpful
10
Replies

Plantronics Savi 740 and IP Communicator?

We are using Plantronics Savi 740s (wiress headsets) connected to the PC via USB and IP communication 8.6.1.  The problem is that the Savi is not consistently answering the phone when it rings even though it has been set to default to the PC.  You often have to tap the answer on the headset AND press the ANSWER on the softphone.  Has anyone else seen this or determined a cause/solution?

10 REPLIES 10
sunildsouza
Beginner

Can you check if you have installed the latests version of Plantronics SPOKES software on your PC. This can be downloaded from the link provided below.

http://www.plantronics.com/us/support/software-downloads/business-windows.jsp

This software will tell the the headset that the softclient is ringing and it needs to pick up the call.

Also have you configured it for single number teach - both the deskphone and IP Communicator rings when someone call you?

If that is the case then the Savi 740 pics up the module (deskphone or softclient) which rings first. Based on the delays in the USB or phone messaging it might vary on a call by call basis. We suggest users to noy use the Savi 740 in this configuration because it gives rise to unpredictibility.

In this case, single number reach is not applicable - the number exists only on the soft phone.  It seems however, that which one rings first should be irrelevant because the "answer" is only coming from the headset control (or should be) so it should still work no matter who rings first. 

In any case, I determined that the number in question was the second line on the phone and for whatever reason, the headset will respond to the first line, but not the second (consistently).  By flipping the numbers so the second number appears as the first line on the phone, I was able to make this function as desired.  It would be better if it would respond to ANY line ringing on the phone, but it doesn't appear to do that  Now if only the button could also take the phone off-hook for dialing it would be almost perfect!

As a follow-up.  This still does not consistently work.  The user extension (and the UCX extension) only appear on the softphone.  There is no mobility function enabled.  On some desktops the combination of the softphone and the Savi 740 work flawlessly, on others it requires that the user answer the call by pressing the headset button AND the softphone answer button - pressing just one of those fails to connect the call.  And pressing the headset button alone never allows the softphone to go off-hook in these cases.  It's as iff the off-hook signal never reaches the softphone client.  On some desktops this is not an issue and the phone answers as expected.

Installing the Savi software makes no difference whatsoever.  Changing the settings under Windows as to whether or not the Savi is the default communications device can affect the ability for audio to stream (or not) but it doesn't seem to affect the off-hook situation.

The Savi appears to use the defauls USB audio driver, and the glitch really seems to be that the Windows layer somehow isn't handing off the off-hook message to the Cisco softphone, but I can't quite pinpoint it to correct it.  Regular audio sources flow to/from the Savi just fine, but the on-hook/off-hook messages are failing to flow consistently.

Anyone who has seen anything like this - the input is appreciated!  As it is, needing to hit the on-screen button to go off hook kind of defeats the purpose of a wireless headset!

Chris,

Can you please go to the audio tuning wizard of Cisco IPC and make sure that Handset, Headset and Speakerphone are all pointing to the Savi 740? IP Communicator consideres the USB port (using which Savi connects to PC) as the handset port. It considers the headset interface to be the soundcard - dual 3.5mm jacks. Also please do not use the headset icon on the IP Communicator since it will route the audio to the sound card.

Please let us know if this solves the problem.

I have done this before – most of these things you have suggested so far are pretty straightforward and I have tried them multiple times already. But to confirm, I just ran it again and it does not correct the problem.

Chris,

Can you please provide me your email address? I will reach out to you directly and help you your problem.

Thanks.

Sunil

Sunil, I am having the exact same problem and can't figure out how to resolve it. Can you help?

Joe,

I'm sorry you are having problems. Have you tried posting this question to the Cisco Support Community

(https://supportforums.cisco.com/index.jspa)? It is a great resource for this kind of issue, and there are a number of posts relating to this topic. If you are not able to resolve your issue, another option is to open a ticket with the Cisco Technical Assistance Center (www.cisco.com/go/support) to get expert debugging assistance.

Hope that helps,

Kelli Glass         

Moderator for the Cisco Collaboration Community


Kelli, thanks for the info. I've searched the supportforums.cisco.com site and can't find an answer to my problem. When I went to the cisco.com/go/support site it says that we need a service contract to open a ticket?

Christopher,

A couple of quick ideas from a Plantronics point of view.

 

1) Make sure your W740 is set to default to the Computer.  Out of the box the default is the Desk Phone.  There are three buttons on the top of the Savi base Desk Phone, Mobile Phone and Computer.

With the system idle, you can change your default line to Computer by pressing the desired base button (Computer) until it flashes green four times.You can also change the default line using the Plantronics Control Panel by going to  Start > Programs > Plantronics > Plantronics Control Panel > Device Settings > Base.

Check to see what the W740 is set to by pressing Call Control button (on headset).  The Computer button will light if it has been changed to default.

  

2) Make sure you have the latest Plantronics Spokes Software http://www.plantronics.com/us/support/software-downloads/

3) Check out the Plantronics User Guide for installation and other details http://site.theheadsetteam.com/plantronics_savi_w700_series/savi_w740_user_guide_83542-01_8354201.pdf

  

4) You can also contact Plantronics TAC 800-544-4660 Press 5 and then extension 5538.  They can troubleshoot or provide a warranty replacement if under warranty.

Allen

Create
Recognize Your Peers
Content for Community-Ad