cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
4167
Views
0
Helpful
8
Replies
Vladimir Stankov
Beginner

Presence 8.6 federation with Google Talk - one way IM

Presence: 8.6.3.10000-20

Cisco Jabber for Windows: 9.0(5)

The system is configured for federation with Google talk but I can only send messages from Cisco Jabber to gtalk. The other way around is not working and presence status is not exchanged. In the XMPP Federation Connection service log I see the following message:

11:29:20.324 |XMPPSinTranscoder{245D05732}: New inbound connection from 74.125.186.18 authenticated as: gmail.com. Using SSL: No

11:29:20.536 |XMPPSinTranscoder{245D05732}: Got a stanza for a host which is not local (telelink.com) from <user>@gmail.com. Disconnecting connection.

11:29:20.536 |XMPPSinTranscoder{245D05732}: Connection for gmail.com is gone.

My internal domain is telelink.bg (accordingly the IM address is user@telelink.bg) and the outside domain is telelink.com. The e-mail address is user@telelink.com and I have configured the option: Enable use of Email Address when federating, but still this is not working.

Any ideas why this is happening? Am I missing something in the configuration?

Best Regards,

Vladimir

8 REPLIES 8
gmantovani
Enthusiast

Hi Vladimir,

you have to follow these steps on the CUP Server:

1) Stop the following services:

- Cisco UP SIP Proxy (Control Center - Feature Services)

- Cisco UP Presence Engine (Control Center - Feature Services)

- CIsco UP XCP Router (Control Center - Network Services)

2) Change the following parameter:

System-> Cluster topology -> Settings -> Domain Name

change it from telelink.bg to telelink.com and save

3) Start the following services:

- Cisco UP SIP Proxy (Control Center - Feature Services)

- Cisco UP Presence Engine (Control Center - Feature Services)

- CIsco UP XCP Router (Control Center - Network Services)

Please let me know if it solve!

Best Regards,

Giordano

Hi Giordano,

thanks for your suggestion. I thought of that, but the problem is that all IM addresses change on the server side but not in the user side hence the user must re-add all users once again. I think this would work but I have postponed it till now - I hadn't had a chance to deep more on the underlying issue - Enable use of Email Address when federating option.

Regards,

Vladimir

Hi,

do you have a link to the walkthrough in setting up this federation perhaps? I can't find a decent resource anywhere.

Hi,

I've used the official configuration guide:

http://www.cisco.com/en/US/docs/voice_ip_comm/cups/8_6/english/integration_notes/Federation/CUP_8.6_Interdomain_Federation.html

Don't know about other resource.

Regards,

Vladimir

Hello,

I've the same issue regarding XMPP federation with Google Talk, as our internal domain name (the one configured as domain name in CUP Topology) does not match the external ones (in email address of users). I can send message to Gtalk users from Jabber but when message are coming from Google then I've got this message:

15:42:01.999 |b456db90| debug| XMPPSinTranscoder{112710D0F0} [IN PACKET]

from='xxxx.yyy@gmail.com/gmail.B5C4969C'

id='137'

to='zzzz.zzzzz@external-domain.fr'

type='get'>http://jabber.org/protocol/disco#info'/>

15:42:01.999 |b456db90| error| XMPPSinTranscoder{112710D0F0} Got a stanza for a host which is not local (vicat.fr) from

xxxx.yyyy@gmail.com/gmail.B5C4969C. Disconnecting connection 15:42:01.999 |b456db90| debug| XMPPSinTranscoder{112710D0F0} [IN PACKET] from='xxxx.yyy@gmail.com/gmail.B5C4969C' id='137' to='xxxx.yyyy@external-domain.fr' type='get'>http://jabber.org/protocol/disco#info'/>
15:42:01.999 |b456db90| error| XMPPSinTranscoder{112710D0F0} Got a stanza for a host which is not local (vicat.fr) from xxxx.yyyy@gmail.com/gmail.B5C4969C. Disconnecting connection

(I have hidden the real user/domain in the trace)

How to instruct the CUP server that it should accept a list of external domain aliases ?? We have several external domain names in our email addresses (large LDAP AD) like any large company with several entitiies.

So I guess there is a solution !

Thank you for your feedback,

Regards,

Christophe

Hi Cristophe,

probably you can achieve that in this way:

1) Populate the e-mail field for every Jabber user;

2) Enable use of Email Address when Federating on the CUP (Presence -> Setting);

3) Add all the external domain aliases on the CUP (Messaging -> Group Chat Server Alias Mapping);

4) Reload the main CUP Services.

Regards,

Giordano

Hi Giordano,

I've tried your configuration suggestion, but the problem is still there. The Group chat server Aliases do not seems to have an effect on dynamic chat rooms.

On log files I could see those messages tht make me think the aliases are well configured:

10:20:14.201 |b3bffb90| debug| SSCommandProcessor.cpp:1116 Found a local host: conference-2-standalonecluster878bf.xxx.intra

10:20:14.201 |b3bffb90| debug| SSCommandProcessor.cpp:1116 Found a local host: conference-2-xxxx-cup-emea.xxxx.intra

10:20:14.201 |b3bffb90| debug| SSCommandProcessor.cpp:1116 Found a local host: fridapbx07-xmpp.xxxx.fr

10:20:14.201 |b3bffb90| debug| SSCommandProcessor.cpp:1116 Found a local host: fridapbx07-xmpp.xxxx.com

I've added 2 aliases, 1 for my external domain xxx.fr and the other one xxx.com  (real names hidden)

But I've still the error message on incoming XMPP for xxx.fr

BUT,the news is that incoming XMPP are working for my other external domain xxxx.com and the only configuration parameter that explain that is that I've configured this domain xxx.com in :

Service Parameters/PUBLISHER NODE/Cisco UP SIP Proxy/Federation Routing Parameters (Clusterwide)/

When I have incoming XMPP message for this domain, I can now see those logs:

10:00:13.628 |b4521b90| debug| XMPPSinTranscoder{245CD2D0C} [IN PACKET] from=xxxx.yyyy@gmail.com' to='testfr1.xxxx@xxxx.com' type='subscribe'/>
10:00:13.628 |b4521b90| debug| SSCommandProcessor.cpp:1235 Incoming packet: from=xxxx.yyyy@gmail.com' to='testfr1.xxxx@xxxx.com' type='subscribe'/>
10:00:13.628 |b4521b90| debug| SSCommandProcessor.cpp:2045 swapForJid
10:00:13.628 |b4521b90| debug| SSCommandProcessor.cpp:3103 _getJidFromMap - check map for testfr1.xxxx@xxxx.com
10:00:13.629 |b4521b90| debug| SSCommandProcessor.cpp:3110 _getJidFromMap - found 330101@xxxx.intra
10:00:13.629 |b4521b90| debug| SSCommandProcessor.cpp:2087 swapForJid - setting the to field as 330101@xxxx.intra
10:00:13.629 |b4521b90| debug| SSCommandProcessor.cpp:2092 swapForJid - checking if this is a muc packet
10:00:13.629 |b4521b90| debug| SSCommandProcessor.cpp:2234 checkMuc - this is not a MUC packet.
10:00:13.629 |b4521b90| debug| SSCommandProcessor.cpp:1255 Incoming packet after swap: from=xxxx.yyyy@gmail.com' to='330101@xxxx.intra' type='subscribe'/>

As you can see, the CUP is correctly doing the lookup and the swap of the JID to the internal domain name xxx.intra !

But if the email address of the the CUP user is on xxx.fr, I still have those error messages:

09:58:40.579 |b45a1b90| debug| XMPPSinTranscoder{62E591310} [IN PACKET]

from=xxxx.yyyy@gmail.com/gmail.B5C54343'

id='108'

to=xxxx.yyyy@xxx.fr'

type='get'>http://jabber.org/protocol/disco#info'/>

09:58:40.579 |b45a1b90| error| XMPPSinTranscoder{62E591310} Got a stanza for a host which is not local (xxxx.fr) from

xxxx.yyyy@gmail.com/gmail.B5C54343

. Disconnecting connection.

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:245 got a request to close

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:265 Enqueuing close request to socket thread

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:285 Got a _close request. 2

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:299 Writing our and waiting. 2

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:338 _doneClose

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:1343 onClose. XML Stream is gone. 0

09:58:40.579 |b45a1b90| debug| XMPPStream.cpp:1368 Firing onClose event

09:58:40.579 |b45a1b90| info| XMPPSinTranscoder{62E591310} Connection for gmail.com is gone.

09:58:40.579 |b45a1b90| debug| XMPPSinTranscoder{62E591310} Notifying SSCP that inbound connection gmail.com is gone.

So, do you confirm that the parameter that makes it work for the domain xxx.com is the service parameter in CUP SIP Proxy, but that means I cannot handle several external domain names for my users ??

Thank you for your help !

Regards,

Christophe

Just for information, the solution to my initial problem was to configure the Federation Routing CUP FQDN with the same name as the public defined DNS record: in my case presence.telelink.com. The internal SIP domain remains telelink.bg. In this way the federation with gtalk works.

Best Regards,

Vladimir

Content for Community-Ad

Spotlight Awards 2021