cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

AMA-CUCM Troubleshooting: Best Practices for Reading Trace Files

29463
Views
16
Helpful
17
Replies
Explorer

Problems with SIP Trunk (one way audio)

Hi everyone !

Our client is testing a new SIP trunk implementation with a different ISP.

They have a SIP trunk between a Cisco 2911 and ISP for PSTN accesss, and a H323 Trunk between CUCM ver 7.1.3.30000-1 for proper call routing to that Cisco2911 gateway.

Here you have Cisco 2911 configuration:

VoiceGW-B#sh runn
Building configuration...


Current configuration : 9341 bytes
!
! Last configuration change at 19:09:50 AST Thu Jan 24 2013 by admin
!
version 15.0
service nagle
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname VoiceGW-B
!
boot-start-marker
boot-end-marker
!
card type t1 0 0
enable secret 5 $1$T05j$vJkR0V2l2/Iu1mIIeVPcu1
!
no aaa new-model
clock timezone AST -4
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
ip domain name domain.local
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol t38 nse force ls-redundancy 0 hs-redundancy 0 fallback pass-through g711ulaw
h323
sip
  min-se 90
  header-passing
  early-offer forced
  midcall-signaling passthru
!
voice class codec 333
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class codec 2
codec preference 2 g711ulaw
codec preference 3 g711alaw
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
!
!


!
!

!
redundancy
!
!
controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24 service mgcp
description SF 137-6042 primary (redundante GWY-A 137-6041)
!
!
!
!
!
interface Loopback0
description ** USED FOR IPT, ROUTING, MANAGEMENT ETC... **
ip address 192.168.100.11 255.255.255.255
no ip redirects
no ip proxy-arp
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.100.11
!
interface GigabitEthernet0/0
description ISP SIP trunk
ip address 120.100.11.135 255.255.255.128
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
description *** P2P to 4506 Core A ***
ip address 192.168.101.6 255.255.255.252
no ip redirects
no ip proxy-arp
duplex auto
speed auto
!
interface GigabitEthernet0/2
description *** P2P to 4506 Core B ***
ip address 192.168.101.14 255.255.255.252
no ip redirects
no ip proxy-arp
duplex auto
speed auto
!
interface Serial0/0/0:23
description ** D Channel ISP_2 **
no ip address
encapsulation hdlc
isdn switch-type primary-dms100
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
!
router eigrp 100
network 192.168.100.11 0.0.0.0
network 192.168.101.6 0.0.0.0
network 192.168.101.14 0.0.0.0
passive-interface default
no passive-interface GigabitEthernet0/1
no passive-interface GigabitEthernet0/2
eigrp stub connected summary
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
ip http path flash:/GUI
!
ip route 120.100.0.0 255.255.0.0 120.100.11.129
!
logging 10.2.173.5
access-list 1 permit 192.168.5.0 0.0.0.255
!
!
!
!
!
!
!
!
!
!

control-plane
!
!
voice-port 0/0/0:23
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/0/4
!
voice-port 1/0/5
!
voice-port 1/0/6
!
voice-port 1/0/7
!
ccm-manager redundant-host 192.168.4.11
ccm-manager mgcp
ccm-manager music-on-hold
!
mgcp
mgcp call-agent 192.168.4.12 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp ip qos dscp cs3 signaling
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface Loopback0
mgcp bind media source-interface Loopback0
!
mgcp profile default
!
!
dial-peer voice 10 pots
service mgcpapp
port 1/0/0
!
dial-peer voice 11 pots
service mgcpapp
port 1/0/1
!
dial-peer voice 12 pots
service mgcpapp
port 1/0/2
!
dial-peer voice 13 pots
service mgcpapp
port 1/0/3
!
dial-peer voice 14 pots
service mgcpapp
port 1/0/4
!
dial-peer voice 15 pots
service mgcpapp
port 1/0/6
!
dial-peer voice 17 pots
service mgcpapp
port 1/0/7
!
dial-peer voice 16 pots
service mgcpapp
port 1/0/5
!
dial-peer voice 3001 voip
tone ringback alert-no-PI
description *** Testint ISP OUTGOING FOR LOCAL CALLS ***
translation-profile outgoing DN-to-E164-srst
preference 10
destination-pattern 12122067379
session protocol sipv2
session target ipv4:120.100.1.10
dtmf-relay rtp-nte digit-drop
codec g711ulaw
no vad
!
dial-peer voice 9004 voip
description ** TO CM PRIMARY FOR DID piloto **
preference 1
destination-pattern 1358
session target ipv4:192.168.4.11
voice-class codec 1
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 9005 voip
description ** TO CM Secondary FOR DID piloto **
preference 2
destination-pattern 1358
session target ipv4:192.168.4.12
voice-class codec 1
dtmf-relay h245-alphanumeric
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 999 voip
description SIP INCOMING DIALPEER
incoming called-number .
dtmf-relay rtp-nte
codec g711ulaw
!
!
num-exp 12126169799 1358
num-exp 2122067379 12122067379
gateway
timer receive-rtp 1200
!
!
!
gatekeeper
shutdown
!
!

=====================

Well we can establish incoming and outgoing calls without any problem during this testing stage, but we only get incoming voice.

We did not get outgoing voice to Voice Gateway.

We checked with ISP, and we see RTP traffic from ISP to Cisco 2911Voice Gateway, but we did not see any RTP packets from Voice Gateway to ISP.

As a matter of fact, we did not see any RTP packets arriving to Voice gateway from internal network.

Could be a routing problem???

Do Internal CUCM and Ip Phones require  routing access to ISP's SIP server? As I understood internal devices only need to know how to arrive to Cisco2911 Voice gateway, so it can work as a Proxy and route traffic towards SIP server???

Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
Explorer

Problems with SIP Trunk (one way audio)

In addition to Chris comments,

1. There is a routing problem : IP Phones should see the route to the ISP, even if they are inside a NAT.

2. If You want that :

        - IP Phones just reach the 2911 and the 2911 IP addresse presents the call to the ISP.

        - the Loopback0 bring the H323

        - And the int GigabitEth 0/0 for the SIP

    then

        Configure the 2911 as a CUBE in flow-through mode

        Use redirect ip2ip

        Configure dspfarm on the 2911

3. Check also this :

    If You did not see any RTP packets from Voice Gateway to ISP

    Then

     - Check if the session transport with the ISP is TCP or UDP.   

     - Configure a CME on the 2911 to check the communication between the {2911 and ISP} and {2911 and CCM}

Regards,

Antra

17 REPLIES 17
Hall of Fame Master

Problems with SIP Trunk (one way audio)

You need to bind your control and media SIP traffic to proper interface, either do this under SIP global command or on individual SIP dial-peers that point to the ISP.

Chris

Explorer

Problems with SIP Trunk (one way audio)

Chris, thanks for your fast answer.

This configuration that you are recommending would be on Cisco Gateway or in CUCM ??

I really appreciate your help !

Hall of Fame Master

Problems with SIP Trunk (one way audio)

Gateway. Global config is:

voice service voip

sip

  bind control source-interface Loopback0

  bind media source-interface Loopback0

dial-peer (if sufficient IOS):

dial-peer voice 1 voip 

voice-class sip bind control source-interface GigabitEthernet0/1

voice-class sip bind media source-interface GigabitEthernet0/1

HTH, please rate all useful posts!

Chris

Highlighted
Enthusiast

Problems with SIP Trunk (one way audio)

To elaborate on Chris's response,

You need to make sure that the signaling and RTP packets are routable by the service provider and by the gateway.

So you should bind the signaling and media as stated above, and also ensure that the Lo0 IP is reachable by your SIP provider.  Without this, it's possible that you were sending RTP from a different GW interface IP than you expected.

From your description of which packets are missing, you may not have a route to the IP address required for the RTP stream, or there might be a firewall or ACL blocking your outbound RTP stream somewhere. 

Lastly, if you're using private IP space for your phones make sure that your RTP stream must pass through the CUBE, not flow-around.  I think flow-thru is the default.  But if your system is telling the phones to send direct, I would bet that your firewall is blocking the traffic.

Explorer

Problems with SIP Trunk (one way audio)

Chris, only to be sure:

a) when you say:

dial-peer voice 1 voip

You are talking about dial-peer against my SIP provider?? On my case "dial-peer voice 3001 voip"

b) When you say

voice-class sip bind media source-interface GigabitEthernet0/1

"GigabitEthernet0/1" is the interface connected to ISP, on my case: "interface GigabitEthernet0/0" ????

As I was not sure, I only configured these bind commands under "sip", and the SIP trunk went down, although we got the following output from "show sip-ua status":

Oneil-VoIP-GWY-B#sh sip-ua status
SIP User Agent Status
SIP User Agent for UDP : ENABLED
SIP User Agent for TCP : ENABLED

SIP User Agent for TLS over TCP : ENABLED
SIP User Agent bind status(signaling): ENABLED  192.168.100.11
SIP User Agent bind status(media): ENABLED  192.168.100.11
SIP early-media for 180 responses with SDP: ENABLED
SIP max-forwards : 70
SIP DNS SRV version: 2 (rfc 2782)
NAT Settings for the SIP-UA
Role in SDP: NONE
Check media source packets: DISABLED
Maximum duration for a telephone-event in NOTIFYs: 2000 ms
SIP support for ISDN SUSPEND/RESUME: ENABLED
Redirection (3xx) message handling: ENABLED
Reason Header will override Response/Request Codes: DISABLED
Out-of-dialog Refer: DISABLED
Presence support is DISABLED
protocol mode is ipv4

SDP application configuration:
Version line (v=) required
Owner line (o=) required
Timespec line (t=) required
Media supported: audio video image
Network types supported: IN
Address types supported: IP4 IP6
Transport types supported: RTP/AVP udptl

THANKS  A LOT for your help

Explorer

Problems with SIP Trunk (one way audio)

Chris and Vivien

THANK YOU for your support !!

The command on dial-peer is not supported.

I changed the command under sip configuration to this:

bind control source-interface GigabitEthernet0/0

bind media source-interface GigabitEthernet0/0

Because GigabitEthernet0/0 is the interface connected to ISP SIP trunk, and the SIP trunk started up !!!

But the one way voice problem continues.....

During these new tests, thanks to "debug voip rtp"  command we detected what happen to rtp traffic generated by internal Ip Phones............it is going to another Gateway that connect to an old SIP trunk with diferent ISP !!!

As our new Voice Gateway s in testing stage, we have not include it into CUCM's Route Group for PSTN calls, we only configured a test Route-Group and test-router pattern for use of our new Voice-Gateway.

Could this be the origen of our problem ???

Please let me know if you need more information and again thanks

Hall of Fame Master

Problems with SIP Trunk (one way audio)

So, is the call making it to the GW (CUBE)?

Can you do "debug ccsip messages"?

As to the command not being available on the dial-peer it means that your IOS is not recent enough for it as this was added in one of the 15.1 versions I believe.  What version are you running?

Chris

Explorer

Problems with SIP Trunk (one way audio)

Cisco CISCO2911/K9 (revision 1.0) with 475136K/49152K bytes of memory.

Processor board ID FTX1402AKAY

3 Gigabit Ethernet interfaces

24 Serial interfaces

1 Channelized T1/PRI port

8 Voice FXS interfaces

DRAM configuration is 64 bits wide with parity enabled.

255K bytes of non-volatile configuration memory.

254464K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:

License UDI:

-------------------------------------------------

Device#   PID                   SN

-------------------------------------------------

*0        CISCO2911/K9          FTX1402AKAY

Technology Package License Information for Module:'c2900'

----------------------------------------------------------------

Technology    Technology-package          Technology-package

              Current       Type          Next reboot

-----------------------------------------------------------------

ipbase        ipbasek9      Permanent     ipbasek9

security      None          None          None

uc            uck9          Permanent     uck9

data          None          None          None

Configuration register is 0x2102

Thanks again for your help.

I am not sure if you read on my last comments, but during debug testing we detected that all rtp traffic from Ip Phones is going to ANOTHER voice gateway (with similar configuration than mine but connected to a different ISP with a SIP trunk, connection between this gateway and CUCM server is through a H323 trunk).

I hope this can help !

Enrique Villasana

Explorer

Problems with SIP Trunk (one way audio)

Hi chris ! thanks for your reply.

I am sendinf an email with output of "debug ccsip messages"

But as I have told to Antra, the problem is allways the same, although I can establish incoming/outgoing calls through this voice gateway link ( CUCM---> h323 Trunk --> VoiceGateway --> SIP trunk --> ISP ), all rtp traffic from internal Ip Phones goes to other voice gateway which has another SIP trunk with a different ISP.

I really appreciate your support !!

Explorer

Re: Problems with SIP Trunk (one way audio)

Hi chris !!

Sorry for my late answer.

I am attaching the file "debug ccsip messages" as you required.

I am also attaching other file (debug OLD voice gw.txt) , in order you can see how all rtp traffic which is supposed to go to my voice gateway is going to a different voice gateway with another SIP trunk to a different ISP (our client is currently using this voice gateway)

As you can understand this new debug

    •a)      192.168.4.50 different voice gateway Ip address

    •b)      192.168.100.11 my voice gateway Ip address.

    •c)      192.168.5.37 Ip Phone’s Ip address

I hope this can help

And THANKS again !!!

Enrique Villasana

Explorer

Problems with SIP Trunk (one way audio)

In addition to Chris comments,

1. There is a routing problem : IP Phones should see the route to the ISP, even if they are inside a NAT.

2. If You want that :

        - IP Phones just reach the 2911 and the 2911 IP addresse presents the call to the ISP.

        - the Loopback0 bring the H323

        - And the int GigabitEth 0/0 for the SIP

    then

        Configure the 2911 as a CUBE in flow-through mode

        Use redirect ip2ip

        Configure dspfarm on the 2911

3. Check also this :

    If You did not see any RTP packets from Voice Gateway to ISP

    Then

     - Check if the session transport with the ISP is TCP or UDP.   

     - Configure a CME on the 2911 to check the communication between the {2911 and ISP} and {2911 and CCM}

Regards,

Antra

Explorer

Re: Problems with SIP Trunk (one way audio)

We moved reference interface for H323 gateway on router from loopback0 to a physical interface (using a different Ip address), and the problem was solved.

We supposed the root problem was a routing issue from Ip phones' networl  to loopback0's Ip address , but once we moved H323 Interface all rtp traffic started to go toward our new Voice Gateway. !!!

Thanks Antra and all of you for your very useful information.

Best regards

Beginner

Problems with SIP Trunk (one way audio)

Hi, I have a similar problem, but more config related.

I was wondering if your implementation is in Australia?

As I wanted to compare your config with mine.

Explorer

Problems with SIP Trunk (one way audio)

Hello,

I  already experience this issue.

1. Configure properly the Media Termination point

2. Or Configure a CUBE if it doesn't works

Try this first

=============

conf t

voice rtp send-recv

voice service voip

h323    

  no h225 timeout keepalive

==============

If it doesn't work then configure the 2911 to be a CUBE => This solution works all the time.

Regards,

Antra

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards