cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1128
Views
10
Helpful
12
Replies
Dilyan Dimov
Beginner

"Database communication error" after Unity 11 fresh install

Hello everyone!

I have a brand new environment where the CUCM was installed few days ago and now I'm installing the Unity but immediately after the installation I'm getting "Database communication error" when trying to login to the Web! It is the latest v.11 SU2 available at the moment - UCSInstall_UCOS_11.0.1.22900-14.sgn.iso

Any thoughts?

12 REPLIES 12
Suresh Hudda
Rising star

Do you see any error when you login into it via CLI (ssh) ?

Is it CUC cluster of 2 nodes ?

Suresh

Single server so far (this is the publisher). No errors in the CLI.

Dilyan Dimov
Beginner

So, it seems this is a bug. When applying the patch together with the fresh installation, the system will end up with the DB error.

I've reinstalled it couple of times always using the same settings and finally I've made it work after clean 11.0 install and then applying the patch through the Web.

I'll leave this topic just in case if someone else hit the same issue.

Thanks for updating here Dilyan, +5 :-)

Suresh

Rob Huffman
Hall of Fame Community Legend

Hi Dilyan,

As Suresh nicely noted, thank you for providing an update to this thread! If you get a moment, I was wondering if you might add the Bug ID for this problem.

Cheers!

Rob

Rob, I don't have it and I didn't open a TAC case as I was able to workaround it. Honestly I don't think that there is such a bug reported yet as the ISO is available for 2 weeks only.

Rob Huffman
Hall of Fame Community Legend

Hi Dilyan,

No worries my friend! I'll keep an eye on the Bug Search Tool over the next while to see what pops up. If I see the related Bug I'll add it to this thread. Thanks again for your kind follow up here.....much appreciated! Glad you got things working. (+5)

Cheers!

Rob

Hi Dilyan,

can you paste the output of "utils service list" from CUC where you are seeing this error.

JB

I don't have it anymore as the system is already working. But I did that when I faced the problem initially and I remember the database was up!

Great you were able to work with TAC for resolution.

Historically you would see "Database communication error" when "A Cisco DB" is down there can be multiple reasons why that can happen.

  • This issue generally occurs when any modification is done with the hostname or the IP address of the CUCM \ Unity. However, the error code and the types or error may depend on situations.

  • It may also arise when the "sqlhosts" file is either corrupt or any process tried to modify the file and failed to do so. In order to check if it is due to the corrupt/missing-entries of sqlhosts file, you can try bringing the informix up manually and it shows sqlhosts file in the error message.

  • Another possible reasons for A CIsco DB to go down may be the change of security password. If you are using CUCM/CUC 8.x/10.x you might want to refer one of these bugs:

below is one of the many BUG open for these issue.

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCup30002/?reffering_site=dumpcr

JB

JB, no offense my friend, but I would advise you to read everything once again.

Tl;dr:

- This is a brand new installation of the very first Unity server - no cluster, no data migration, no password changes!

- The problem occurs ONLY if you upgrade the server together with the fresh installation - you know that step where it is asking you if you want to apply any patches...

- If you install the system with clean 11.0 and upgrade it afterwords, there is no such problem - this is how I workaround it.

- And the last but no least - as I mentioned few posts above, I didn't open a case with the TAC because I was able to workaround it by myself.

Be well!

Hi Dilyan,

My bad i missed on the part that you fixed it yourself, regarding the explanation i wanted it to be documented so that people can refer it for "Database communication error" issue.

JB

Content for Community-Ad

Spotlight Awards 2021