cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

1213
Views
1
Helpful
2
Replies
Highlighted
Beginner

SalesForce TroubleShooting

Hi,

I'm testing out the Unified CRM connector (7.52) for SalesForce. What we would like are for our sales force users (both call center agents and non-callcenter agents) to be able to have the screen pops and make calls from sales force.

I went through the implementation guide, installed the server, changed the config.ini, and installed the salesforce adapter. When I log into salesforce I can see a login box for agentID, password, extension.

Environment:

CUCM - 6.1.4

UCCExpress - 5.0(2) SR1

Question/Problem #1 - I'm not able to log in using my CAD credentials withing salesforce. Its doesn't give any errors on the page. Anyone have or know of a troubleshooting document? I posted some of my logs below.

Question #2 - What I'm seeing so far seems geared towards the call center agents, is there something different for standard users that are not cisco agents? We'd like them to be able to get the screen pops as well.

Question #3 - Anyone know how to use the Null Connector? The implementation guide has a whole section on how to set it up, but nothing on how to actually use it.

Below are some log entries that I'm seeing. It seems like it's not able to connect to the CTI server.

CTIModule.log

I20110421-070310.846,2264,    0,Initialized Tracing for Module 'CTIModule'

D20110421-070310.846,2264,    0,Base Initialization for Module 'CTIModule' returning 0x0

I20110421-070310.846,2264,    0,File Version = 5.3.0.4

D20110421-070310.846,2264,    0,CONFIG: CTI LINK VERSION = 9

D20110421-070310.846,2264,    0,CONFIG: SERVICE MODE = PM

D20110421-070310.846,2264,    0,CONFIG: REQUEST TIMEOUT = 10 sec

D20110421-070310.846,2264,    0,CONFIG: INT EXT LEN = 4

D20110421-070310.846,2264,    0,CONFIG: DATA_STORE = DataStore

D20110421-070310.846,2264,    0,CONFIG: RETURN DATASTORE ERRORS = Y

D20110421-070310.846,2264,    0,CONFIG: CONVERT CAD KEYS TO UPPER = N

D20110421-070310.846,2264,    0,CONFIG: SERVER A = =[My UCCX IP]

D20110421-070310.846,2264,    0,CONFIG: PORT A = 42027

D20110421-070310.846,2264,    0,CONFIG: Not configured for duplex ICM environment

D20110421-070310.846,2264,    0,CONFIG: CLIENT ID = AMC_TC1

D20110421-070310.846,2264,    0,CONFIG: DEFAULT PERIPHERAL ID = 5000

D20110421-070310.846,2264,    0,CONFIG: PERIPHERAL_TYPE = CALL_MANAGER

D20110421-070310.846,2264,    0,CONFIG: DEFAULT REASON CODE = 0

D20110421-070310.846,2264,    0,CONFIG: FUNC ENH MASK = 0000

D20110421-070310.846,2264,    0,CONFIG: MCIS EVENT MODE = ASYNC

D20110421-070310.846,2264,    0,CONFIG: EXECUTE SNAPSHOTS = N

D20110421-070310.846,2264,    0,CONFIG: DROP AS RECONNECT IN CONSULT = Y

D20110421-070310.846,2264,    0,CONFIG: USE COMPLEX CALL ID = Y

D20110421-070310.846,2264,    0,CONFIG: NEW CALL DATA ACTION = APPEND

D20110421-070310.846,2264,    0,CTI Module has been initialized

D20110421-070314.018,2264,    0,Base Start for Module 'CTIModule' returning 0x0

D20110421-070314.018,2540,    0,EventProcessor: Start >>>

D20110421-070314.018,2544,    0,EventSaver: Start >>>

D20110421-070314.018,2544,    0,Connect2Cisco: Connecting to Site A (Server=[My UCCX IP], Port=42027)

D20110421-070314.018,2264,    0,CTI Module has been started

D20110421-070314.018,2544,    0,Connect2Cisco: Active - Site A

D20110421-070314.018,2544,    0,OpenRequest: Sending OPEN_REQ (InvokeID=1)

E20110421-070314.018,2544,-2147467259,ValidateEncodeSend: ValidateOutput failed for MsgType=3 (E_CTI_INVALID_SERVICE_MASK)

D20110421-073334.393,3316,    0,REGISTER-00580000001k6eoAAA: Start >>>

D20110421-073334.393,3316,    0,AddExt2MonExtMap-1703: Start >>>

D20110421-073334.393,3316,    0,SnapshotDeviceReq: Sending SNAPSHOT_DEVICE_REQ (InvokeID=2, EXT=1703)

E20110421-073334.393,3316,-2147467259,SendMsg: SEND failed: 10054

D20110421-073334.393,3316,    0,AddExt2MonExtMap-1703: End >>>

E20110421-073334.393,3316,-2147467259,REGISTER-1703: Unknown DN. End >>>

RemotingEndpoint.log

E20110421-070313.908,01, 0,Init: invalid format for mapping. must be separated by single ','

E20110421-073333.986,06,-2147024809,EventServiceManager:RegisterWorktop: Instance: [MyPCName]_00580000001k6eoAAA_[CRM Connector Server IP] is not initialized

E20110421-073334.565,06,-1073477996,WorkTopManagementService::Register: Exception. Exception from HRESULT: 0xC0040910

E20110421-073334.565,06,-2147024809,EventServiceManager:DeRegisterWorktop: Worktop: 00580000001k6eoAAA is not registered

I can give more information if needed. Thanks in advance!

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

SalesForce TroubleShooting

Just an update on this. Cisco has 2 products for integration with salesforce. One is the Unified CRM connector which is meant for UCCE/UCCX. The other product is the Unified CallConnector. The Unified CallConnector can be integrated with both UCCX or directly with Callmanager.

I chose to use the Unified CallConnector (v1.3.2 was the only download). I did have a problem with it not allowing call log editing from the callconnector window if the call was linked to a salesforce contact. Calls that were not linked to a salesforce contact could be edited ok. I contacted Cisco and they gave me a couple dlls to replace and that fixed that problem. Hopefully that saves someone else some headache.

Here's the link for the Unified CallConnector for Salesforce: http://www.cisco.com/en/US/products/ps7292/index.html

2 REPLIES 2
Contributor

SalesForce TroubleShooting

Hi Kris,

We have another CRM connector that is currently in beta which integrates UCCX and SFDC. It is a free download -

http://www.cisco.com/en/US/products/ps7292/index.html

Abhi.

Beginner

SalesForce TroubleShooting

Just an update on this. Cisco has 2 products for integration with salesforce. One is the Unified CRM connector which is meant for UCCE/UCCX. The other product is the Unified CallConnector. The Unified CallConnector can be integrated with both UCCX or directly with Callmanager.

I chose to use the Unified CallConnector (v1.3.2 was the only download). I did have a problem with it not allowing call log editing from the callconnector window if the call was linked to a salesforce contact. Calls that were not linked to a salesforce contact could be edited ok. I contacted Cisco and they gave me a couple dlls to replace and that fixed that problem. Hopefully that saves someone else some headache.

Here's the link for the Unified CallConnector for Salesforce: http://www.cisco.com/en/US/products/ps7292/index.html

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards