cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
11377
Views
5
Helpful
5
Replies
afaudale
Beginner

SIP/2.0 503 Service Unavailable

Hello and thank you for your time.

 

We have a fairly new CUBE configuration. Our connection to our SIP provider seems to be correct. However, we are receiving a SIP/2.0 503 Service Unavailable when we place calls inbound over a test number that the SIP provider has given us. I have a matching translation pattern in CUCM which translates to me internal test DN 10369. I see a few error messages when I do a debug ccsip messages. I see the "SIP/2.0 503 Service Unavailable" message, I see a "SIP/2.0 404 Not Found" message and I also see a warning: 399 x.x.x.x "No matching outgoing dial-peer".  Below is the part of the config I feel might be important to help you better understand our setup (items removed or changed for privacy purposes). Let me know if you need any additional information and thanks in advance for your help!

 

voice service voip
ip address trusted list
ipv4 10.10.10.200
ipv4 10.10.10.201
ipv4 X.X.X.X
ipv4 X.X.X.X
no ip address trusted authenticate
rtp-port range 20002 30000
address-hiding
mode border-element license capacity 300
allow-connections sip to sip
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
sip
bind control source-interface GigabitEthernet0/3
bind media source-interface GigabitEthernet0/3
options-ping 60
!
voice class codec 10
codec preference 1 g711ulaw
codec preference 2 g729r8
!
voice class codec 20
codec preference 1 g711ulaw
codec preference 2 g729r8
!
interface GigabitEthernet0/0
description TRUNK-TO-CUCM
ip address 10.20.10.7 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description MANAGEMENT
vrf forwarding iptollfree
ip address 10.20.11.7 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/2
vrf forwarding iptollfree
ip address 10.20.12.7 255.255.255.0
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/3
ip address X.X.X.X 255.255.255.248
ip access-group SIP in
duplex auto
speed 100
!
ip tftp source-interface GigabitEthernet0/1
ip route 10.10.10.0 255.255.255.0 10.20.10.1
ip route X.X.X.X 255.255.255.255 X.X.X.X
ip route vrf management 0.0.0.0 0.0.0.0 10.20.10.1
ip route vrf iptollfree 0.0.0.0 0.0.0.0 10.20.11.1
ip route vrf voicecomplete 0.0.0.0 0.0.0.0 10.20.12.1
!
ip access-list extended SIP
permit udp host X.X.X.X any range 5060 5061 log
permit udp host X.X.X.X any eq echo log
permit icmp host X.X.X.X any
permit icmp host X.X.X.X any
permit udp host X.X.X.X any
permit udp host 10.10.10.200 any range 5060 5061 log
permit udp host 10.10.10.201 any range 5060 5061 log
permit udp 10.0.0.0 0.255.255.255 any range 5060 5061 log
deny ip any any log
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/3
sccp ccm 10.10.10.201 identifier 1 priority 1 version 7.0
sccp ccm 10.10.10.200 identifier 2 priority 2 version 7.0
sccp
!
sccp ccm group 1
bind interface GigabitEthernet0/3
associate ccm 1 priority 1
associate ccm 2 priority 2
!
!
!
dspfarm profile 1 mtp
codec g711ulaw
maximum sessions software 48
associate application SCCP
!
dspfarm profile 2 mtp
codec g711ulaw
maximum sessions software 48
associate application SCCP
!
dial-peer voice 69101 voip
description Inbound Calls SP to CUBE
incoming called-number .
voice-class codec 10 offer-all
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
dial-peer voice 79005 voip
description Inbound to Sub1
preference 1
destination-pattern 571.......
session protocol sipv2
session target ipv4:10.10.10.201
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 79105 voip
description Inbound to Pub
preference 2
destination-pattern 571.......
session protocol sipv2
session target ipv4:10.10.10.200
dtmf-relay rtp-nte
codec g711ulaw
!
dial-peer voice 69000 voip
description CUBE to SP - PSTN
destination-pattern 9T
session protocol sipv2
session target sip-server
session transport udp
voice-class codec 10 offer-all
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs3 signaling
no vad
!
!
sip-ua
set pstn-cause 1 sip-status 503
set pstn-cause 3 sip-status 503
retry invite 2
retry bye 2
retry cancel 2
timers trying 550
sip-server ipv4:X.X.X.X
g729-annexb override
!

 

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
afaudale
Beginner

This issue is now resolved. For some unknown reason (slip of the finger I guess) I had this box checked on my translation pattern "Route Next Hop By Calling Party Number". Once I removed that check box the call routed as expected.

View solution in original post

5 REPLIES 5
afaudale
Beginner

Adding a debug voice ccapi inout as well

afaudale
Beginner

Adding a debug voice ccapi inout as well

afaudale
Beginner

This issue is now resolved. For some unknown reason (slip of the finger I guess) I had this box checked on my translation pattern "Route Next Hop By Calling Party Number". Once I removed that check box the call routed as expected.

afaudale
Beginner

This issue is now resolved. For some unknown reason (slip of the finger I guess) I had this box checked on my translation pattern "Route Next Hop By Calling Party Number". Once I removed that check box the call routed as expected.

Jon Clark1
Beginner

Just wanted to add my experience on this same error 503.

I had a customer who couldn't dial out and was getting 503.

I came to this forum for help but nothing matched my situation.

 

I pulled the CDR's and plugged into translator x and saw no initial invite. Only a whole bunch of dialogue between the phone and the CUCM it was registered to. A bunch of NOTIFY's and SUBSCRIBE ->  <-404 not Found in return then finally a 503. Never an INVITE.

 

I then put the call in notepad++ and saw the recording AQM Trunk involved in much of the traces just before the 503. Nothing jumped out at me so I did 2 things...

 

1. Changed the Recording Source from Gateway to Phone Preferred on the DN in question.

2. Upgraded the phone's firmware to the latest.

 

Caller was then able to dial out.

Hope this helps someone.

Create
Recognize Your Peers
Content for Community-Ad