cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Walkthrough Wednesdays
422
Views
0
Helpful
6
Replies
aelankoud
Beginner

SRST between CUCM 11 and CME v7 Integration

Hi ALL,

Actually, CME v7 is installed in our Organization, Now we want to migrate from CME to CUCM, with CME remains operational
We want to configure all the IP Phones to the CUCM, to become the Primary VOIP Server and the CME Secondary, to do that we will activate the SRST mode, that means if CUCM is deactivated the IP Phones recover its configuration automatically from CME,
The types of IP Phones that we have: (7911, 7931, 7975, roughly 200 IP phones total)
My questions :
1- it's to enable SRST mode if the CUCM and CME in the same LAN?
1- what's the firmwares that are compatible with CME 7 and CUCM 11?
2- Is what we need to do a migration from CME v7 to CME v11?

thank you for your helping ?

1 ACCEPTED SOLUTION

Accepted Solutions
Laith Ibrahim
Beginner

Here what i recommend you do:

1- Upgrade your CME router to be at least version 11.

2- Configure your CME router as ( H323 or SIP gateway ).

3- Use SRST Manager to configure ESRST to have more features on SRST mode.

All what you need to migrate is the following:

1- Add all your phones to the CUCM.

2- Change the TFTP address in the Voice VLAN dhcp pool to be CUCM instead of CME.

3- Configure the CME router ip address as SRST reference in the CUCM.

4- You may need to erase the configuration on the phones before they be able to register to the CUCM.

View solution in original post

6 REPLIES 6
Manish Gogna
Cisco Employee

>> SRST and CUCM on same LAN will work but really does not help much if the same router is being used for srst and handling incoming/outgoing calls.

>> SRST, CME and CUCM firmware compatibility matrices are given below

http://www.cisco.com/c/en/us/support/unified-communications/unified-survivable-remote-site-telephony/products-device-support-tables-list.html

http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/unified/communications/system/Compatibility/CSR-Compatibility-Matrix-InteractiveHTML.html

http://www.cisco.com/c/en/us/support/unified-communications/unified-communications-manager-express/products-device-support-tables-list.html

>> Migration / Upgrade of CME is detailed in the following guide

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/admin/configuration/manual/cmeadm/cmeinstl.html

HTH

Manish

Laith Ibrahim
Beginner

Here what i recommend you do:

1- Upgrade your CME router to be at least version 11.

2- Configure your CME router as ( H323 or SIP gateway ).

3- Use SRST Manager to configure ESRST to have more features on SRST mode.

All what you need to migrate is the following:

1- Add all your phones to the CUCM.

2- Change the TFTP address in the Voice VLAN dhcp pool to be CUCM instead of CME.

3- Configure the CME router ip address as SRST reference in the CUCM.

4- You may need to erase the configuration on the phones before they be able to register to the CUCM.

View solution in original post

Hi Ibrahim, thank you for your answer,

I reset two IP Phone in Default Factory mode, then I added them in CUCM, but when I plug the IP Phone to the Switch does not recover its configuration and it can not do the upgrade.
I give you the configuration of my switch and my router (DNS server, DHCP server and Voice Gateway), and CUCM:

SWITCH-VOIP # show cdp neighbors detail
-------------------------
Device ID: SEP64D98969A7C3
Entry address (es):
   IP address: 10.2.10.7
Platform: Cisco IP Phone 7911, Capabilities: Two-port Mac Relay
Interface: FastEthernet0 / 19, Port ID (outgoing port): Port 1
Holdtime: 176 sec
Second Port Status: Down


Release: 79XX_default_load

Advertisement
Duplex: full
Power Drawn: 5,000 Watts
Power request id: 42947, Power management id: 3
Power request levels are: 5000 0 0 0 0
Management address (es):

-------------------------------------------------------------

Voice Gateway :

ip dhcp excluded-address 10.2.10.1
ip dhcp excluded-address 10.2.10.2
ip dhcp excluded-address 10.2.10.3
ip dhcp excluded-address 10.2.7.1
ip dhcp excluded-address 10.2.7.2
ip dhcp excluded-address 10.2.7.3
ip dhcp excluded-address 10.2.10.10
ip dhcp excluded-address 10.2.10.11
ip dhcp excluded-address 10.2.10.12
ip dhcp excluded-address 10.2.10.13
ip dhcp excluded-address 10.2.10.14
ip dhcp excluded-address 10.2.10.15
ip dhcp excluded-address 10.2.8.1
ip dhcp excluded-address 10.2.8.2
!
ip dhcp pool dpool1
 import all
 network 10.2.7.0 255.255.255.0
 default-router 10.2.7.12
 dns-server 10.2.7.12
 domain-name cisco.com
 option 150 ip 10.2.7.13
!
ip dhcp pool dpool2
 import all
 network 10.2.10.0 255.255.255.0
 default-router 10.2.7.12
 dns-server 10.2.7.12
 domain-name cisco.com
 option 150 ip 10.2.7.13
!
ip dhcp pool dpool3
 import all
 network 10.2.8.0 255.255.255.0
 default-router 10.2.7.12
 dns-server 10.2.7.12
 domain-name cisco.com
!
no ip domain lookup
ip domain name cisco.com
ip name-server 10.2.7.12
ip cef
no ipv6 cef
multilink bundle-name authenticated


voice-card 0
!
voice call send-alert
!
voice service voip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  session transport udp
!
voice class h323 1
  call start fast
!
license udi pid CISCO2901/K9 sn FGL204610JC
hw-module pvdm 0/0
!
username admin privilege 15 password 7 06350E2D491C594852
!
redundancy
!
ip ssh time-out 50
ip ssh authentication-retries 4
ip ssh version 2
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 10.2.7.12 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.7
 encapsulation dot1Q 7
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.8
 encapsulation dot1Q 8
 ip address 10.2.8.2 255.255.255.0
 ip helper-address 10.2.7.12
!
interface GigabitEthernet0/1.10
 encapsulation dot1Q 10
 ip address 10.2.10.2 255.255.255.0
 ip helper-address 10.2.7.12
!
!
router eigrp 1
 network 10.0.0.0
!
ip forward-protocol nd
!
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip dns server
ip route 10.2.8.0 255.255.255.0 10.2.8.1
ip route 10.2.10.0 255.255.255.0 10.2.10.1
!
ip access-list extended acl-vlan-interco
 permit ip 10.2.0.0 0.0.255.255 10.2.0.0 0.0.255.255
 deny   ip any any
!
control-plane
!
dial-peer voice 1 voip
 destination-pattern 1...
 progress_ind setup enable 3
 session target ipv4:10.2.7.13
 incoming called-number 0T
 codec g711ulaw
 no vad
!
dial-peer voice 2 pots
 preference 1
 destination-pattern 0T
 port 0/1/0
 forward-digits all
!
dial-peer voice 3 pots
 preference 2
 destination-pattern 0T
 port 0/1/1
 forward-digits all
!
dial-peer voice 4 pots
 preference 3
 destination-pattern 0T
 port 0/1/2
 forward-digits all
!
dial-peer voice 5 pots
 preference 4
 destination-pattern 0T
 port 0/1/3
 forward-digits all

-----------------------------------------------------------
CUCM Configuration

thank you for helping

Dear,

is this the CUCM ip: 10.2.7.13 ?

if it is, double check if the phone added to phone list,

go to Device --> Phone and double check the MAC address,

Thanks,

Hi Ibrahim,

the IP Phones is added on CUCM correctly, MAC addresses is correct,

but, when i type " show cdp neighbors detail " It lacks the management address :

SWITCH-VOIP # show cdp neighbors detail
-------------------------
Device ID: SEP64D98969A7C3
Entry address (es): IP address: 10.2.10.4
Platform: Cisco IP Phone 7911, Capabilities: Two-port Mac Relay
Interface: FastEthernet0 / 19, Port ID (outgoing port): Port 1
Holdtime: 176 sec
Second Port Status: Down

Release: 79XX_default_load

Advertisement
Duplex: full
Power Drawn: 5,000 Watts
Power request id: 42947, Power management id: 3
Power request levels are: 5000 0 0 0 0
Management address (es):

---------------------------------------------

it means not communication between the IP Phone and CUCM

such as the routing between the VLANs is configured correctly.

thank you for your helping.

Hey,

Double check the phone ip config that it got the TFTP ip address correctly,

Then try to restart the TFTP service in the call manager,

if it didn't work, try downgrading the firmware in call manager,

Thanks,

Content for Community-Ad

Spotlight Awards 2021