cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5797
Views
5
Helpful
7
Replies
adam.whitlatch
Beginner

UCS B230 - Windows BFS Issue

All,

Hoping someone can help me here.

I am trying to install Windows 2008 R2 Sp1 on one of our UCS blades - we are going Boot from SAN. No Local Disks. I boot to the CD, Enterprise install, load the drivers for the MK81 Card. I see 50Gb LUN we created. I select to online the disk. The installer created the two partitons for the Primary and 100MB boot partions. But when I try to install windows gives the error:

"Windows cannot be installed to this disk. The computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu."

I've been thru the Cisco Guide on installing Windows 2008 R2 in a BFS configuration. It appears we have everything set right. Short of putting only one HBA in the system, what else am I missing?

Thanks much in advance!

-Adam

1 ACCEPTED SOLUTION

Accepted Solutions
bmoorewiz
Enthusiast

The issue is with the EFI shelf, you need to go into the BIOS and change the boot manager policy from "Strict" to "Loose".

Now, you will mount the ISO image the same way as before however, when you choose the image at the boot menu make sure you do NOT use the EFI virtual CD/DVD, you have to use the other Virtual CD/DVD, I believe it says version 1.22 or something close to that.

This is an error in Windows w/ the EFI shelf that was supposed to be resolved with Windows 2008 R2 SP1 but apparently it is not.

*Answered*

View solution in original post

7 REPLIES 7
adam.whitlatch
Beginner

bump

harold.himes
Beginner

Same Problem. Anyone have any advice?

Make sure there is only one path to the storage. When building Windows, if you have more than one path it won't ever work. I went as far as making sure there was only one HBA assigned to the profile and also making sure only one path was zoned up to see the storage. Once I did that, it worked fine.

bmoorewiz
Enthusiast

The issue is with the EFI shelf, you need to go into the BIOS and change the boot manager policy from "Strict" to "Loose".

Now, you will mount the ISO image the same way as before however, when you choose the image at the boot menu make sure you do NOT use the EFI virtual CD/DVD, you have to use the other Virtual CD/DVD, I believe it says version 1.22 or something close to that.

This is an error in Windows w/ the EFI shelf that was supposed to be resolved with Windows 2008 R2 SP1 but apparently it is not.

*Answered*

View solution in original post

What a great answer! Thanks bmoorewiz!

I was so frustrated trying to figure it out what when wrong during the installation. You saved me a day :-)

Hi bmoorewiz,

I have the same error above when installing windows 2008 R2 on ucs 2.2.6e

I check this bios setting but found it dimmed as attached

Do you have any idea about that ?

Thanks

Alkali
Beginner

I know this thread is super old, but I just had this exact problem and was pulling my hair out trying to troubleshoot it, which led me here.

 

The solution for me was...Never trust your storage guys.  Make sure that the boot LUN is set to LUN 0 on the device.  After that everything started working.  I spent a day and a half trying to install to LUN 1 which of course doesn't work.

 

Hope this helps anyone else who stumbles across this.

-Alkali

 

Cisco B200M5

All firmware up to date 3.2(2b)

Windows Server 2016

Create
Recognize Your Peers
Content for Community-Ad