cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2133
Views
8
Helpful
4
Replies
Highlighted
Beginner

Unity 5.0(1) partner Exchange 2010

All,

Following the 'Using Microsoft Exchange 2010 with Unity version 8.0, 7.0 and 5.0 document found at :

http://www.cisco.com/en/US/docs/voice_ip_comm/unity/7x/using_exch2010/usingex2010withcu7x5x.html

Have compelted the section adding one or more exchange 2010 servers to an exisiting unity install.  Now looking at completing the change in partner exchange server from 2003 to 2010.  Following the guide details:

Changing the Partner Server for a Cisco Unity 8.0, 7.0, and/or 5.0 Server to an Exchange 2010 Server

Revised July 2, 2010

Do the procedure in this section to change the partner Exchange server for a Cisco Unity 8.0, 7.0, and/or 5.0 server to an Exchange 2010 server.

To Change the Partner Server for a Cisco Unity 8.0, 7.0, and/or 5.0 Server to an Exchange 2010 Server


Step 1 If you have not already configured Cisco Unity for Exchange 2010: Do the procedure in the "Adding One or More Exchange 2010 Servers to an Existing Cisco Unity 8.0, 7.0, and/or 5.0 Installation" section.

Step 2 If there are two or more Exchange 2010 servers in the environment: Determine which of the Exchange servers to use as the partner Exchange server. See the "Determining the Partner Exchange Server for Cisco Unity 8.0, 7.0, and/or 5.0" section.

Step 3 In the Add/Remove Programs Control Panel, run the Cisco Unity Message Store Configuration wizard, and select the following options:

For the message store version

Select Microsoft Exchange 2007/2010.

For the server

Select the Exchange 2010 server that you want to use as the partner Exchange server.

At Step 3, I stop CSAgent, but when I run the Message store Configuration Wizard I'm getting an error.  The wizard starts, I click next to continue and the wizard states:

Cannot install Cisco unity

This wizard cannot install Cisco unity on your computer, because the following reasons:

But there are no reason as to why it can't run the config wizard.  Click next and the screen displays Cisco unity has not been correctly installed and the wizard then presents only the option to finish.

Unity is running 5.0(1) ES 88.  Anyone with any ideas as to why I can't run the Message Store Configuration wizard?

Many thanks

David

4 REPLIES 4
Highlighted
Cisco Employee

Highlighted

Hi Atul,

thanks for the post back. 

Had a look at CSCsv47328 but can't see where to download patch #103 that is mentioned under the workaround for the problem.  Have looked under CCO downloads for unity 5.0 and can't see it listed.  Do I need to request this directly from TAC?

Followed the detailis in CSCtb46143 and can confirm we are using ENG locale and not ENU.  The xml file was not there.  Have followed workaround details by moving the xml file.  This has now allowed me to enter password for the unity installation account we used.  However when I now select Exchange 2010 from the list and click next it gives an error stating the Exchange 2003 Management tools are not installed.  These were removed as part of the original documentation Step 13.  Any suggestions on next course of action?

Many thanks

David.

Highlighted

Update for anyone hitting this.  After working with TAC we identified that we were hitting the following bug:

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCto58324

The detail of this bug is as follows:

MSCW fails with "Exchange 2003 System Manager is not installed"
Symptom:
MSCW fails with error "Exchange 2003 System Manager is not installed - Install Exchange System Manager."

Conditions:
Unity 5.x installed with a non ENU locale.
ESM has been removed in order to re-partner Unity with Exchange 2010.
This defect is applicable to all non-ENU files that are packaged in 5.0 starting with ES85.

Workaround:
Check [HKEY_Local_Machine\SOFTWARE\Active Voice\Commserver Setup\1.0\Properties\GUILanguageDefault] to verify the default locale (e.g. DAN).
Then copy \CommServer\SysCheck\ENU\Exchange2007\TestExchange2007.xml to the appropriate locale directory. E.g. copy to: \CommServer\SysCheck\DAN\Exchange2007\ and replace the existing file.
Highlighted

hi David,

Thanks for updating us with correct bug.

- Atul