cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
823
Views
5
Helpful
4
Replies
Beginner

Unity 8 and exchange 2k7 and exchange 2010

Hi Everyone,

I have the following environment:

2 - Unity 8 servers running in failover

Exchange 2010 DAG

Legcay Exchange 2007 mail servers

I recently upgraded Unity from version 7 to version 8 and installed the required ES's for 2010 support.  The partner server remained on exchange 2k7.

I then migrated a few users to exchange 2010 to ensure unity would still work.  They all received messages as expected.  However, a few of them no longer received MWI notifications.  I checked the event log and saw the dreaded malex error for the user in question.  I tried a UTIM resync and that did not work as a fix.  I then tried deleting the unity account and recreating it.  This worked.  However, I then tried migrating this user back to the 2k7 server.  This broke the MWI light again.

This morning, I changed the partner server to the exchange 2010 server.  After rebooting both unity servers, the partner server was successfully working as well as all MWI notifications.  I then moved an account from 2010 to the 2k7 server and the MWI broke again.  UTIM sync did not fix it either.

I am hesitant to start migrating our users from 2k7 to 2010 because of this issue.  Has anyone seen anything like this?  Any advice on a fix?

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: Unity 8 and exchange 2k7 and exchange 2010

Date Created: 01-APR-2011 07:22 PM Created By: Martin, Yanick(YANMARTI,276568) Suspected bug CSCtg15295

The client installed ES 10 (engineering special 10) but it was still failing on Unity 8.0.3 ES 10.

We were going to collect traces for further troubleshooting but the client finished the migration of the accounts to Exchange 2010 and did not need further troubleshooting since after a DOH prop test Global Catalog resync it worked fine and no mailboxes will be moved back to Exchange 2007 anymore. 

4 REPLIES 4
Beginner

Re: Unity 8 and exchange 2k7 and exchange 2010

I ended up forcing both an AD and GC resync via dohproptest.  Everything is working now.

I then moved an account between exchange 2010 and 2007 again and it all broke.  I forced a resync again and all is well.

It seems like there could be an issue with the syncing happening automatically.  In fact, I have some ciscounity_dsgc errors in the event log.

Has anyone seen this before?

Cisco Employee

Re: Unity 8 and exchange 2k7 and exchange 2010

What ES do you have installed? Latest is ES 10. With defect CSCtg15295 and CSCtk14418

there were changes to the way Unity performs mapi and communicates to the GC.

Highlighted
Beginner

Re: Unity 8 and exchange 2k7 and exchange 2010

I am on ES9.

I do not see ES10 on the support site.  Is this a tac request only update?

Beginner

Re: Unity 8 and exchange 2k7 and exchange 2010

Date Created: 01-APR-2011 07:22 PM Created By: Martin, Yanick(YANMARTI,276568) Suspected bug CSCtg15295

The client installed ES 10 (engineering special 10) but it was still failing on Unity 8.0.3 ES 10.

We were going to collect traces for further troubleshooting but the client finished the migration of the accounts to Exchange 2010 and did not need further troubleshooting since after a DOH prop test Global Catalog resync it worked fine and no mailboxes will be moved back to Exchange 2007 anymore. 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards