cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
765
Views
0
Helpful
12
Replies
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Dear All

I have two Questions :

1) i need to upgrade Unity Unifid messaging from ver 4.2 to 8.6 and from ver 5.0 to ver 8.6 on existing server(not separate server) with failover servers , do have PDF that  to show me step by step to upgrade main unified messaging server and failover unified messaging  server ?????

Note : they have 2003 Activ Directory/ Exchange

2) I need to upgrade CCM(Publisher and Subscribers) from version 7.1 to 8.5 and 6.1 to 8.5 and 5.1 to 8.5 on existing server(not separate server) , Do you have PDF that to show me step by step to upgrade Publisher and Subscribers ???

Please reply me ASAP

Thanks and regards

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Advisor

Upgrade CCM/unity unified messaging to version8.6 with failover

Let's back up a second:

Unity upgrades - tell us what you have.  Do you have 2 separate Unity systems - 1 running 4.2 and the other running 5.0 OR are you thinking you would upgrade one system from 4.2 to 5.0 to 8.x?

On that token, Cisco Unity and Unity Connection are not the same product.  Cisco Unity does not go beyond version 8.0.  Unity Connection does...there is a version 8.6 of Unity Connection.

If you want to upgrade/migrate from Unity to Unity Connection then you will need to use COBRAS and there is simply some data that doesn't get migrated but the most critical data goes - Subscriber info, greetings, etc.  You can even migrate messages if you want to.

So, first things first - tell us exactly what you have and we'll kick back off from there.

View solution in original post

12 REPLIES 12
Highlighted
Hall of Fame Master

Re: Upgrade CCM/unity unified messaging to version8.6 with failo

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Hi Chris

first , thanks for your reply , in actually i read the link that you sent , but  i have confused regarding upgrade unfied messaging  from 4.2 to 8.6  and   5.0 to 8.6 , it is not straight forward

is there direcly upgrade for Unified Messaging from version 4.2 to version 8.6 ?? if no as i read , how upgrade it will be in it depends version ????? : ex from 4.2 to ver 7.5 then to 8.6  

and the same question for 5.0 to ver 8.6 ????

thanks and regards

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Any Replay ASAP ???

Highlighted
Hall of Fame Master

Upgrade CCM/unity unified messaging to version8.6 with failover

Are you upgrading to Unity or migrating to Unity Connection as that is desired these days since Unity is a dead product?

I don't think there is Unity 8.6, only Unity connection 8.6 in which case you need to use COBRAS tool to perform the migration and implement Single Inbox feature to integrate with Exchange for unified messaging.

Chris

Highlighted
Advisor

Upgrade CCM/unity unified messaging to version8.6 with failover

Unity is EoL/EoS and the last version is 8.0.  If you are looking at version 8.6 then it is Unity Connection as Chris said.  In your case, you would need to stand up a new Unity Connection cluster and get it integrated with Exchange for Unified Messaging (if you have 4.2 and 5.0 versions of Unity then you must have 2 separate systems, which are being consolidated) first.  You will then need to use the COBRAS migration tools to export the data from the Unity servers and import it into Unity Connection.  You can read up on COBRAS here:

http://www.ciscounitytools.com/Applications/General/COBRAS/Help/COBRAS_Briefcase/COBRAS_Briefcase.htm

You could try to reuse a Unity server (assuming it is supported for Unity Connection) but could be a real operational risk if you run into issues along the way.

For CUCM, this would also be hardware dependent.  If you have a system that you need to step upgrade from 5.x to 8.6, then you need to understand the hardware dependencies first as a) the server may not be supported or b) it may require RAM and/or HDD upgrades to support 7.1 or 8.6.  Since you have so many steps along the way, you'll have to treat each step as a separate upgrade from a prep perspective while also accounting for which SU versions you may also need to patch to in order to faciliate the most direct upgrade path.

Hailey

Please rate helpful posts!

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Hi

i read this restriction in COBRA tools that doesnt support , but they have Greeting and Handlers and Hloiday ,  as following as below :

Note : the customer wants buy new RAM and new Hard Disk instrad of new server

COBRAS Does Not Get:

  • Class      of Service
  • Restriction      tables
  • Locations
  • Contacts      (includes SMTP/AMIS/Bridge/VPIM subscribers)
  • Holidays      for Unity (Connection Holidays are included in the backups)
  • System      configuration data such as switch configuration, LDAP integration details,      IMAP login data, RSA configuration, advanced settings etc..
  • Subscriber      templates
  • Call      Handler templates
  • Password      policy information

1)So I think that i cant use COBRA which one is good to take every things in unity COBRA ,GSM and TIRT ????? Note: they have Aoto Attendent in unuty

2) I read this in PDF

If the Cisco Unity server is running a version earlier than 4.2(1): Upgrade both Cisco Unity servers to Cisco Unity 4.2(1). Upgrading from a version of Cisco Unity earlier that 4.2(1) directly to version 8.0 is not supported.

Do not upgrade to Cisco Unity 5.x or 7.x, either of which would require interim license files in addition to the Cisco Unity 8.x license files

what it measn ?? i cant jump from 4.2 to 8.6 directly ??? if no,  how it will be the upgrade ??

thanks and regards

Highlighted
Advisor

Upgrade CCM/unity unified messaging to version8.6 with failover

Let's back up a second:

Unity upgrades - tell us what you have.  Do you have 2 separate Unity systems - 1 running 4.2 and the other running 5.0 OR are you thinking you would upgrade one system from 4.2 to 5.0 to 8.x?

On that token, Cisco Unity and Unity Connection are not the same product.  Cisco Unity does not go beyond version 8.0.  Unity Connection does...there is a version 8.6 of Unity Connection.

If you want to upgrade/migrate from Unity to Unity Connection then you will need to use COBRAS and there is simply some data that doesn't get migrated but the most critical data goes - Subscriber info, greetings, etc.  You can even migrate messages if you want to.

So, first things first - tell us exactly what you have and we'll kick back off from there.

View solution in original post

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Loay,

If I have understood your initially question, below is what you're trying to achive.

1. Unity to UnityConnection

You have two different legacy Unity cluster with failover ,one running 4.2 with faiolver and another running 5.2 with failover. This being said, you want to upgrade these cluster's to Unity Connection 8.6 using the same hardware and looking for inputs correct ???

2. CUCM Upgrade :

Looks like you have three different CUCM cluster with PUB and SUB running 6.1,7.1,& 5.1 versions.Here you're looking to upgrade all these clusters to 8.5 on the same hardware correct ??

If Yes, you will have to spec out the server models that you're running these applications currently, for us to help you out.

Thanks,

Simah.

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Hi

- I have two cluster , one of them have unity (unified messaging/voice mail) version 4.2 , i want to upgarde it to version 8.6 (Unity connection as i read in the PDF) on the existing server (raise in RAM and HD)  , as i read in the PDF , it will jump diretly from 4.2 to 8.6 by taking Backup by COBRA, my Question ,

it is right to jump directly from 4.2(1) to 8.6 ???

regarding AD/exchange it will upgrade as well or not ??? they have AD 2003 ???

i read in the PDF i can do upgrade in main and Failover unity server Simultaneous , it is right and it is recommended ???

- and the other one is from 5.0(1) to 8.6 as well ? and the same questions

i have three cluster as menstion as below , each clutser has different version , I need to upgrade all  CCM(Publisher and Subscribers) to version 8.5

cluster 1) 7.1.5.3  to 8.5

and cluster 2)  6.1.3 to 8.5

and cluster 3)    5.1.3.1 to 8.5

on existing server(raise in RAM and HD) and not separate server , My Question is :

- from 7.1.5.3 to 8.5 ,the upgarde it will jump directly to 8.5 , it is right ???

- from 6.1.3 to 8.5 , the upgarde will , first  from 6.1.3 to 7.1(3) , then to 8.6 , it is right ???

- from 5.1.3 to 8.5 , the upgrade will , first from 5.1.3 to 6.1(3) then to 8.6 , it is right ???

if not how it will be in both in unity and CCM ???

thanks and regards

Highlighted
Advisor

Upgrade CCM/unity unified messaging to version8.6 with failover

OK, here goes:

For both Unity upgrades, I am assuming that your desire to keep the systems separate (in other words, you are going to install 2 separate Unity Connection clusters).  In both cases, if your current Unity hardware supports Unity Connection 8.6 then you can use the failover server to start.  You would need to rebuild the failover server to do a fresh installation of Unity Connection 8.6.  Then you will need to get basic system configurations done on that new Unity Connection server (Subscriber Templates, Classes of Service, anything that does not get migrated - see COBRAS help for specifics).  During this time, your Unity primary server would remain online and you'd be able to run the COBRAS Export tool to get the data that migrates.  From there, you will import the data on the new Unity Connection server.  You would then have the choice to either, keep the existing Unity server online for a bit (in case you need to backout or reference anything) OR go ahead and use it to do a fresh install of Unity Connection and add that as a failover subscriber within a Unity Connection cluster pair.

Your AD/Exchange environment should be independent of these activities if you are configured as Unified Messaging with Unity today.  If you are voicemail only, then you will no longer need AD/Exchange for Unity Connection to function.  However, you can integrate Unity Connection with an Exchange 2003 system to provide Unified Messaging if that is a requirement.

Your upgrade path for CUCM can vary depending on the specific versions running on each cluster.  For direct upgrades, you can upgrade to 8.6(2a)SU2 on supported hardware directly from 7.1(5) or 6.1(4).  The 5.x will require an interim upgrade - again, the path may vary depending on the specific version you are running.

There are a lot of moving parts and considerations for the changes you are looking to implement.  In this case, I would definitely recommend enlisting some help from a local Cisco UC partner in your area.

Hailey

Please rate helpful posts!

Highlighted
Beginner

Upgrade CCM/unity unified messaging to version8.6 with failover

Hi David

as i understood regarding Unity upgrade , you are talking if you want to  upgarde both server primary and failover

Simultaneous , however if you dont want to do it Simultaneous , as i understand from PDF in brief

- take the Backup from Primary unity by COBRA tools.

- do upgrade at primary unity after finish

- go to failover unity server upgarde

it is right , or there is another way , which is the best way to upgrade both servers in your opinion ????

thanks and regards

Highlighted
Advisor

Re: Upgrade CCM/unity unified messaging to version8.6 with failo

No, I'm saying you could leave Unity in a functional state by upgrading one server to Unity Connection and getting data migrated over first with COBRAS. Then you can migrate users to the new server but be able to switch back to Unity in a pinch.

Sent from Cisco Technical Support iPhone App

CreatePlease to create content