cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
4726
Views
0
Helpful
19
Replies
Highlighted
Frequent Contributor

VMO 8.5(7) and Unity 7.02 phone playback

Anyone know if there is workaround to issue/bug with phone playback bug below?

Just installed the VMWS patch on Unty 7.02 ES40 server and rebooted, checked DCOM VMO settings (other cisco doc) and when we playback over phone the phone rings then we get window saying it did not work with a TRAP_E_UNKNOWN error. The bug below is what we are running into.

So they just release this recently and it don't work?

CSCtq38536 Bug Details

VMO 8.5(6) w/ Unity TRaP to phone fails.
Symptom:

When users attempt to perform TRaP playback to phone for voice messages in their Exchange mailbox by using Outlook 2010 and ViewMail 8.5(6), they encounter an error of type:

Recording or playback failed: Unknown error occurred, AudioEventId= TRAP_E_UNKNOWN. Contact your system administrator.

This correlates with the following log file entry from the VMO 8.5 logs:

"2011-04-20 11:36:59.3609 INFO: OUTLOOK 1252 5 VMOLibrary.TRaP.Unity7TrapImpl.ProcessTypicalTransaction Got VMWS Fault: E_VMWS_MSG_INVALID_MESSAGE_ID"


Conditions:

ViewMail for Outlook plug-in version 8.5(6) is the first version of VMO 8.5(x) which supports TRaP playback to phone. Seen with Exchange versions 2003 and 2010 so far. Seen with Unity version 7.0(2) so far.

Workaround:

19 REPLIES 19
Highlighted
Beginner

@ebergquist

@Fred Hunt

Just wondering, but what version of the Unity/Unity Connections do you have on the backend?  Is the phone system you're using native Cisco VoIP, or are you hybrid with something like an Avaya PBX?

In my shop we've got Unity Connections 8.6.1 taking calls from an Avaya SG8500 with VoIP integration handled through a PIMG unit.  We see a lot of strange behavior with playback to phone, but at another one of our offices that is Cisco native phone system they have no problems.

Highlighted

Cisco Call Manager 8.x, Cisco Unity 7.02 ES40. All Cisco, Cisco IP Phones on same subnet at one location.

Fred, I'm guessing you've tried 8.6.6 - does it work sometimes and not others like what I experience?

I've looked at Unity server and see no performace problems and theres no calls on Unity when the VMO playback fails, no high memory or CPU usage, etc.

Highlighted

We are running Cisco Call Manager 7.1.3 and Unity 7.0.2 ES43 (since has been pulled by Cisco).  I have tried ViewMail 8.6.6, as well as every version since 8.5.4 when Outlook 2010 was support was added.

Highlighted

Update on this. So I opened up a TAC ticket and this bug (CSCtq38536 ) is due to be fixed in VMO 8.6.7 apparently, no ETA at this time. It is bug on viewmail side they said and not Unity 7.x side.

Also, since I worked on this VMO last (april 2011 timeframe) the docs apparently have been updated and now there is a matrix starting that VMO 8.5/8.6 with Unity 7.x on Windows 7 PCs is not supported. Thats fine, back when I first started trying to get 8.5 to work it was new and there was hardly any documentation / etc on it. The docs state Unity 8.x is needed for Windows 7 PC support with VMO. I still have this problem on Windows XP machines so waiting to see if VMO fixes the issue while we pursue getting Unity Connections update approved.

Highlighted

Another update, after doing further work on this with TAC and some packet captures, the following defect is being hit. This is not fixed yet and no ETA, and is issue with MAPI on Unity 7.x server talking to Exchange. Unity Connection is not effected by this defect.

CSCtx27613 Bug Details


Viewmail play to phone intermittently drops calls

Symptom:
Issue: Playback via phone intermittently drops call.

Versions: Unity 7.0.2 with either exchange 2010/2007

Viewmail versions: Seems to occur in all supported versions of viewmail

Error on unity when call drops:Event Type: Error
Event Source: CiscoUnity_Miu
Event Category: Error
Event ID: 530
Description:
Cisco Unity's telephony component has encountered a serious error.

Event Type: Error
Event Source: CiscoUnity_Wav
Event Category: Error
Event ID: 800
Cisco Unity's multi-media component has encountered a serious error.

Sniffer capture of unity traffic to exchange shows the following error:
17344 2011-10-20 10:14:58.006312 172.16.1.16 172.17.0.10 DCERPC 86 Fault: call_id: 22779 ctx_id: 0 status: nca_s_fault_context_mismatch
Error matches resolved defect: CSCti70702
Conditions:

Workaround:

None