cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
10868
Views
5
Helpful
14
Replies
david.kelsen
Beginner

WARNING: It has been X day(s) without a successful backup. Please verify backup configuration.

Before I go to TAC, I thought I'd see if anyone knows of a fix for this.

 

We recently upgraded CUCM and CUPS 8.6(4) to 10.5(2).

 

In 10.x, all DRS functions for CUPS have been moved CUCM.

 

Post-upgrade, whenever we log into the OS Administration page of the IM&Presence Publisher we see the following Warning in the banner: "WARNING: It has been X day(s) without a successful backup. Please verify backup configuration." Where X represents the number of days since the upgrade to 10.5.(2) - currently 3 days. Interestingly the same error is not seen in the IM&Presence Subscriber.

 

I can confirm 100% that CUCM DRS backups have completed successfully. The IM&Presence servers have received the backup devices and schedules configured in CUCM DRS and the IM&Presence components have been successfully backed up as part of the CUCM backups.

 

I suspect this is a cosmetic issue only, the problem is that the customer can see it and so now it needs to be resolved.

 

Any guidance is greatly appreciated.

 

 

14 REPLIES 14
Manish Gogna
Cisco Employee

Hi David,

It looks to be related to the following

https://tools.cisco.com/bugsearch/bug/CSCuf21791/?reffering_site=dumpcr

CUCM Need warning message at login when no valid backup files exist
 
Symptom:
No warning displayed if no valid backup files exist

Conditions:
DRS backups never configured or out of date

Workaround:
Configure backup device and scheduler
 
If the backups are working fine then it looks to be cosmetic. You may try a restart of DRF and Tomcat services.
 
HTH
 
Manish

 

Hi Manish,

Thanks for your reply.

I don't think I'm hitting that bug actually because I'm running a version listed under the 'Known Fixed Releases', 10.5(2.10000.5).

The CUCM Publisher has two backup devices and two backup schedules defined. DRS has completed successfully several times.

I've tried restarting DRF and Tomcat services, without any change to the warning banner.

 

 

Hi David

Did you log a TAC case and get an outcome for this, I have the same issue with 10.5.2.10000-5.

 

Hi Nick,

Not yet unfortunately. Its on my radar, but since it seems to be a cosmetic problem, I might wait until the project completion to log it.

Getting the same message on 10.5.2.11900-3. If anyone gets this resolved, please post the resolution. It does appear to be cosmetic though as backups are working as expected.

Hi All,

I did a little research and noticed that it is a cosmetic issue as indicated by David. It looks like it is related to:

https://tools.cisco.com/bugsearch/bug/CSCus44191/?reffering_site=dumpcr

  • Inconsistency in Failed Backup Notice on /ccmadmin

As indicated, if the backups are successful, we can verify that by looking at the DRF logs, just to be sure that they are indeed successful.

Also, we can try and restart the RIS DC and tomcat service (utils service restart Cisco Tomcat) for that node and notice the change.

 

If still the issue does not get resolved, then I believe we are hitting the bug CSCus44191, which has been noticed in CUCM 10.5.2.

Post for any questions.

 

Regards,

Ronak Agarwal

 

Hi Guys , 

I have the same problem in CUP version 10.5.2.22900-2

We log into the OS Administration page of the IM&Presence Publisher we see the following Warning in the banner: "WARNING: It has been X day(s) without a successful backup.

I restart the server but the problem still exist .

We migrated CUCM and CUPS 8.6(4) to 10.5(2)

How can I resolve this problem ?

Regard 

Orlin

Hi Orlin,

If you are able to take IMP backup successfully from CUCM, then it would be just a cosmetic issue as mentioned by Manish in first post.

regds,

aman

I think you are seeing this error orlingenchev  

Cosmetic Error IM&P Backup Warning

CSCuv43136

Symptom:
The IM&P admin page displays the following message on login:
WARNING: No backup device is configured. This is required to recover your system in case of failure.

This error message displays even after a valid backup is configured and has been run, and after the services have been restarted, and the system rebooted.

Conditions:
This occurs on 10.5.2.21900-1 and 10.5.2.22900-4

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuv43136

 

I am myself on: 10.5.2.22900-2

My backups are going via CUCM, and I can see in my IM & Presence Disaster Recovery System page, that my backups are successful every day.

Hi Folks,
After restart the services the cosmetic issue disappeared.

Tks !

Hi,

I am also hitting the same issue with CUCM 10.5.2.10000-5.

If you have resolved, Please share your solution.

Any help would be greatly appreciated.

Regards,

Ashish Bagla

Hi, 

I upgraded to 10.5.2.23900. I haven't seen the problem since. 

I would copy Johan and get off 10.5 base. Also make sure you are using a supported SFTP version. There's really only one:

https://supportforums.cisco.com/document/12761651/opening-tac-case-info-gatherthink-about-when-troubleshooting-drs-cucmcer

---------------------------
Please rate helpful content (i.e. videos, documents, comments). Also, please select the correct answer(s) if any comment(s) answer your question otherwise the questions remains on the support forums as unanswered
---------------------

hassan.mehsen
Beginner

Hello David,

This warning message has been introduced as enhancement request and documented on CSCuf21791.

The CUCM Admin page will display this warning message if there is no backup device configured or no successful backup is taken over 1 day.

Setting scheduled backup for 24h would ensure that backup is always “up-to-date” and warning message would not be observed.

Create
Recognize Your Peers
Content for Community-Ad