cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
18038
Views
25
Helpful
24
Replies

CIMC Supervisor firmware upgrade times out on C220 M3 servers

dmveron01
Beginner
Beginner

Hello,

I manage about three dozen UCS C220 M3 and M4 servers for our company. I'm using an evaluation copy of Cisco's IMC Supervisor to see if it's worth purchasing for centrally managing firmware upgrades. Upgrades for our M4 servers are going well, but every attempt to upgrade the M3 servers are failing with one of these errors:
FAILED - Read timed out
FAILED - Update Complete CIMC InProgress,

I'm trying to update from 3.0(4d) to 3.0(4i). Opening the Java KVM from CIMC Supervisor, attaching the ISO as virtual media, and upgrading that way works without issue.

Any ideas on how to troubleshoot this issue?

Thanks.

2 Accepted Solutions

Accepted Solutions

Thanks for the additional info.

Based on the cimc mem issues that pop up during a non-IMC sup triggered install, this would appear to not be IMC sup related, but something with the current CIMC firmware version, and the process of upgrading the CIMC itself.

Think you are at the point where it would be helpful to open a TAC case based on the Rack server, and errors during upgrade.

Probably need TAC to check the CIMC status before/during upgrade attempt, and HUU log output for the upgrade attempt.

 

Thanks,

Kirk...

View solution in original post

Hi peeat,

I recently did several 3.0(4i) to 3.0(4j) updates, and the situation has not changed. We have several different sub-model C220 M3 hosts, and the problems are the same as described in the original post and your experience. I have managed to complete CIMC upgrades following these steps:

1. Power off the host completely.

2. Log into the CIMC web GUI and select the option to reboot the CIMC.

3. Once that completes, open the KVM, attache the virtual media, power on the host, and boot into the HUU ISO.

4. Once fully loaded and scanned, upgrade only the CIMC (you will most likely get a warning about not upgrading the CIMC and BIOS at the same time).

5. If successful, update everything else.

6. If you still get the CIMC needs to be rebooted due to memory error, select the option to reboot. Wait 10-15 minutes and reconnect to the CIMC and KVM.

7. The HUU should still be up, and you should be able to retry the install. I find that it always works at this point if I've followed the previous steps.

8. After the CIMC updates, update everything else.

 

Hopefully this works for you.

View solution in original post

24 Replies 24

Kirk J
Cisco Employee
Cisco Employee

Greetings.

Ultimately you may to open a tac case to review the IMC sup logs and the CIMC logs on the server to see what is the problem.

Have you tried watching the KVM of the 220m3's attempting the update to see if the HUU ISO i even being mounted?

Is there anything different with the 220M3s vs the M4s in terms of the location/connection of the CIMC connections on the network?

Are you using NFS shares, or just using the IMC sup to host the firmware images?

 

Also, what version of IMC Sup are you running?

I'm in process of testing that specific ISO on some 220m3's in the lab now from IMC SUP 2.2.0.3

Thanks,

Kirk...