Showing results for 
Search instead for 
Did you mean: 

Nexus 1000v remove unused Uplink port-profile

Mate Grbavac
Level 1
Level 1


while first time setting up Nexus 1000v i created some uplink port-profiles. Now, I created new, production, uplink port-profiles and move my vmnics to that new port-profile but can't delete old port-profile because there is still port-channel interface under it.

I tried everything regarding documentation, but I simply can't remove Po2 from Test-SystemUplik port-profile.

Can somebody, please, help me?

port-profile Test-SystemUplink

port-profile Prod-SystemUplink

Nexus1000V-VSM-1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Nexus1000V-VSM-1(config)# port-profile Test-SystemUplink
Nexus1000V-VSM-1(config-port-prof)# no system vlan
This will remove all system vlans from this port profile. Do you really want to proceed(yes/no)? [yes]
ERROR: Cannot remove system vlans, port-profile currently in use by interface Po2

Nexus1000V-VSM-1(config-port-prof)# int po 2
Nexus1000V-VSM-1(config-if)# shut
ERROR: Cannot set port admin status to 'shutdown' for interface inheriting a system port-profile
Nexus1000V-VSM-1(config-if)# no inherit port-profile Test-SystemUplink
ERROR: Port-profile de-inherit not allowd an intf in attached state


Best regards,


11 Replies 11

Robert Burns
Cisco Employee
Cisco Employee

G'day Mate

Do a "show port-profile usage", and verify that the "old" port profile is not being used.

If nothing is using it, you should be able to simply delete it with "no port-profile xxxxxx". 

Once that's removed then delete your Port Channel "no int port-channel x".

Let me know if that works, if not reboot your VSM and try again.



Well, that's the hole problem...

I actually do not using this port profile (don't have any vmnic in that

"old" PP on vCenter) but Nexus from some reason still shows port-channel2

mapped to "old" port-profile, although there is no vmnics.

Part of configuration:

Nexus1000V-VSM-1#sh port-profile usage

port-profile Test-SystemUplink

Which version of 1000v are you running and did you try to reboot the VSM as recommended?

Currently, I'm using Cisco Nexus 4.2(1)SV1(4), but through few days I will

upgrade it to version 4.2(1)SV1(4a).

Yes, I rebooted it also few times.

Best regards, Mate

From: roberbur

To: Mate Grbavac

Date: 03.11.2011 17:24

Subject: - Re: Nexus 1000v remove unused Uplink



Let me know if you still have this issue post-upgrade.  If so, I'd probably advise you to open a TAC case.  I did a bug scrub against both versions and don't see anything bugs that account for this behavior.

One thing I did notice is that you tried to "remove" the system vlans and inheritence from the Port Channel.  Can you try to put one/both commands back and see if it successfully removes then?



I tried everything, but nothing helps.

I have two VSM's and both have same problem.

Simply, after migrating vmnic's on vCenter from one port-profile to

another, old port-profile on VSM keeps old port-channel.

This is not always, just sometimes, but I still didn't find cause.

From: roberbur

To: Mate Grbavac

Date: 04.11.2011 14:16

Subject: - Re: Nexus 1000v remove unused Uplink


I've found the same issue with the same N1kV version. In my case i've tried to create a new port-profile with different name and when i've attached the ESX Interface to the Uplink, N1kV create a new PortChannel for the same ESX than before was ussing another differnet PortChannel Number wth the old Port-Profile. So now i have the old port-profile with Portchannel belonging to the ESX than in fact now are attached to the new one. N1kv is reporting and mismatch vlan configration because has same VLAN ID are in two different uplinks portprofile. Although the old one has nothing connected to it. It is immposible delete, shutdown, disable or whatever other accction because show portchannel (intactive) linked...

Any idea?

thanks a lot

Have you tried rebooting the ESX host and/or VSM?

Another way that should definately clear the discrepency is to remove & re-add the host to the vDS.

1. Evacuate all VMs to other hosts.

2. Ensure any vmk interfaces have been moved off the vDS (to the vSwitch temoprariliy).

3. From vCenter remove the host from the vDS.

4. From the host CLI issue the following commands

vem stop

vem unload

vem load

vem start

(waiting for 5 sec. between each command)

5. Re-add the host in vCenter to the dVS

6. Verify everything is consistent with uplinks & connectivity.

7. Migrate a test VM to this host & test connectivity.

8. Remove any unused port channels from the VSM

show port-channel summary

Doing this should flush any stale config and stabalize the host.




Are you still having an issue with your system?  If so, send me a private message and we'll see if we can setup a session to take a look - unless you've already opened a TAC case.



I am also having this same problem.  A reboot of ESXi hosts and/or the VSM did not help.

FYI: I solved my problem, and wanted to chime in to this thread.  If you run a 'show port-profile usage' to see what interfaces inherited the config, it should list the port-channels that utilize it.  In my case, running a "show int po xx" determined that none of the port-channels had operational members.  To delete the port-profiles, I had to first delete the port-channels (all of them, using "no int po xx"), then use "no system vlan" in the port-profile, then remove the port-profile with the 'no port-profile xx" command.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card