cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3288
Views
0
Helpful
13
Replies
Highlighted
Beginner

Adding ports to a vlan on Fabric interconnect (End-host Mode)

Hi All,

 

I have an issue, i created vlan 99 and added the ports and port-channel to the vlan on the ucs fabric interconnects and saved the configs.

 

To my surprise nothing has changed, they are still on vlan 1 (default).

See my configuration below.

UCS-A# scope eth-uplink
UCS-A /eth-uplink # create vlan EMM_NET 99
UCS-A /eth-storage/vlan* # create member-port a 1 15
UCS-A /eth-storage/vlan* # create member-port a 1 16
UCS-A /eth-storage/vlan* # create member-portchannel a 61
UCS-A /eth-uplink/vlan* # set sharing none
UCS-A /eth-uplink/vlan* # commit-buffer
UCS-A /eth-uplink/vlan #

Or should i only create vlan 99 on the northbound switch (Nexus5548UP) since the Fabric Interconnect is in end-host mode?????????????

 

Regards,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

OK, now you have to give us more detailed information ?

what is you OS ? ESXi ?

And maybe, depending how your host is configured, you should make Vlan 99 as the native vlan !

View solution in original post

13 REPLIES 13
Highlighted
Advocate

If you create a new Vlan (most likely for both fabrics), it will automatically be included in all uplink trunks ! you don't have to do any special action.

Connect nx-os and do the proper CLI commands, like "show interface brief",... sho interface ...

Highlighted

Hi Wdey,

 

I tried that, still no changes, see the attached screenshots.

Below is the output from the show interface:

 

EMM-UCS-A(nxos)# show interface eth1/15-16
Ethernet1/15 is up
  Hardware: 1000/10000 Ethernet, address: 002a.6a6f.e896 (bia 002a.6a6f.e896)
  Description: U: Uplink
  MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 10 Gb/s, media type is 10G
  Beacon is turned off
  Input flow-control is off, output flow-control is off
  Rate mode is dedicated
  Switchport monitor is off
  EtherType is 0x8100
  Last link flapped 21:30:59
  Last clearing of "show interface" counters never
  30 seconds input rate 1576 bits/sec, 197 bytes/sec, 1 packets/sec
  30 seconds output rate 72 bits/sec, 9 bytes/sec, 0 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 1.22 Kbps, 1 pps; output rate 144 bps, 0 pps
  RX
    3690 unicast packets  8690660 multicast packets  171390 broadcast packets
    8865740 input packets  723784844 bytes
    0 jumbo packets  0 storm suppression bytes
0 giants      0 input error  0 short frame  0 overrun   0 underrun      0 watchd
og  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    2 unicast packets  565878 multicast packets  21336 broadcast packets
    587216 output packets  142538564 bytes
    0 jumbo packets
    0 output errors  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause
  2 interface resets

Ethernet1/16 is up
  Hardware: 1000/10000 Ethernet, address: 002a.6a6f.e897 (bia 002a.6a6f.e897)
  Description: U: Uplink
  MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 10 Gb/s, media type is 10G
  Beacon is turned off
  Input flow-control is off, output flow-control is off
  Rate mode is dedicated
  Switchport monitor is off
  EtherType is 0x8100
  Last link flapped 21:30:59
  Last clearing of "show interface" counters never
  30 seconds input rate 464 bits/sec, 58 bytes/sec, 0 packets/sec
  30 seconds output rate 72 bits/sec, 9 bytes/sec, 0 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 504 bps, 0 pps; output rate 144 bps, 0 pps
  RX
    2691 unicast packets  946092 multicast packets  262803 broadcast packets
    1211586 input packets  190929407 bytes
    0 jumbo packets  0 storm suppression bytes
0 giants      0 input error  0 short frame  0 overrun   0 underrun      0 watchd
og  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    0 unicast packets  565177 multicast packets  26 broadcast packets
    565203 output packets  129867445 bytes
    0 jumbo packets
    0 output errors  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause
  2 interface resets

EMM-UCS-A(nxos)#

 

 

Highlighted

show interface trunk
 
To display information about all the trunk interfaces, use the show interface trunk command.
 
show interface [ethernet type/slot | port-channel channel-number] trunk [module number | vlan vlan-id]

Highlighted

Hi Wdey,

 

I'm lil confused there!!! It doesn't take the command

 

 show interface ethernet 1/15 | port-channel 61 trunk 1 | vlan 99

 

Is that correct???

 

Highlighted

show interface ethernet 1/15 trunk ....

Highlighted

EMM-UCS-A(nxos)# show interface ethernet 1/15-16 trunk

--------------------------------------------------------------------------------
Port          Native  Status        Port
              Vlan                  Channel
--------------------------------------------------------------------------------
Eth1/15       1       trnk-bndl     Po61
Eth1/16       1       trnk-bndl     Po61

--------------------------------------------------------------------------------
Port          Vlans Allowed on Trunk
--------------------------------------------------------------------------------
Eth1/15       1,99
Eth1/16       1,99

--------------------------------------------------------------------------------
Port          Vlans Err-disabled on Trunk
--------------------------------------------------------------------------------
Eth1/15       none
Eth1/16       none

--------------------------------------------------------------------------------
Port          STP Forwarding
--------------------------------------------------------------------------------
Eth1/15       none
Eth1/16       none

--------------------------------------------------------------------------------
Port          Vlans in spanning tree forwarding state and not pruned
--------------------------------------------------------------------------------
Eth1/15       --
Eth1/16       --

 

 

 

EMM-UCS-A(nxos)# show interface port-channel 61
port-channel61 is up
  Hardware: Port-Channel, address: 002a.6a6f.e896 (bia 002a.6a6f.e896)
  Description: U: Uplink
  MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA
  Port mode is trunk
  full-duplex, 10 Gb/s
  Beacon is turned off
  Input flow-control is off, output flow-control is off
  Switchport monitor is off
  EtherType is 0x8100
  Members in this channel: Eth1/15, Eth1/16
  Last clearing of "show interface" counters never
  30 seconds input rate 2184 bits/sec, 273 bytes/sec, 1 packets/sec
  30 seconds output rate 160 bits/sec, 20 bytes/sec, 0 packets/sec
  Load-Interval #2: 5 minute (300 seconds)
    input rate 1.73 Kbps, 1 pps; output rate 296 bps, 0 pps
  RX
    6487 unicast packets  9645844 multicast packets  436377 broadcast packets
    10088708 input packets  915809390 bytes
    0 jumbo packets  0 storm suppression bytes
0 giants      0 input error  0 short frame  0 overrun   0 underrun      0 watchdog  0 if down drop
    0 input with dribble  0 input discard
    0 Rx pause
  TX
    2 unicast packets  1131784 multicast packets  21362 broadcast packets
    1153148 output packets  272571179 bytes
    0 jumbo packets
    0 output errors  0 collision  0 deferred  0 late collision
    0 lost carrier  0 no carrier  0 babble
    0 Tx pause
  3 interface resets

 

EMM-UCS-A(nxos)# sho run int eth1/15-16

!Command: show running-config interface Ethernet1/15-16
!Time: Wed May 28 06:59:10 2014

version 5.0(3)N2(2.11.3a)

interface Ethernet1/15
  description U: Uplink
  pinning border
  switchport mode trunk
  switchport trunk allowed vlan 1,99
  channel-group 61 mode active
  no shutdown

interface Ethernet1/16
  description U: Uplink
  pinning border
  switchport mode trunk
  switchport trunk allowed vlan 1,99
  channel-group 61 mode active
  no shutdown

 

Highlighted

OK, nice, your Vlan 99 appears !

Is your problem solved ?

Highlighted

Not yet, i can't ping the servers. I have added the Nics to vlan 99 on the service profile template.

That's the only thing left

Highlighted

Not yet, i can't ping the servers. I have added the Nics to vlan 99 on the service profile template.

 

 

Highlighted

OK, now you have to give us more detailed information ?

what is you OS ? ESXi ?

And maybe, depending how your host is configured, you should make Vlan 99 as the native vlan !

View solution in original post

Highlighted

It worked after i changed i made vlan 99 a native vlan.

 

Thank you!!!! You're a star smileyyes

Highlighted

Perfect ! Congratulation ! one problem less :-)

Have a nice day

Walter.

Highlighted

show interface trunk
 
To display information about all the trunk interfaces, use the show interface trunk command.
 
show interface [ethernet type/slot | port-channel channel-number] trunk [module number | vlan vlan-id]

Content for Community-Ad