Showing results for 
Search instead for 
Did you mean: 
Field Notice 70545

B250 M2 unable to install Microsoft Hyper-V Server 2012 R2

Hi All,


My Environment:

2x FI 6248 (v2.2.1)

2x 5108 Chassis

1x B200 M2

1x B250 M2


I am experiencing an annoyed OS installation symptom. I tried installing Microsoft Hyper-V 2012 R2 on my B250 M2 blade but unfortunately it give error message "we couldn't create a new partition or locate an existing one". 


Based on forum, i had tried many ways (diskpart, map/unmap DVD, reboot) but with NO luck so far.


Note: I managed to install Windows Server 2012 R2 on B200 M2 and B250 M2 blade.


Look forward to your help.

Walter Dey

According to the tool

B250-M2 doesn't support Windows Server 2012 R2 under 2.2.1.

I don't think that there is a separate certification for Hyper-V 2012 R2 ?

However, B200-M2 should work ok.

- is this a network install or local disk ?

Hi Wdey,


Thanks for your fast reply.


Yes, the Matrix didn't show Windows Server 2012 R2 for B250M2.

BUT in fact, i had successfully installed Windows Server 2012 R2 on B200M2 and B250M2.

I don't think so, there is separate certification for Hyper-V 2012 R2 server.

I had also tried installing Hyper-V 2012 R2 on B200M2 but receives same error "we couldn't create a new partition or locate an existing one". 


I am installing Hyper-V on my SAN disk (NetApp). I must load the driver (M81KR) to detect the LUN and map back my OS installer to continue the installation.


We really need to Hyper-V to be installed on B250M2.


​Look forward to your advice.




Regarding B250-M2; I fully understand your point; however, if you open a TAC case, the engineer will check the matrix, and say sorry. It's really the tradeoff of it's working but not supported. In your case, something odd must be wrong; there shouldn't be a difference between Server 2012 R2 and Hyper-V 2012 R2.

I assume you know

otherwise your Server 2012 R2 installation wouldn't be successful.

Q. In the Hyper-V installation: do you see the LUN ?

I would open a TAC case for B200-M2 !

Good luck


Hi Walter,


Yes, after mapping the driver, i saw the LUNs and then i map my installation iso to continue. When i click next, error appears again :-(.

I suspect, something strange happens for my case/issue.

Even i tested my iso media on other machine, it works. So not the media, hmmmm



I assume you installed enic/fnic drivers ?

Do you have only one path open to the lun ? Multipathing is not yet installed / configured

Hi Walter,


Install fnic driver because we are using FC.

I have two path to the same LUNs which shows during installation setup.

Usually, after completed OS installation, i will enable the MPIO feature. Can i enable during the installation?

Any other suspect or breakthrough with my issue?

I don't think thats the problem, but I would disable the second path to the lun (e.g. by moving the VSAN of the vhba to the default one (VSAN 1))

Switching from driver iso back to OS iso: did you do a refresh ?



I guess you have more paths to the lun than target wwpns defined in your boot policy. The lun where you try to install the windows os is probably listed multiple times at the installer (as many times as there are paths to the storage array). You have to choose the lun which is offered from one of the wwpn you have defined in the boot policy, otherwise the windows installer won't let you continue because there is a check if it is possible to boot from that disk after the installation.

Another issue might be if you mixed up the target wwpn in the boot policy, for example you defined for the first vHBA (assuming over fabric interconnect A), the target wwpn of the port which is only reachable over the second vHBA (FI B).


I just checked the screenshot ;) okay there are two paths.

If the wwpn at the associated boot policy are correct, try to run disk part and take disk 4 offline and enable disk 5 and do the installation on this one.


hope this helps


kind regards



It seems that MSFT has a lot of patches for Windows Server 2012 R2

Recognize Your Peers
Content for Community-Ad