cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
AMA event- Migrating Existing Networks to Cisco ACI
20768
Views
5
Helpful
12
Replies
Beginner

Boot device / boot media access

Hi folks,

I need help!  I can't get my server to boot to the ESXi iso.

"Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key"

Brand new UCS environment racked and cabled 2 weeks ago.  4 UCS C240 M4 S2 connected via VIC1227 to a pair of 6296 FIs.  Created policies, service profile template, and service profile.  Associated one server to a service profile, etc...

Boot order is set via Boot Policy:

1: CD/DVD

2: SD Card (yes, FlexFlash has been enabled)

Via the KVM Console I activate virtual media, mount the ESXi iso, and let the system boot.  I get the above message.  I have tried F6 and selecting all options: vKVM Mapped vDVD, CIMC-Mapped vDVD, and KVM vmDisk-CD.  No luck.

This isn't my first rodeo with UCS, but it is with C-Series servers managed via UCS.  Please provide any assistance you can think of!

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Thanks Tom,

Thanks Tom,

When creating your boot policy, are you using "Add CD/DVD" or "Add Local CD/DVD"?

Try using Add CD/DVD option and see if the issue persists. You may also try local CD/DVD if you are using the first option.

Have you tried using any other ISO just to ensure the one you are using it not corrupted, etc?

HTH,

Wes

View solution in original post

12 REPLIES 12
Advocate

Hi Tom

Hi Tom

Did discovery properly work for your server ?

Did you upgrade BIOS, CIMC, adaptor ?

Which version are you using ?

Option ROM enabled for the proper devices ?

Walter.

Beginner

Hi Walter,

Hi Walter,

Thank you for replying!  Yes, discovery worked properly and I have set the host firmware policy to 3.1.1h (leaving default package versions selected).  Installed firmware versions:

BIOS - C240M4.2.0.10c.0.032320160820

CIMC - 2.0(10b)

Adapter (MLOM 1227) - 4.1(1f)

HBA Option ROM - n/a

Option ROM -

Quiet Boot is set to Platform Default.  I was not sure if this was set to disabled or not, so I disabled it, no noticeable change during POST or boot, so I assume the default is disabled.

LOM and PCIe slots - all Platform Default here.  

Thank you,

Tom

Cisco Employee

Tom,

Tom,

You will need to ensure a few things when booting from Flexflash SD:

1. Ensure you enable Flexflash scrub on the disk(s) prior to use. This will require a re-ack of the service profile to complete.

2. Ensure we are using default BIOS policy if you are using a custom BIOS policy, and see if the issue persists.

Reference:

http://www.cisco.com/c/en/us/products/collateral/servers-unified-computing/ucs-c-series-rack-servers/whitepaper-c11-734876.html

HTH,

Wes

Beginner

Hello Wes,

Hello Wes,

1. I was using the default scrub policy, but have now changed Flexflash scrub to Yes.  I don't think this is part of my problem (yet) because I haven't been able to boot to a KVM-mounted iso.

2. BIOS Policy - there is no 'default' option, only SRIOV and usNIC.  I had modeled my BIOS policy after this Cisco reference architecture.  I found where I can set the BIOS policy to 'use default' though, and have tried this.

However, trying both of the above change has yielded no different effects.  The server still does not seem to recognize that an ISO is mounted to CD/DVD virtual device.

Thanks!

Cisco Employee

Thanks Tom,

Thanks Tom,

When creating your boot policy, are you using "Add CD/DVD" or "Add Local CD/DVD"?

Try using Add CD/DVD option and see if the issue persists. You may also try local CD/DVD if you are using the first option.

Have you tried using any other ISO just to ensure the one you are using it not corrupted, etc?

HTH,

Wes

View solution in original post

Advocate

Hi Tom

Hi Tom

Can you please check in the service profiles: configured boot order / actual boot order ?

It seems to me, that the SP is not properly setting up the boot order ?

Can you try to enter BIOS during the boot process, and configuring boot order there ?

Walter.

Beginner

Hi Wes and Walter,

Hi Wes and Walter,

This was it!  My Boot Policy boot order was set to:

1. CD/DVD

2. SD Card

I added the CIMC Mounted CD/DVD and Remote Virtual Drive before the others:

1. CIMC Mounted CD/DVD

2. Remote Virtual Drive

3. CD/DVD

4. SD Card

Rebooted, and viola!  The ESXi installer started loading.

THANK YOU!

Best regards,

Tom

Beginner

Re: Thanks Tom,

The Remote CD/DVD boot option on my Boot policy worked which gives the option to anble the KVM mounted CD/DVD option......

Beginner

Re: Thanks Tom,

Hi Arun & Tom

 

I would like to map iso image to kvm automatically and boot the server automatically. i searched google and found some articles this can be done via Vmedia policy. could you please share if you have the document to implement.

 

Thanks in Advance 

Highlighted
Cisco Employee

Re: Thanks Tom,

Beginner

Re: Thanks Tom,

Hi Mojafri

 

Thanks for sharing the detailed cisco document, I will go through and follow the same.

 

Cheers.

Beginner

Re: Thanks Tom,

Hi Mojafri

 

Presently i can able to install the operating system using vMedia policy.

However after installed the operating system still booting via vmedia policy and again starting the installation. 

Could you please tell me how to configure below way?

precede mounted vMedia in the boot order would result in a “first-time-only” use of the mounted vMedia.  Once the OS is installed on the disk, the vMedia mount would not be used,

 

Thank you.

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards