cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
AMA event- Migrating Existing Networks to Cisco ACI
2827
Views
1
Helpful
14
Replies
Highlighted
Beginner

Bug: Sorting VLANs on UCSC does not work properly

Developers,

I have 54 VLANS in UCSC, sorting by VLAN ID is critical for us.  When I sort by VLAN the UI has a bug where the complete list of VLANs is no longer listed.

See attached word doc.

We are running 1.2(1d).

Please log a bug and fix.  You will need to have at least 54 vlans in your test case to reproduce.

Thanks,

Ben

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Hey Ben,

This was a bug, and it's fixed. I just tested in my lab version 1.2.1f. Please see attached, and upgrade at your convenience.

Also know that UCSC Version 1.3 is expected to be GA soon.

Best Regards,

Matt

View solution in original post

14 REPLIES 14
Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Hey Ben,

This was a bug, and it's fixed. I just tested in my lab version 1.2.1f. Please see attached, and upgrade at your convenience.

Also know that UCSC Version 1.3 is expected to be GA soon.

Best Regards,

Matt

View solution in original post

Enthusiast

Re: Bug: Sorting VLANs on UCSC does not work properly

Hi Matt,

Unfortunately this still occurs in 1.2(1f).  We upgraded from 1d to 1f this Monday and the symptoms are the same.  For what it's worth, old/removed VLANs still show as assignable options for vNICs despite not existing in the LAN cloud so perhaps there is some back-end issue on our installation?

-Alex

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

OK, sorry for the problem you are having.

Can you verify that you have also deleted the Org Permissions for those old/removed VLANs, and then see if that helps.

Just asking...for the graphical problem, have you tried accessing with another client, or perhaps consider your Flash Version?

Enthusiast

Re: Bug: Sorting VLANs on UCSC does not work properly

In terms of the VLANs still showing as options in vNICs you hit the nail on the head.  I never would have considered having to remove the org permission on a VLAN that no longer exists...

Unfortunately that didn't fix the VLAN sorting issue though.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Understand, and I don't like that behavior as well. Will see what engineering can do about that going forward.

Do you experience the UI, VLAN Sorting problem on more than one client accessing UCSC?

Enthusiast

Re: Bug: Sorting VLANs on UCSC does not work properly

Confirmed on 2 different clients both in IE and Chrome.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Let me investigate more and get back with you.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Alex, I deployed a new 1.2.1f, and I used UCSC PowerTools to instantiate 51 VLANs.

I used Chrome, IE and Firefox, and all three browsers were successful at sorting the 51 VLANs. I will say, there was a consistent "nuance" when I scrolled through the VLANs, and then followed that action with a "ID Sort"....it seems that a single VLAN would be "out of order" at the top of the UI....nothing that a simple "Refresh" using the button on the screen didn't fix however.

Are you running a older version of Flash, and have you tried to upgrade Flash?

Thanks,

Matt

Enthusiast

Re: Bug: Sorting VLANs on UCSC does not work properly

Chrome auto-updates flash so that should be at least recent.  I also manually updated flash from version 15.x (installed in November to 17.0.0.134 but still experience the problem.  Our version of UCSC was originally a 1.1x and has been updated 4-5 times to 1f if that helps.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Alex, I am not sure of how large your infrastructure is, but we are "imminent" with the Release of UCSC 1.3, Some Major Enhancements are the introduction of a new "HTML-5" UI (while also keeping the traditional Flash-Based UI), and also the introduction of NFS-Based Clustering for UCSC-HA.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Greetings Ben, pardon if you've communicated this to another person in Cisco, but it's the first I've heard of the timer being a problem. I understand, and I can try to communicate additional flexibility going forward.....but the behavior will be the same with 1.3.

Cisco Employee

Re: Bug: Sorting VLANs on UCSC does not work properly

Alex, Have you tired to completely delete your Flash Cache in the Flash Settings Manager, Control Panel/System and Security/Flash?

Enthusiast

Re: Bug: Sorting VLANs on UCSC does not work properly

Tried it on two different clients in both IE and Chrome (including clearing all cached data through Chrome).  No luck.

Beginner

Re: Bug: Sorting VLANs on UCSC does not work properly

I've also tried this on multiple browsers and devices (1 Win7, 1 Win2008 R2).  VLAN sorting is still not working.

Ben

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards