cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Webcast SD-WAN
2279
Views
0
Helpful
8
Replies
Highlighted

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

I have a C210 M2 server that is failing with an apparent (?) hardware issue. From the UCS cli, I see the following:

# show fsm status

ID: 11

Server: sys/rack-unit-11

    FSM 1:

        Remote Result: Service Unavailable

        Remote Error Code: 4106

        Remote Error Description: Invalid HBA for Cisco VIC adapter

        Status: Discover Pnuosinventory

        Previous Status: Discover Pnuosinventory

        Timestamp: 2012-11-08T15:52:48.856

        Try: 6

        Flags: 0

        Progress (%): 53

        Current Task: Perform inventory of server 11 pre-boot environment(FSM-STAGE:sam:dme:ComputeRackUnitDiscover:PnuOSInventory)

    FSM 2:

        Status:

        Previous Status:

        Timestamp:

        Try:

        Flags:

        Progress (%):

        Current Task:

And the console seems stick in a loop:

Any advice is appreciated.

Cheers,

Paul

Everyone's tags (7)
8 REPLIES 8
Cisco Employee

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Hello Paul,

Is this new server being integrated to UCSM ?

Can you please let me know the topology ?

What is the current firmware on the rack server ( CIMC , BIOS and P81E adapter ) ?

Padma

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Padma,

This is a server being integrated into an existing UCSM environment.

The topology is C6248 FIs and C2232 FEXs running firmware 2.0(3c)

Here's the firmware details for the server in question.

# show firmware

Server 11:

    CIMC:

        Running-Vers: 1.2(2d)

        Package-Vers:

        Update-Status: Ready

        Activate-Status: Ready

    Adapter 1:

        Running-Vers:

        Package-Vers:

        Update-Status:

        Activate-Status:

    BIOS:

        Running-Vers: C200.1.4.1.0.071320110702

        Package-Vers:

        Update-Status:

        Activate-Status: Ready

    RAID Controller 1:

        Running-Vers:

        Package-Vers:

        Activate-Status:

    RAID Controller 2:

        Running-Vers: 12.12.0-0060

        Package-Vers:

        Activate-Status: Ready

atl01-ucsf01a-A /server # scope adapter 1

atl01-ucsf01a-A /server/adapter # show detail

Adapter:

    Id: 1

    Product Name: Cisco UCS P81E

    PID: N2XX-ACPCI01

    VID: V00

    Vendor: Cisco Systems Inc

    Serial: QCI1543AG7D

    Revision: 0

    Mfg Date: 2011-10-31T00:00:00.000

    Slot: 1

    Overall Status: N/A

    Conn Path: Unknown

    Conn Status: Unknown

    Managing Instance: B

    Product Description: PCI Express Dual Port Cisco Converged Network Adapter Supporting 10Gb Ethernet and 4Gb Fibre Channel

Glad to provide any additional information.

Cheers,

Paul

Cisco Employee

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Hello Paul,

Since this is a new rack server being integrated to UCSM, please disconnect the cables and upgrade the firmware components to minimum recommended version via HUU

Summary of required steps

1)  Disconnect the cables and bring up the rack server in stand alone mode

2)  Configure CIMC with an IP address

3)  Use HUU 1.4.3K image to upgrade all firmware components

4)  Cold reboot the server ( remove the cable to PSU )

5)  Reset the CIMC to factory default

6)  Manually power off the server

7)  Connect the cables to

             LOM 1 and VIC port 0 to  FEX 1

             LOM 2 and VIC port 1 to  FEX 2

8) Power on the server

9) Monitor the discovery process via UCSM /KVM console

1.4.3k HUU download link

http://www.cisco.com/cisco/software/release.html?mdfid=283862069&flowid=25882&softwareid=283850974&release=1.4%283k%29&relind=AVAILABLE&rellifecycle=&reltype=latest

UCSM Integration guide

http://www.cisco.com/en/US/customer/docs/unified_computing/ucs/c-series_integration/ucsm2.0.2/b_UCSM_202_C-Integration_chapter_01.html

HTH

Padma

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Padma,

The server is located in a remote datacenter. Is it possible to do this remotely?

Cheers,

Paul

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Padma,  Our site engineers followed the instructions you provided, and upgraded the firmware using the Host Upgrade Utility. However, server discovery now fails with a different error. Here's what I see:  atl01-ucsf01a-A# scope server 11 atl01-ucsf01a-A /server # show fsm status  ID: 11 Server: sys/rack-unit-11      FSM 1:         Remote Result: Intermittent Error         Remote Error Code: Err Insufficiently Equipped         Remote Error Description: No connected adaptors         Status: Discover Fail         Previous Status: Discover Fail         Timestamp: 2012-12-04T16:30:47.240         Try: 0         Flags: 0         Progress (%): 99         Current Task: Invoke post-discovery policies on server 11(FSM-STAGE:sam:dme:ComputeRackUnitDiscover:HandlePooling)      FSM 2:         Status:         Previous Status:         Timestamp:         Try:         Flags:         Progress (%):         Current Task:  atl01-ucsf01a-A /server # show firmware Server 11:     CIMC:         Running-Vers: 1.4(3k)         Package-Vers: 2.0(3c)C         Update-Status: Ready         Activate-Status: Ready      Adapter 1:         Running-Vers:         Package-Vers:         Update-Status:         Activate-Status:     BIOS:         Running-Vers: C200.1.4.3f.0.032920122244         Package-Vers: 2.0(3c)C         Update-Status:         Activate-Status: Ready      RAID Controller 1:         Running-Vers:         Package-Vers:         Activate-Status:      RAID Controller 2:         Running-Vers: 12.12.0-0087         Package-Vers: 2.0(3c)C, 2.0(2r)C         Activate-Status: Ready  atl01-ucsf01a-A /server # scope adapter 1 atl01-ucsf01a-A /server/adapter # show detail  Adapter:     Id: 1     Product Name: Cisco UCS P81E       PID: N2XX-ACPCI01     VID: V00     Vendor: Cisco Systems Inc     Serial: QCI1543AG7D     Revision: 0     Mfg Date: 2011-10-31T00:00:00.000     Slot: 1     Overall Status: N/A     Conn Path: Unknown     Conn Status: Unknown     Managing Instance: B     Product Description: PCI Express Dual Port Cisco Converged Network Adapter Supporting 10Gb Ethernet and 4Gb Fibre Channel  atl01-ucsf01a-A /server/adapter #   Any suggestions are appreciated.  Cheers,  Paul

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

(this time with html formatting)

Padma, 

Our site engineers followed the instructions you provided, and  upgraded the firmware using the Host Upgrade Utility. However, server  discovery now fails with a different error. Here's what I see:

atl01-ucsf01a-A# scope server 11

atl01-ucsf01a-A /server # show fsm status

ID: 11

Server: sys/rack-unit-11

    FSM 1:

        Remote Result: Intermittent Error

        Remote Error Code: Err Insufficiently Equipped

        Remote Error Description: No connected adaptors

        Status: Discover Fail

        Previous Status: Discover Fail

        Timestamp: 2012-12-04T16:30:47.240

        Try: 0

        Flags: 0

        Progress (%): 99

        Current Task: Invoke post-discovery policies on server 11(FSM-STAGE:sam:dme:ComputeRackUnitDiscover:Hand

lePooling)

    FSM 2:

        Status:

        Previous Status:

        Timestamp:

        Try:

        Flags:

        Progress (%):

        Current Task:

atl01-ucsf01a-A /server # show firmware

Server 11:

    CIMC:

        Running-Vers: 1.4(3k)

        Package-Vers: 2.0(3c)C

        Update-Status: Ready

        Activate-Status: Ready

    Adapter 1:

        Running-Vers:

        Package-Vers:

        Update-Status:

        Activate-Status: 

    BIOS:

        Running-Vers: C200.1.4.3f.0.032920122244

        Package-Vers: 2.0(3c)C

        Update-Status:

        Activate-Status: Ready

    RAID Controller 1:

        Running-Vers:

        Package-Vers:

        Activate-Status: 

    RAID Controller 2:

        Running-Vers: 12.12.0-0087

        Package-Vers: 2.0(3c)C, 2.0(2r)C

        Activate-Status: Ready

atl01-ucsf01a-A /server # scope adapter 1

atl01-ucsf01a-A /server/adapter # show detail

Adapter:

    Id: 1

    Product Name: Cisco UCS P81E

    PID: N2XX-ACPCI01

    VID: V00

    Vendor: Cisco Systems Inc

    Serial: QCI1543AG7D  

    Revision: 0

    Mfg Date: 2011-10-31T00:00:00.000

    Slot: 1

    Overall Status: N/A  

    Conn Path: Unknown

    Conn Status: Unknown 

    Managing Instance: B 

    Product Description: PCI Express Dual Port Cisco Converged Network Adapter Supporting 10Gb Ethernet and 4Gb

Fibre Channel

atl01-ucsf01a-A /server/adapter # show fsm status

                                           ^

% Invalid Command at '^' marker

atl01-ucsf01a-A /server/adapter # up

atl01-ucsf01a-A /server # show fsm status

ID: 11

Server: sys/rack-unit-11 

    FSM 1:

        Remote Result: Not Applicable

        Remote Error Code: None

        Remote Error Description:

        Status: Discover Pnuosident

        Previous Status: Discover Pnuosident

        Timestamp: 2012-12-04T16:41:59.757

        Try: 1

        Flags: 0

        Progress (%): 50 

        Current Task: Identify pre-boot environment agent on server 11(FSM-STAGE:sam:dme:ComputeRackUnitDiscove

r:PnuOSIdent)

    FSM 2:

        Status:

        Previous Status: 

        Timestamp:

        Try:

        Flags:

        Progress (%):

        Current Task:

atl01-ucsf01a-A /server #

Any suggestions are appreciated.

Cheers,

Paul

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

I opened a TAC case with Cisco, and they shipped a replacement P81E adapter, which resolved the issue.

Cisco Employee

C210 M2 server failure: "Invalid HBA for Cisco VIC adapter"

Paul ,

I did replace the palo card on the server and it helped to complete the discovery of the rackmount.

Important to mention that the UCS server was integrated with UCSM so we checked cabling and hardware however adapter was the culprit.

Glad to hear the issue was resolved.

David

CreatePlease to create content
Content for Community-Ad
June's Community Spotlight Awards