Showing results for 
Search instead for 
Did you mean: 

cannot see hba in my brocade switch

I got my brocade switch attached to my fabric interconnects. on the brocade switch the port is an F port and I can see that the FIs are showing up on the brocade switch via the port HBA WWPNs. 


But when I boot up my ucs blade I am not seeing that blades hbas showing up in the brocade switch


any idea?

Cisco Employee

Hi Tony,Is you blade booting

Hi Tony,

Is you blade booting from SAN?  If you are blade is not configure to boot from SAN, you will not see the wwpns of the servers until the server boot up.  Not only that if you don't have the drivers installed on your blade assuming is not boot from san, you will not see the flogi.



Tony,You should also check


You should also check and see if NPIV is enable on your switch.




Npiv is called Access Gateway

Npiv is called Access Gateway with Brocade


Did you ever figure this out?

Did you ever figure this out? I'm encountering the same exact problem. FIs are showing up on the Brocade, but I cannot see each individual blade's vHBAs.


If NPIV (Brocade Access

If NPIV (Brocade Access Gateway, which is a per port command) is not enabled, you only see one flogi, the link between FI and Brocade !


Thanks for that. After some

Thanks for that. After some more researching, it appears my Brocade is not in AG mode. It's in Native. That apparently won't work with vHBAs?


Sorry for the confusion:

Sorry for the confusion: putting a Brocade switch to AG mode is disruptive; the switch will reboot; this corresponds to a MDS NPV mode !

By default, NPIV is enabled, see below. Therefore your setup with UCS should work, without any special setup on the Brocade (Zoning of course needs to done).

Viewing NPIV port configuration information

  1. Connect to the switch and log in using an account assigned to the admin role.
  2. Enter the portCfgShow command to view the switch ports information.

    The following example shows whether a port is configured for NPIV:

    switch:admin> portcfgshow
    Ports of Slot 0    0  1  2  3    4  5  6  7    8  9 10 11   12 13 14 15
    Speed             AN AN AN AN   AN AN AN AN   AN AN AN AN   AN AN AN AN 
    Trunk Port        ON ON ON ON   ON ON ON ON   ON ON ON ON   ON ON ON ON 
    Long Distance     .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    VC Link Init      .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    Locked L_Port     .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    Locked G_Port     .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    Disabled E_Port   .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    ISL R_RDY Mode    .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    RSCN Suppressed   .. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    Persistent Disable.. .. .. ..   .. .. .. ..   .. .. .. ..   .. .. .. .. 
    NPIV capability   ON ON ON ON   ON ON ON ON   ON ON ON ON   ON ON ON ON

see e.g.

Configuring NPIV

The NPIV feature is enabled by default. You can set the number of virtual N_Port IDs per port to a value from 1 through 255 per port. The default setting is 126.

The portCfgNPIVPort command is used to specify the maximum number of virtual N_port IDs per port on a switch. It can also be used to enable or disable NPIV. Once NPIV is enabled on the port, you can specify the number of logins per port. If the NPIV feature has been disabled, then the NPIV port configuration does not work.

The addressing mode can limit the maximum number of NPIV logins to 127 or 63 depending on the mode. The portCfgNPIVPort command can set the maximum number of NPIV logins limit to anything from 1 through 255, regardless of the addressing mode. Whichever of these two (addressing mode or the value configured through portCfgNPIVPort) is lower will be the maximum number that can be logged in.


Oh you didn't confuse me. You

Oh you didn't really confuse me. You pointed me in the right direction

NPIV capability is turned ON for the ports on the Brocade, but it is in Native mode. It won't be able to see the N ports from my WWPN pool unless I changed it to AG. Right?


Or are you saying I can be in Native mode on the Brocade and make this work?




Brocade in native mode is

Brocade in native mode is perfect ; check that the port has NPIV capability, and this should work.

You see one flogi per native FC link between FI and Brocade, and then additional ones for every pwwn initiator vhba from your service profiles.....


OK. Thank you for your

OK. Thank you for your help.


If the SP is assoicated, and

If the SP is assoicated, and you have configured vhba's, you should see the flogi of the initiator pwwn's.

Some useful command can be found in

Good luck !


I got it to finally work. For

I got it to finally work. For some uknown reason, the FCoE VLAN ID got set to 1, thus causing all sorts traffic disruption because other IDs were set to 1 as well.

See Cisco's 'Note' here:

FCoE VLANs in the SAN cloud and VLANs in the LAN cloud must have different IDs. Using the same ID for an FCoE VLAN in a VSAN and a VLAN results in a critical fault and traffic disruption for all vNICs and uplink ports using that FCoE VLAN. Ethernet traffic is dropped on any VLAN which has an ID that overlaps with an FCoE VLAN ID.


Silly setting to overlook but now I know.



Good to hear !I hope you have

Good to hear !

I hope you have a different VSAN id's for Fabric A and B, different from 1, and map the corresponding FCoE Vlan ID to some high number, eg. offset of 3500.

CreatePlease to create content