cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5015
Views
20
Helpful
7
Replies
Arthur Luke
Beginner

Cisco custom ISO - Upgrade to ESXi 6.5 - Conflicting VIBS Error

FYI - I was running into an error upgrading to ESXi 6.5 using the Cisco custom ISO's stating "CONFLICTING_VIBS ERROR". Seems to happen on every Cisco custom 6.5 ISO available through VMware:Screen Shot 2019-01-11 at 8.07.26 PM.png

 To get past this, I had to do the following to the existing ESXi install:

From ESXi Console:
alt + F1 (to enter shell)
esxcli software vib remove --vibname scsi-qla2xxx
esxcli software vib remove --vibname scsi-lpfc820

 

Just putting this out here in case someone else is running into this - haven't seen any other posts referencing it, but TAC says that several customers are running into this same problem.

 

 

 

7 REPLIES 7
ccm@dm1n1
Beginner

super info, thank you, 1st hit on google search and this was my issue. saved me a bunch of trouble doing a fresh install and having to reconfig the vm settings. weird part is, I only hit this one one of 6 ucs-b series blades all running same version of 5.5 in the same chassis. not sure why 1 was different than the rest...

martin.malyon
Beginner

I had the exact same issue going from ESXI 5.5 U2 to ESXI 6.5U2, on a UCS C240 M3. Also using the cisco custom image. I had to remove the following vibs using the ESXi console:


esxcli software vib remove --vibname net-ixgbe
esxcli software vib remove --vibname scsi-qla2xxx

esxcli software vib remove --vibname scsi-lpfc820

 

Rather annoyling the last vib scsi-lpfc820 didnt show as a conflict until a second upgrade was attempted. 

 

 

1.png2.png

 

martin.malyon
Beginner

 

 

 

 

 

Hard_Boiled_Greg
Beginner

I had the same problem today when upgrading a Cisco UCS C240 M3S from ESXi 6.0.0 to ESXi 6.5 SU2. The error I received was:

 

============================================================
Error(s)/Warning(s) Found During System Scan
The system encountered the following error(s)
<CONFLICTING_VIBS ERROR: Vibs on the host are conflicting with vibs in metadata. Remove the conflicting vibs or use Image Builder to create a custom ISO providing newer versions of the conflicting vibs.
['VMWare_bootbank_scsi-qla2xxx_901.k1.1-14vmw.500.0.0.469512', 'WMWare_bootbank-scsi-qla2xxx901.k1.1-14vmw.500.0.0.469512']>
===============================================================
 
I opened a TAC case. They had me issue the following command from the ESXi shell:
             esxcli software vib remove --vibname scsi-qla2xxx
 
To do that, I did the following:
1) In the vSphere client, enable the ESXi Shell option in security permissions
2) Open the KVM console to the ESXi session
3) Press ALT-F1 to get to the ESXi shell command prompt
4) Enter the login credentials
5) Enter the following command to delete the conflicting drivers
esxcli software vib remove --vibname scsi-qla2xxx
6) Reboot the Hypervisor server and try the upgrade again
 
After running the suggested command,  I attempted the upgrade again and was successful without the error. Of note, I was using the image VMware_ESXi_6.5.0_10719125_Custom_Cisco_6.5.2.3.iso. 
 
Hard_Boiled_Greg
Beginner

I've had this same issue twice recently when upgrading to either ESXi 6.5 or 6.7. For my recent 6.5 upgrade attempt, I got the following:

"Error(s)/Warning(s) Found During System Scan. The system encountered the following error(s). Builder to create a custom ISO providing newer versions of the conflicting vibs.
QLogic_bootbank_scsi-qla2xxx_934.5.29.0-10EM.500.0.0.472560
Emulex_bootbank_scsi_lpfc820_10.0.727.24-10EM.500.0.0.472560
Emulex_bootbank_scsi_lpfc820_10.0.727.24-10EM.500.0.0.472560
Cisco_bootbank_net-enic_2.1.2.42-10EM.500.0.0.472560
QLogic_bootbank_scsi-qla2xxx_934.5.29.0-10EM.500.0.0.472560
Cisco_bootbank_net-enic_2.1.2.42-10EM.500.0.0.472560']"

 

I opened TAC case 689066644. They had me do the following steps:

1) In the vSphere client, enable the ESXi Shell option in security permissions
2) Open the KVM console to the ESXi session
3) Press ALT-F1 to get to the ESXi shell command prompt
4) Enter the login credentials (root/******)
5) Enter the following command to delete the conflicting drivers
esxcli software vib remove --vibname scsi-qla2xxx
esxcli software vib remove --vibname scsi-lpfc820
esxcli software vib remove --vibname net-enic
6) Reboot the Hypervisor server and try the upgrade again

 

I did this and was able to upgrade without issue.

mukesh.kumar1000
Beginner

I am also having the issue.

error message.bmp

 

esxcli software vib list | grep cisco-vem

cisco-vem-v300-esx 5.2.1.3.2.1.0-6.0.1
=====================================================
] esxcli software vib remove --vibname=cisco-vem-v300-esx
[LiveInstallationError]
Error in running rm /tardisks/cisco_ve.v00:
Return code: 1
Output: rm: can't remove '/tardisks/cisco_ve.v00': Device or resource busy
It is not safe to continue. Please reboot the host immediately to discard the unfinished update.
Please refer to the log file for more details.

mukesh.kumar1000
Beginner

Had rebooted the host , put in the MW but still the same issue.

Content for Community-Ad