cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco UCS Platform Emulator (2.2(1bPE1))

93668
Views
174
Helpful
77
Comments

Cisco UCS Platform Emulator, Release 2.2(1bPE1)

Updated July 25, 2014:  Reposted UCSPE 2.2(1b) to fix the expired certificate issue.


New Hardware Features

Cisco UCS Platform Emulator, Release 2.2(1bPE1), adds support for the following new hardware:

  • SD card - All supported Compute servers now have SD card in their slot.

New Software Features

Cisco UCS Platform Emulator, Release 2.2(1bPE1) includes the following new features:

  • Smartplay bundles with new bundle packs
  • Second-level boot order support for Blade and Rack servers
  • User-Space NIC (usNIC) support for Blade and Rack servers
  • Firmware download support from a local file system
  • Direct Connect Rack configuration feature in the Emulator GUI
  • SD card firmware upgrade support for supported Compute servers

NOTE: From UCS PE 2.2(1bPE1) onwards, UCS PE supports uploading the B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of only the stripped-down versions (attached to this document), which includes only the firmware metadata but not the actual firmware itself in the binaries.  The stripped-down version of the firwmare bundles which contain metadata only of the B-series and C-series server firmware is reduced to approximately 50 kB in size.


Comments
Cisco Employee

Great!  Glad it all worked out for you.

Beginner

Download fails after 5min or around 20MB of download with corrupted zip file.

Cisco Employee

Hi Eric,

          I am using VMplayer. I have opened the UCSPE CLI & have configured the ip address as well. But when I put the ip address of the Eth0 int on Mozilla /Chrome it does not show me the GUI.

Any help would be appreciated.

Rgds

Shuva

Community Member

I am getting an error while importing it into VMware Workstation 10 / Player 6. i have

Cisco_UCS_Platform_Emulator_2.2.1bPE1.ova

Community Member

I too successfully downloaded and imported the OVA using the Player, but I had to upgrade my Player to v6.0.  After starting the VM and logging into the console, I am unable to ping or connect using IE or Chrome, to the IP address presented on the top of the screen.  I tried both static and DHCP addresses.

Cisco Employee

If you don't mind, can we do a WebEx session to troubleshoot it?  It would be beneficial to see the issue you are having, so we can know if it is a broad issue w/ Player, etc since a few of you are having this issue.  Let me know.    

Community Member

It turned out to be AnyConnect VPN. Once I disconnected it I was able to ping and browse to the PE’s IP.

Marc Sugarman

Consulting Systems Engineer

US Data Center - Service Provider

+1 973 441 1194 / Mobile

+1 732 635 4300 / Office

msugarma@cisco.com<mailto:msugarma@cisco.com> / Email

Customers - Visit the Cisco Unified Computing<http://www.cisco.com/en/US/products/ps10265/> page

Community Member

Hi!  I'm getting the following error when trying to import the appliance into virtual box:

Failed to import appliance C:/Users/k.vernon/Desktop/Cisco_UCS_Platform_Emulator_2.2.2cPE1.ova/Cisco_UCS_Platform_Emulator_2.2.2cPE1.ova.

Cannot register the hard disk 'C:\Users\k.vernon\VirtualBox VMs\vm\Cisco_UCS_Platform_Emulator_2.2.2cPE1-disk3_2.vmdk' {72d11c82-efb4-4bad-8efe-ed61b650a97b} because a hard disk 'C:\Users\k.vernon\VirtualBox VMs\vm\Cisco_UCS_Platform_Emulator_2.2.2cPE1-disk3_2.vmdk' with UUID {e45d5d97-de1a-4b8e-ac5c-c56d7a1df0dd} already exists.

Result Code: E_INVALIDARG (0x80070057)
Component: Appliance
Interface: IAppliance {3059cf9e-25c7-4f0b-9fa5-3c42e441670b}
Community Member

i can not download Cisco_UCS_Platform_Emulator_2.2.2cPE1。。。

when it download for 40M or more ,it show finished,but I can not open the zip. what is the matter?

Beginner

Hi Expert,

I tried it on VM Workstation 8, it's able to power up successfully and am able to view the UCS Manager login page. However, I couldn't login due to the following error:

Login Error: java.net.sockettimeoutexception:read timed outjava.net.sockettimeoutexception:read timed out

I'm using JRE: 7U45. I tried different Java v7 version, all having the same issue.

Anyone encounter this?

Btw, how do I upload the picture over here? it seem like the insert image function has been disabled.

Cisco Employee

That error looks like UCSPE didn't unpack properly on VM startup.  Log into the VM console with user config / password config and perform a factory reset.  Let me know if you still have that same issue.    

Secondly, if that doesn't fix it, did you happen to remove any of the three NICs on the VM? 

Thanks,

Eric

Beginner

Hi Eric,

I did the factory reset, but still the outcome is same.

Yes, you're right, I removed the 2nd & 3rd NIC from the VM, as I thought I don't need that in fact. Could that be the reason that I couldn't login?

I noticed the RUN TIME status, the SAM Controller is always show as "STOPPED", is this a normal behaviour? I remember I google somewhere its indicated from some version onward this is the expected behaviour.

Thanks

Cisco Employee

That is your problem.  UCSPE needs ALL three NIC's to be present on the VM.   One NIC represents the Virtual IP for UCS Manager, and the other two represent the Fabric Interconnect A and B's IPs.  Please redeploy the VM from OVA, and make NO edits to the VM configuration, and let me know how it works out.

Thanks,

Eric    

Beginner

Hi Eric,

I deleted away the VM and re-import again, and it's working fine now, yea

But I just couldn't understand, the other two NICs are for FI-A and FI-B as you mentioned, but what I'm facing right now is the UCSM login issue, I can't even view the FI. How's this inter-related?

Many Thanks.

Cisco Employee

They are inter-related because the UCS Platform Emulator won't work properly without all of the three NICs.  Just to clarify, did reimporting a clean VM fix all of the problems?  It wasn't clear from your last message.

CreatePlease to create content
This widget could not be displayed.