cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

Cisco UCS Platform Emulator (3.0(1cPE1))

121541
Views
219
Helpful
101
Comments

Cisco UCS Platform Emulator, Release 3.0(1cPE1)

The UCS Platform Emulator version 3.0(1cPE1) is a platform release that ONLY supports the 6324 Fabric Interconnect based domains.  No other Fabric Interconnect (6100 / 6200) will work with this UCSPE.

New Hardware Features

Cisco UCS Platform Emulator, Release 3.0(1cPE1), adds support for the following new hardware:

  • Fabric Interconnect IOM: UCS-FI-M-6324
  • Chassis: UCSB-5108-AC2 and UCSB-5108-DC2

Known Limitations

  • Cisco UCS Platform Emulator, Release 3.0(1cPE1) has the following limitations:
  • In the UCSM component topology, the link between the rack server and FI is shown as down.
  • While importing with the ‘Live Import’ feature, adapters other than Lexington do not get imported.
  • Firmware version of components in UCSPE is not visible on the Cisco UCS Central.
  • Disconnecting of the servers by unconfiguring their server ports does not impact the server state.
  • We recommended that you check the imported configuration on the Control Panel to ensure there are no missing components or unsupported components. Unsupported or missing components can impact discovery and it is out of the limitation of the UCSPE catalog that such a scenario can occur. We suggest you delete the unsupported components and add the component manually on the Control Panel. Occasionally, import of rack servers might fail.
  • Live import of the configuration is possible only with the UCS Mini and not with other versions of the Cisco UCS Manager.

NOTE: From UCS PE 2.2(1bPE1) onwards, UCS PE supports uploading the B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of only the stripped-down versions (attached to this document), which includes only the firmware metadata but not the actual firmware itself in the binaries.  The stripped-down version of the firwmare bundles which contain metadata only of the B-series and C-series server firmware is reduced to approximately 50 kB in size.

Comments
Enthusiast

When will the Cisco UCS Platform Emulator (3.0(1cPE1)) be availble for download?

Cisco Employee

It just finished uploading.

Enthusiast

Eric,

Thanks for the update. Downloading it now.

Enthusiast

Hello,

I downloaded the OVF file and tried to import it in to my vCenter and am getting an error on import. I am able to extract the .OVF file and see all the  VM files.

Error: "The OVF descriptor is too large"

Any ideas on how to get past this error?

Cisco Employee

What is the file size of the OVF?    It should be -> 480,016,896 bytes (480 MB on disk)

I just deployed it to my VMware environment via Deploy OVF Template, and it worked / started fine for me.  Can you retry the download and try again?

Enthusiast

Eric,

It looks like it might be missing some bytes. Mine is showing on disk as 463,904 (422 MB) on disk. I will kick off another download and see if that fixes it. I just looked at my DL manager and it says the file downloaded completely with no errors. 

Enthusiast

It is downloading the file now but it still only shows that the file is 442 MB in size which is what it says on your post as well.

Enthusiast

Eric,

Same thing with a new download. I downloaded the "Cisco_UCS_Platform_Emulator_3.0.1cPE1.ovf.zip" file which shows the size of 453,032 KB (442 MB). When I extract the zip the .ovf file is 468,767 KB (457 MB). and I am still getting the same error when doing the import.

I just downloaded the plain zip file and will try to copy those up to ESXi and add VM from there just to test.

Enthusiast

Eric,

I have downloaded the OVF file from 2 other servers and am still getting the error when trying to deploy the OVF file.

I then downloaded the .zip file and did an import on the vmx file and it imported ok but when I tried to run it on ESXi 5 it completely crashed the host and it had to be rebooted. I have also tried this on 1 other host and had someone else try it on a totally separate ESXi host and it crashed their host as well. It is running on a MAC with VirtualBox.

Any ideas?

Enthusiast

Eric,

I have an update on this issues I am having. I was able to unpack the OVF file that I downloaded "Cisco_UCS_Platform_Emulator_3.0.1cPE1.ovf" using 7-zip and import the VM using the .ovf file that was located in that file. That import worked just fine and loaded all the correct NIC's and booted right up.

I was never able to get the .zip package to import and run. 

Enthusiast

So I tried to do the import in vCenter again and manually removed the NIC's and added them back and it still does not properly boot and just hangs. Once that happens ESXi server becomes unstable and the VM will not shutdown.

The only way I was able to get  this VM to shutdown was to force a reboot of ESXi.

Beginner

I was able to get the .zip file to install but no matter what I get the error java.net.sockettimeoutexception: read timed out when trying to login.  I get this with either IP address. 

cisco-ucspe# show cluster

  extended-state  Extended-state

  state           State

cisco-ucspe# show cluster state

Cluster Id: 0xf5ca9b7e184511e4-0x8cad000c294c2c5c

A: UP, PRIMARY

B: UP, SUBORDINATE

HA NOT READY

No device connected to this Fabric Interconnect

cisco-ucspe#

Cisco Employee

Did you manipulate the VM in any way (i.e. remove any of the three NICs)?  If not, please log as user: config / password: config and perform a factory reset.  From what you describe it sounds like you removed a couple of the 3 NICs, or don't have all 3 NIC's IP'ed properly so they can communicate together.

Cisco Employee

I personally have yet to be able to reproduce any of this behavior.  I've imported it successfully to a ESXi server w/o modification of the OVF configuration.  The ESXi server is running 5.1.0.  I could import it successfully without any changes, and it booted with no issues at all, and fully discovered with the base configuration. 

I'm at a loss as to what is causing this.  What versions of VMware are you running.  Are you sure your datastore didn't have connectivity issues at the time of deployment.  I have never seen any behavior that would cause ESXi to get wedged and cause a hypervisor reboot because of a VM deployment.  I have deployed hundreds of copies of UCSPE myself with little to no problems in our lab.

Enthusiast

I am running ESXi 5.1.0 with the latest patches. I tried it on 3 different ESXi servers and they all had the same issues. I have installed other UCS Emulators and currently have v2 running as a VM and no issues. Not sure what is going on with it. I was able to find the workaround so I at least have it running.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here
This widget could not be displayed.