Showing results for 
Search instead for 
Did you mean: 
Field Notice 70545

Cisco UCS Platform Emulator 3.1(1ePE1)


Cisco UCS Platform Emulator, Release 3.1(1ePE1)

To download the Platform Emulator, please go to the downloads page (login required)

New Features and Significant Changes in Cisco UCS PE, Release 3.1(1ePE1)

  • Unified release supporting all platforms and components (e.g., UCS Classic, UCS Mini, and UCS Modular Servers)
  • UCSM 3.1(1e) with HTML5 (Java version still available)
  • Emulation of full scale configuration (same scaling as UCSM 3.1(1e))
  • Dynamic insertion, removal, and modification of components without restarting the Platform Emulator

New Platform Emulator GUI Features

  • Single "Inventory" Navigation Pane with expandable Equipment menu
  • Icon based control and menus in the Content/Work Pane (see User Guide for icon descriptions and functions)
  • NOTE: Browser focus follows UCSM when HTML5 UCSM is launched.  HTML5 UCSM can be opened in a New Tab/Window if there is a need to continue viewing the PE Navigation Pane.

New Hardware Features

See the User Guide for additional details on supported Hardware.  Here is a summary of M4 and 3rd Generation Fabric Interconnect Hardware:

  • Cisco UCS Fabric Interconnect 6332
  • Cisco UCS Mini Fabric Interconnect 6324
  • Cisco UCS I/O Module 2304
  • Cisco UCS Fabric Extender C2348
  • Cisco UCS Blade Server Chassis 5108
  • Cisco UCS M-Series Chassis 4308
  • Cisco UCS B200/B420 M4 Blade Server
  • Cisco UCS Scalable M4 Blade Module (2S/4S)
  • Cisco UCS C220/C240 M4 Rack Server
  • Cisco UCSME M4 Modular Server
  • Cisco Blade Server Adapter VIC 1340/1380
  • Cisco Rack Server Adapter VIC 1387/1385

Known Limitations

  • Imported configurations should be manually checked to ensure there are no missing or unsupported components.  If issues are experienced following an import, any unsupported components can be manually deleted and missing components manually added through the Equipment menu on the Navigation pane.
  • Firmware Management and Firmware Auto Install have not been fully validated in this release.  See below for additional information on Firmware Management using metadata files.

Firmware Management Note: UCS PE supports uploading B-Series, C-Series, and M-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of stripped-down versions (link below).  Stripped-down versions include only the firmware metadata (not the actual firmware binaries).


Thanks to Cisco UCS PE team for long hoped-for release (DCICT is coming).

Works like a charm.


Unable to download--links to a "CONFIDENTIAL FILE" page, text only. Pls advise.

Matthew Faiello
Cisco Employee

I'll notify someone that can fix this.

Cisco Employee

Hi raerevlon.  If you're still having issues with downloads, please try the new downloads page: Cisco UCS Platform Emulator 3.1(1ePE1) Downloads

Community Member

Cannot locate the DB Persistence settings on the config page....  browser issue / refresh?   Was clear in older releases. 

Cisco Employee

Hi Joseph,

The new 3.1 PE does not persist UCSM settings to avoid issues across resets and allow for dynamic HW configuration updates. Backup of UCSM configuration (from the UCSM) admin tab and subsequent import of configs are the best way to persist settings. Please let me know of questions.



Wajih Rehman


I am new to Cisco DC product line and trying to understand how this emulator work.My question is if this  can be connected with live equipment? Like Nexus

Cisco Employee


The UCS Platform Emulator does not directly connect to or emulate non-UCS hardware like Nexus. You can import hardware configuration information from live UCS systems as described in the “Importing the Equipment from a Cisco UCS Domain” section of the User Guide.

Let us know of other questions.



Can you integrate this version of UCSPE with an active instance of VSphere VCenter so you can work with the virtual machines assigned to host ESXi servers?


Cisco Employee

You can register UCSPE with vCenter using the UCS vCenter plugin (instructions on installing/using the plugin are here:

Since the UCSPE emulates UCS infrastructure and does not run host OSes, all emulated servers will show up as “non-ESX”.

Let us know of other questions.


I have been diligently backing up my configurations. Today I looked at the XML files and noticed that the information in the file did not match what I had configured. For instance I removed the three preloaded VLANs and added close to 22 VLANs to match our company's configuration. In the XML the only thing showing were the preloaded VLANs.

A second example was the creation of port Channels for FCoE and Ethernet. I created port channels and then deleted a couple but in the XML file the original ones still showed.

I then rebooted the appliance in an attempt correct this issue and noticed that the database reset (per notice above) so hours of work went down the drain. In order to have something a bit further than I would get with a fresh reload I imported one of the configurations I had saved and nothing changed. No port channels, no up-links, no MAC pools. no WWNN or WWPN pools.

I uploaded both a System State backup and a All Configuration backup.I am attempting to use UCSPE to preconfigure some new equipment we have purchased and at this rate I just as well wait until it gets on hand.


Additional information:

I had been using the HTML administration console for all of the activities. I got a wild hare and decided to try the Java console for the import and it worked but loaded only what was saved in the XML from the HTML console. So I do not have as much work to rebuild but I have work.


A bit more on this.

I started to rebuild what was missing and change the incorrect information and then took an HTTP backup to a local file system again (which I have been using all along) using All Configuration from the Java GUI. I looked at the resulting XML and the changes were missing. I then tried an SCP backup to a Linux box I have and that one worked. All the changes came across.

I have also noted the XML format is different between the SCP download and the HTTP downloads.

Cisco Employee

Sorry to hear your configurations aren't being saved as expected.  We regularly use backup/import in our labs and dCloud (Cisco demo cloud), although most are script based using PowerTool or the Python SDK.  I'll try some operations in the GUI to try and reproduce the issue, and I'll let you know what I find.

Cisco Employee

I’m not sure the communities site will show my attached image, but I just went through a backup using the HTML5 console that specified an “all configuration” backup to the local file system using HTTP. My full state was preserved in the XML output. Can you let me know what the “FSM Details” are showing for you during a backup operation and what Timestamps are shown there vs. the timestamp of the created file?


Recognize Your Peers
Content for Community-Ad