cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco UCS Platform Emulator 3.2(3ePE1)

27417
Views
18
Helpful
30
Comments

Cisco UCS Platform Emulator, Release 3.2(3ePE1)

 

CONFIGURATION IMPORT NOTE:  Importing configuration backups (All, System, or Logical) taken from the UCS Platform Emulator (UCSPE) to physical UCS Manager domains is not recommended or supported by Cisco TAC.  UCSPE backups should only be imported to UCSPE domains.

 

New Features and Significant Changes in Cisco UCS PE, Release 3.2(3ePE1)

  • Full scale emulation of UCS Manager 3.2(3e) which supports M5 Hardware.  Note that there are limited functional changes from the previous release and not all features present in UCS Manager 3.2(3e) are supported (see Known Limitations).
  • New default HW config with M5 servers added.
    • Additional example Hardware configurations have been attached below.  The attached UCSPE configs can be imported from the UCSPE Equipment page.
  • UCSPE is featured in a Cisco dCloud programmability demo.   The demo includes a comprehensive lab guide including the following content for the Cisco UCS PowerTool and Python SDK:
    • Overviews of PowerShell and Python programming environments with step-by-step usage instructions
    • Code generation examples including code generation with UCS Manager's HTML5 interface
    • Sample script creation and use with UCSPE


Hardware Feature Summary

Please see the Release Notes for a complete list of supported Hardware.  Below is a summary:

  • M5 and M4 B-Series and C-Series servers including HX220C and HX240C
  • Cisco UCS S3260 chassis, servers, and storage controllers
  • NVMe-based PCIe storage options


Known Limitations

  • The Platform Emulator does not support connections to Cisco Intersight to avoid the use of Intersight resources by emulated devices. The Intersight Device Connector has been disabled and the device connector menu in the UI is non-functional. You can use Intersight demo environments in the Cisco demo Cloud (https://dcloud.cisco.com/ ) and Cisco DevNet (https://developer.cisco.com/site/intersight/ ) to explore the Intersight management of UCS.
  • Imported configurations should be manually checked to ensure there are no missing or unsupported components.  If issues are experienced following an import, any unsupported components can be manually deleted and missing components manually added through the Equipment menu on the Navigation pane.
  • Firmware Management and Firmware Auto Install have not been fully validated in this release.
    • If issues are experienced during FW download, please try alternate methods such as API based download (e.g., using PowerTool or Python SDK).
    • If issues are experienced with FW policies, please try excluding all components from the policy.
  • AAA-based authentication (LDAP, RADIUS, TACACs)— The Platform Emulator accepts security configuration changes, but does not enforce local or remote password authentication.  Any username and password combination can successfully log into the Cisco UCS Manger UI with administrator privileges.
  • See the Release Notes for the complete list of Known Limitations.

IMPORTANT CONFIGURATION NOTE: Backup/Import of UCSM Configuration

  • The Platform Emulator does not save UCSM configuration state across Emulator resets (to avoid consistency issues in UCSM configuration and the emulator HW configuration).  To preserve UCSM state, UCSM backup and import operations can be performed.  See an example backup/import flow here: PythonSDK for backup/restore (import) of UCSM config


Firmware Management: UCS PE supports uploading B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of stripped-down versions (link below).  Stripped-down versions include only the firmware metadata (not the actual firmware binaries).


Download Instructions


MD5 hashes for downloads:

  • ZIP: 4B409EB4046354BA333A3AD4BFC4F15F
  • OVA: 587B64E769546E6069E9318D66968FFE
Comments
Beginner

Great - thank you @jig 

Beginner

Seems like the links are removed:
"This shared file or folder link has been removed."

Beginner

Chassis Templates are not working for me at all. 

 

UCSPE 3.2.3e.

Cisco Employee
For those using the emulator and have an actual Hypervisor (ESXi) not Workstation... If you suspend your session, you can restart your session and your configurations will be available across reboots of that host. So suspend the VM, put the Host in Maintenance Mode, Shut down the Host. When you restart, you'll be right where you left off assuming you exit the application properly. (Exit in UCSM that is).
Beginner
I have the same thing as Mohammed Hasaballa happening. I made sure I can still login to UCSPE with my ldap stuff but wondering if anyone figured out how to get around this. Kyle
Beginner

Hi, I'm using the latest emulator in VMware workstation 12.5 however I'm unable to generate a Key Ring certificate request after following the instructions multiple times.  As you can see the Request is empty.

 

ucspe /security/keyring # show certreq
Certificate request subject name: ivan.example.com
Certificate request ip address: 0.0.0.0
Certificate request FI A ip address: 0.0.0.0
Certificate request FI B ip address: 0.0.0.0
Certificate request e-mail name:
Certificate request ipv6 address: ::
Certificate request FI A ipv6 address: ::
Certificate request FI B ipv6 address: ::
Certificate request country name:
State, province or county (full name):
Locality name (eg, city):
Organisation name (eg, company):
Organisational Unit Name (eg, section):
DNS name (subject alternative name):
Request:

ucspe /security/keyring


 

Any ideas?  Can anyone else reproduce this issue?

Cisco Employee

Ivan

 

I had the same problem.  Perform the following:

 

Step 1 UCS-A# scope security

Step 2 UCS-A /security # scope keyring default

Step 3 UCS-A /security/keyring # set regenerate yes

Step 4 UCS-A /security/keyring # commit-buffer

 

I was able to use https and get to https://cluster-ip/config

Beginner

Thanks jzitcovi.

 

I'm getting this error on a non-default keyring.  Any workarounds for this use case?  Or does the emulator with Https only work with the default keyring?

Beginner

I ran through your commands however when I attempted to create the cert req for default keyring the CSR field is still empty when running show certreq

Cisco Employee
Haven’t tried the anything but the default at this point..
Cisco Employee
I tried to use the CLI to create the cert request..

I’m getting a DME error from

Scope security..
Then the log message pops up about the DME..

so something is wrong with this build related to the cert..


Beginner

Ok, thanks for the update.  If you can point to a version of the emulator that doesn't exhibit this issue that would be great.

Beginner

Pretty sure the emulator is EOL. Spoke to someone from Cisco @ Cisco Live this year.

Cisco Employee
Terry,

I am expecting 4.0 UCSPE to be released.
The 6454 may not make the build so I would be limited to the 6300.
Beginner

@jzitcovi - Good news. Do you have a target release date?

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards