cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

317
Views
0
Helpful
2
Replies

Compatibility with VIC 1240 with 3.2(3k) and ESXi 6.7 update 1

I'm in process of updating from ESXi 6.5 to 6.7 Update 1.   I have 6248 Interconnects, B200 M3s 2600 series processors, with the 1240 VIC installed on them.  I went on Cisco's HCL page to see what drivers I should use withe 3.2(3) firmware.  I see it wants 1.0.29.0 nenic and 4.0.0.35 nfnic drivers, but it says above that 4.2(3) firmware.  I talked to support earlier and he said that is really a driver bundle.  I downloaded this driver bundle iso,   Inside the release notes for both storage and network drivers,  it says firmware 4.0 again.   I am confused all over again.   I wanted to stay at 3.X version of firmware being I am only using older hardware.    

 

From the nfnic release notes it says

 

Cisco UCS VIC Native fNIC driver Release Notes

Driver Name : nfnic
Driver Version: 4.0.0.35

Compatible ESX Version(s):
ESXi 6.7, including all updates available as of this release


Dependencies:
Cisco UCS Virtual Interface Card 1280 firmware version: 4.0
Cisco UCS Virtual Interface Card 1240 firmware version: 4.0
Cisco UCS Virtual Interface Card 1225 firmware version: 4.0
Cisco UCS Virtual Interface Card 1225T firmware version: 4.0
Cisco UCS Virtual Interface Card 1285 firmware version: 4.0
Cisco UCS Virtual Interface Card 1380 firmware version: 4.0
Cisco UCS Virtual Interface Card 1385 firmware version: 4.0
Cisco UCS Virtual Interface Card 1387 firmware version: 4.0
Cisco UCS Virtual Interface Card 1340 firmware version: 4.0
Cisco UCS Virtual Interface Card 1227 firmware version: 4.0
Cisco UCS Virtual Interface Card 1440 firmware version: 5.x
Cisco UCS Virtual Interface Card 1455 firmware version: 5.x
Cisco UCS Virtual Interface Card 1457 firmware version: 5.x
Cisco UCS Virtual Interface Card 1480 firmware version: 5.x
Cisco UCS Virtual Interface Card 1495 firmware version: 5.x
Cisco UCS Virtual Interface Card 1497 firmware version: 5.x

 

From the nenic driver release notes it says

Cisco Virtual Interface Card Native Ethernet Driver Release Notes

Driver Name : nenic
Driver Version: 1.0.29.0

Compatible ESX Version(s):
ESXi 6.7, including all updates available as of this release


Dependencies:
Cisco UCS Virtual Interface Card 1280 firmware version: 4.0
Cisco UCS Virtual Interface Card 1240 firmware version: 4.0
Cisco UCS Virtual Interface Card 1225 firmware version: 4.0
Cisco UCS Virtual Interface Card 1225T firmware version: 4.0
Cisco UCS Virtual Interface Card 1285 firmware version: 4.0
Cisco UCS Virtual Interface Card 1380 firmware version: 4.0
Cisco UCS Virtual Interface Card 1385 firmware version: 4.0
Cisco UCS Virtual Interface Card 1387 firmware version: 4.0
Cisco UCS Virtual Interface Card 1340 firmware version: 4.0
Cisco UCS Virtual Interface Card 1227 firmware version: 4.0
Cisco UCS Virtual Interface Card 1440 firmware version: 5.x
Cisco UCS Virtual Interface Card 1455 firmware version: 5.x
Cisco UCS Virtual Interface Card 1457 firmware version: 5.x
Cisco UCS Virtual Interface Card 1480 firmware version: 5.x
Cisco UCS Virtual Interface Card 1495 firmware version: 5.x
Cisco UCS Virtual Interface Card 1497 firmware version: 5.x

 

I am also attaching screenshot of Cisco's HCL page.

 

Can someone clarify what drivers I should use with 3.2(3k)?

Everyone's tags (2)
2 REPLIES 2
Cisco Employee

Re: Compatibility with VIC 1240 with 3.2(3k) and ESXi 6.7 update 1

Hello Kevin,

This is your environment:
Server Model: B200 M3
UCS Server Firmware: 3.2(3k)
Adapter Model: VIC 1240
Adapter Firmware: 4.2(3)
OS firmware: ESXi 6.7 U1

Recommended drivers:
FNIC driver: 4.0.0.35 NFNIC
ENIC driver: 1.0.29.0 NENIC

For clarification: 4.2(3) is the adapter firmware, not the UCS server firmware.
Cisco Employee

Re: Compatibility with VIC 1240 with 3.2(3k) and ESXi 6.7 update 1

Agree it's a bit confusing. When you look up your firmware on the HCL, just use the Release Bundle that you have installed.

 

For instance, if you are running 3.2.3i B-series bundle, you would use "3.2.3" to confirm your drivers. The 4.X version is on the adapter itself. This can be a different version, but still part of the "3.2.3x" B bundle. You have the correct supported drivers listed in your previous post.

 

Use this to check which CIMC/BIOS/Adapter firmware are contained in a specific version: Release Bundle Contents for Cisco UCS Manager, Release 3.2

 

Release_Bundle_Contents_for_Cisco_UCS_Manager__Release_3_2_-_Cisco.jpgScreen Shot 2019-05-14 at 3.34.17 PM.png

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards