cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Field Notice 70545
22039
Views
10
Helpful
15
Replies
mbilgrav
Participant

how to create a USB pendrive with HUU for UCS

hi,

I have 4 UCS C220M3 that needs updates, and I downloaded HUU2.0.3d-1 for this as ISO file

I really want to use a USB drive to boot the UCS of of the box before i shipthem out - So there are no network connectvity - just out of the box, boot to USB via F6 and go !

I have doine this before on 1.5 code, but now with 2.0 I got all kinds of funny error and I think its related to the way I create the USB drive

 

So what is the best way to create a bootable USB drive from this Cisco ISO image ?

 

I tried 3 sorts of "makers", but none can boot and load the HUU.

Latest I tried will boot up and start HUU, but then just fails while loading firmware  and tools

 

Please advise

1 ACCEPTED SOLUTION

Accepted Solutions

I did some research and I found the following defect CSCup62091 which you might be hitting.

 

2.0(1a) HUU/4.0(1a) SCU USB boot Error 906

https://tools.cisco.com/bugsearch/bug/CSCup62091

 

Let me know what you think

View solution in original post

15 REPLIES 15
Manuel Velasco
Cisco Employee

mbilgrav

What is the error that you get when you try the install via the USB drive?

 

Another option you have is to connect a laptop directly to the mgmt port of the C Server and configure the ip adress of the cimc and the laptop on the same subnet. when you are done with the firmware upgrade you can reset the CIMC of the server to ffactory defaults to remove ip config of the server

I see "firmware copy has failed ( errorcode 906) ..."

And a dialogbox to save log files 

 

 

i did use virtual media and mounted the same iso and upgraded one

but its so slow ...

besides i dont want tobe depended on test network ...

I did some research and I found the following defect CSCup62091 which you might be hitting.

 

2.0(1a) HUU/4.0(1a) SCU USB boot Error 906

https://tools.cisco.com/bugsearch/bug/CSCup62091

 

Let me know what you think

well, itsn't that dandy

Looks wvery much like my issue, and work around is what I do ...

So Cisco took something that worked and broke it ...

Thanks for the time savings Manvelas.

I hope Cisco will fix this as using virtualMedia is way to slow,

I have the same issue.  The HUU start to load, then have same error " "firmware copy has failed".  Do anybody has a solution?

Using the script in the above bug workaround via CENTOS 7 on VMWARE and am getting the following error:

[root@localhost Desktop]# sh create_util_usb_huu_v2.sh /dev/sdb1 ucs-c240-huu-3.0.1c.iso
syslinux-4.05-13.el7.x86_64
/dev/loop0
ucs-c240-huu-3.0.1c.iso
/dev/loop0
mount: /dev/loop0 is write-protected, mounting read-only

## Creating partitions... Please wait (Will take a few minutes)
umount: /dev/sdb11: mountpoint not found
10+0 records in
10+0 records out
40960 bytes (41 kB) copied, 0.000151812 s, 270 MB/s
Zeroing of USB done.....
Welcome to fdisk (util-linux 2.23.2).

Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.

Device does not contain a recognized partition table
Building a new DOS disklabel with disk identifier 0x0ffa5897.

Command (m for help): No partition is defined yet!

Command (m for help): Partition type:
p primary (0 primary, 0 extended, 4 free)
e extended
Select (default p): Partition number (1-4, default 1): First sector (2048-15633375, default 2048): Using default value 2048
Last sector, +sectors or +size{K,M,G} (2048-15633375, default 15633375): Partition 1 of type Linux and of size 1 GiB is set

Command (m for help): The partition table has been altered!

Calling ioctl() to re-read partition table.

WARNING: Re-reading the partition table failed with error 22: Invalid argument.
The kernel still uses the old table. The new table will be used at
the next reboot or after you run partprobe(8) or kpartx(8)
Syncing disks.
Error: Partition creation failed.

So even the workaround is broken now. What a fiasco...

well, to be frank, the workaround do mention CentOS6.4 - you are using 7.0

But I found that even using the workaround the result was not quite working still ...

You are left with the only option to Mount via CIMC as virtual media and boot on this. This Works ...

Also this should be fixed in later version according to the bug, so maybe you can try using a fixed version.

PS

Maybe the comment in https://communities.cisco.com/docs/DOC-56147 may help you

I'm using the 3.0.1c release which gives out the 906 error. 

Mounting via the CIMC is great...until you realise you've got 96 odd C240s to upgrade!!!

And even then it won't actually mount properly. It'll run the HUU but for some reason it won't upgrade the CIMC and won't quit properly. 

Like I said, this is a fiasco.

depending on your needs, then do a TAC ticket (Again) or you could try to download an older version and hope that this will Work,

Also please see if the commments in

https://communities.cisco.com/docs/DOC-56147

may help, I noticed someone talking about centos 7

I know with large numbers of servers this is needed, and is much faster !

I confirm, it works like a charm with Centos 7.

I have the same issue too...site 

Hello,

I've got the same issue too. 

00CashBack

All you need to do is burn the image to a DVD and you are all set.

thank you very much i have work on it for almost 5 days

Create
Recognize Your Peers
Content for Community-Ad