cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
967
Views
0
Helpful
7
Replies
Beginner

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Hello all-

I am currently running XS 6.0.2 w/ HF XS602E001 & XS602E002 applied running on Cisco UCS B200-M3 blades. XS seems to be functioning ok, except that i cannot see the subnet assigned to my SAN, and as a result, i cannot add any SR for VM storage.

  • The subnet and vNIC that i am configuring is also used for the iSCSI boot.
  • The vNIC is on LAN 2 and is set to Native
  • The SAN is a LeftHand P4300 connected directly to appliance ports (LAN2) on the Fabrics
  • Used the following commands during installation to get the installer to see the LUN.
    • echo "InitiatorName=my.lun.x.x.x" > /etc/iscsi/initiatorname.iscsi
    • /opt/xensource/installer/init --use_ibft

If i missed anything or more info is needed, please let me know.

Everyone's tags (5)
7 REPLIES 7
Highlighted
Beginner

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Additional info:

  • Server Bundle: 2.0(5b)
  • Infa Bundle: 2.11e
  • IOM: 2208XP
  • VIC1 1240 and 1280
  • Server B200 M3
  • FI 6248UP(x2)

Highlighted
Cisco Employee

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Hello Jim,

Are you able to ping the iSCSI target IP from Xenserver host ?

Padma

Highlighted
Beginner

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Padma,

I cannot see the iSCSI subnet from the XenServer host post-installation via ping.

Highlighted
Cisco Employee

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Hello Jim,

After booting the OS via iSCSI, do you notice any NICs from Xen ?

lspci | egrep -i 'net|eth'

The iSCSI vNIC that we create in adapter is only used for booting OS via iSCSI. Once the OS is loaded and if we need to access storage LUNs via iSCSI, we need additional regular vNICs defined in Service profile / VIC.

If you have a NIC,then as a first step, you can verify the IP connectivity to iSCSI storage server.

If you have the NIC and configured an IP address, please make sure it is configured with necessary VLANs in the vNIC ( service profile )

Since we have iSCSI storage connected to FI via Appliance port, make sure you have created the VLANs under Appliance cloud too.

HTH

Padma

Highlighted
Beginner

Re: iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Thanks Padramas,

I have 2 NICs that show up in XenCenter. Nic A is the vNIC associated with VLAN1 and provide the uplink to the rest of the network. The second NIC in XenCenter matches the MAC of the vNIC used to boot XenServer, so the NIC used for booting the OS is visible in XenCenter.

I have tried many different thing on my own to resolve this issue. I believe i have already tried adding a 3rd vNIC to the service profile for VM iSCSI traffic, but with make another attempt.

When configuring the vNIC for VM iSCSI traffic, do I only need to add the 3rd vNIC, or do i need to create both a vNIC and second iSCSI vNIC with Overlay vNic pointing to newly created (3rd) vNIC? My understanding is that the iSCSI vNICs are only used for booting, but I am not 100% sure.

Thanks again for the help!

Highlighted
Beginner

Re: iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Here are a couple configuration screenshots

Highlighted
Cisco Employee

iSCSI- Adding iSCSI SRs to XS booting via iSCSI [Cisco UCS]

Hello Jim,

Thanks for the screen shots.

Let us assume that you have configured vNIC 1 ( eth0 in Xen  ) with an IP address that belongs to iSCSI VLAN and is used as iSCSI initiator.

iSCSI target ( SAN array ) is directly connected to FI via Appliance port.

What exactly happens when you try to ping ( eth0 IP address as source ) iSCSI target IP address ?

Configuration check list for appliance port connectivity are documented here

http://www.cisco.com/en/US/products/ps10279/products_tech_note09186a0080c021e1.shtml

Padma

CreatePlease to create content
Content for Community-Ad
Software Conformance Survey