cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
961
Views
5
Helpful
7
Replies
Highlighted
Beginner

iSCSi booting problem (B230M3 blade)

We followed the Cisco CVD on Vmware and the IP protocol, but we are having problems. The blade initiator does not log into the target igroup (this is on a Netapp controller). No lun is seen at blade bootup. The lun is created, mapped to an igroup and the igroup has the iqn nodename as a member.

We did configure jumboframes according to the paper. The switch is a Cisco 3600, though.

The target is on a 10GbE vlan interface an dit is pingable.

The only thing deviating from the CVD is that we use the same vlan for all iSCSi traffic + NFS traffic. No iSCSi-A and iSCSi-B. The initiator address pool is therefore also just one pool.

7 REPLIES 7
Highlighted
Beginner


Can you add a screenshot of the service profile that you are iscsi booting?
Sent from Cisco Technical Support iPad App

Highlighted
Beginner

One thing you can do it to use the command line to connect to the server's adaptor and collect iSCSI status information.

UCSHOSTNAME#connect adapter 1/1/1

UCSHOSTANME#(adapter)connect

UCSHOSTNAME(adapter)#attach-mcp

adapter 1/1/1 (mcp):20# iscsi_get_config

(To read more about iSCSI boot troubleshooting, check out this blogpost:

http://www.ccierants.com/2012/03/boot-from-san-iscsi-with-cisco-ucs-20.html).

Is your native VLAN set to the VLAN that contains the iSCSI target?

mike

Highlighted

yes it is. At th emoment  I don't know where the misconfig lies. In UCS, switch or on the Netapp.

Highlighted

Atle,

This is a step by step procedure to setup iSCSI boot

https://supportforums.cisco.com/docs/DOC-18756

Michael Stump's iscsi_get_config will assist greatly in determining where the issue may lie.

I've found the easiest way to check the iSCSI lun access is to install Windows 2008r2sp1 on a blade and use the iSCSI initiator and confirm the iqn/ip/gw access to the lun. Then you are just left to figuring out what it wrong with the UCS config.

Dave

Highlighted

The iscsi_get_config will tell you if the iSCSI initiator is able to connect to the target. If you run this command and don't see an active connection to the target, doublecheck your iSCSI target settings in the service profile. One field in particular: Name. Make sure you entered the IQN, not the hostname, for your target. I've always thought that field should be labeled differently.

If you can run the iscsi_get_status and paste the results here, we should be able to find the problem.

mike

Highlighted

ok, will do when I get access at customer site.

Is this iscsi-vnic-A adapter on Fabric-A?

connect adapter 1/1/1

what is it for iscsi-vnic-B?

But I assume this has nothing to do with drivers? The iSCSI VNIC should log  into the igroup at boot-time? Or does this not happen before after the  Cisco vnic driver is loaded? In other words, when do I see the LUN?

Highlighted

The second adapter will be 1/1/2. (See

http://www.cisco.com/en/US/docs/unified_computing/ucs/sw/cli/command/reference/1.0.2/command_reference_1.0.2_chapter4.html#wp2091890055) for additional information on the connect-adapter command).

The Option ROM will handle the iSCSI booting; not OS drivers, since this is all pre-OS activity. Are you seeing a message during POST that says the Option ROM was loaded successfully?

mike

Content for Community-Ad