cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1416
Views
0
Helpful
5
Replies
Beginner

Nexus 1000v extension error

hi Guys

I have upgraded my VC to 5.1 and am using nexus 4.2(1)SV1(5.1a)

When i go to register the plug in i get the message below , all hosts are 4.1.0

specified parameter was not correct, extension.key

Call  "ExtensionManager.RegisterExtension" for object "ExtensionManager" on vCenter  Server "

dkcphsrv36.dk.kworld.kpmg.com

" failed.

Is this because it was registered allready to a previous version of VC , any idea how to fix this ?

Everyone's tags (5)
5 REPLIES 5
Highlighted
Cisco Employee

Nexus 1000v extension error

If this is 5.1 and not 5.0U1 I assume you have a beta build?

I'm not sure if we have support yet for 5.1. I don't have access to the code to verify.

louis

Highlighted
Beginner

Nexus 1000v extension error

Apologies, meant 5.0 update 1

The nexus was previously registeredto the old vc , the new vc is a completely new vm , we didn't upgrade the 4.1

Highlighted
Cisco Employee

Nexus 1000v extension error

Bunch of questions

Is the VSM still connected to the old vcenter?

Does the extension key filename match the key number in the xml file?

Can you cut and paste the xml file?

if the VSM is not currently registered. A quick thing to try a fix is to change the extension key with "vmware vc extension key xxxxxxxx" this will generate a new key. Just make it different then the existing key.

louis

Highlighted
Beginner

Nexus 1000v extension error

hello

the vsm was connected to the old vcenter , which isnt running anymore

what is the correct procedure to unregister the vsm if it is still connected to the old vc ?

Highlighted
Beginner

Nexus 1000v extension error

i have run the commands e.g. no vmware dvs etc so removed the link to the old vc

i am still getting the plug in error though when adding to new vc

CreatePlease to create content