Showing results for 
Search instead for 
Did you mean: 
Field Notice 70545

NPV upstream port not available

I am trying to deploy a new 5108 Chassis and 6120 cluster.  But I get and error for the blades "NPV upstream port not available"

I have had the storage team ensure NPIV is avialable on the switch but they are unable to see the WWN and PN on the B side for these servers.  the A side is on and available.  I just switched ports on the core switch and still get the same error.  has anyone ran into this?


Accepted Solutions

could be a vsan mismatach between the 6120 and upstream FC switch. Is the upstream switch an MDS? Make sure the FC ports on the 6120 are mapped to the correct VSAN.

View solution in original post

Jeremy Waldrop

You will need to shut/no shut the interfaces on the UCS side (disable/enable from UCSM) after NPIV is enabled.

If it is an MDS make sure the VSAN that is on the MDS is created on the UCS side and then the FC interfaces placed into that VSAN.

you will not see any wwpns of servers until service profiles are created and associated to servers, you should see the wwpn of the 6120 FC interfaces though.

Thanks for your reply.  So I have 4 blades with Service Profiles associated and VMware installed on all 4 blades.

They are powered on and they see the A side, I have disabled/ enabled the FC uplink ports for B.  But 3 out of 4 servers still show the NPV upstream port unavailable.  None of the B side ports are able to be seen by the san manager.  On the switch A side ports shows

F-Port  1 N Port + 2 NPIV

Bside just shows the NN for the port.

Any idea?

could be a vsan mismatach between the 6120 and upstream FC switch. Is the upstream switch an MDS? Make sure the FC ports on the 6120 are mapped to the correct VSAN.

the upstream switch is a brocade 48K.  VSANs are mapped to Fabricdual/default vsan ID they are the same on A and B. 

have your SAN admin run portCfgShow against the ports the 6120 is connected to verify NPIV is enabled.

Is your 6120 FI fully liecensed. Pleas check. I had similar problem like this.


License looks good.  and NPIV is enabled.  I may have to open a case.

Feat Name                      Scope Default Total Quant Used Quant State

         Peer Count Comparison   Grace Used

------------------------------ ----- ------- ----------- ---------- -----------

-------- ----------------------- ----------

ETH_PORT_ACTIVATION_PKG        A           8           8          5 License Ok

         Matching                         0

ETH_PORT_ACTIVATION_PKG        B           8           8          5 License Ok

         Matching                         0

it was a vsan mismatch because of the brocade.  so currently one side of the cluster is a different vsan. 

Thanks Jeremy! I had the same issue and was able to resolve it using your post. FC ports on my 6120 were not mapped to the correct VSAN.

haiyang xu

Make sure the MDS's NPIV feature.

Show NPIV or show feature NPIV

Sent from Cisco Technical Support iPhone App


I openned a case.  looks like it was an issue with the new firmware and the Brocade Switch we have.  2.02(Q) has the VSAN ID 1111 and the brocade needed it to be 1 so we modified the FCoE VLAN ID to something other than default.  The HBA's are online and available.

Obscure fix but it is working correctly now.


My deployment is similar in that I will connect native FC between the UCS FIs and Brocade switches. Can you confirm the VSAN requirement when connecting to a pair of Brocade switches.

Should I use the default VSAN 1 on both Fabric Interconnects with a different FCOE Vlan. Or can I still configure 2 different VSAN IDs for the Fabric Interconnects each with their own FCOE Vlan.

Any help would be appreciated.


Recognize Your Peers
Content for Community-Ad