cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
144
Views
5
Helpful
2
Replies

Troubleshooting iSCSI boot from UCS server... should be but not?

Hello all--I'm trying to troubleshoot an iSCSI boot from a UCS managed server.  The UCSM, I believe, is telling me that it can reach the storage array, but the storage array is telling me that the server is not online.  Right now, I'm stuck in the server OS's installation wizard bc the server can't find the iSCSI node.

 

Screen Shot 2019-04-16 at 11.17.25 AM.png

 

adapter 1/1/1 (mcp):1# iscsi_get_config

vnic iSCSI Configuration:
----------------------------

vnic_id: 13
host_id: 0
link_state: Up

Initiator Cfg:
initiator_state: ISCSI_INITIATOR_READY
initiator_error_code: ISCSI_BOOT_NIC_NO_ERROR
vlan: 0
dhcp status: false
IQN: iqn.1966-09.com.cisco.ucs:myucs01:0
IP Addr: 172.25.253.119
Subnet Mask: 255.255.255.0
Gateway: 172.25.253.1

Target Cfg:
Target Idx: 0
State: ISCSI_TARGET_READY
Prev State: ISCSI_TARGET_DISABLED
Target Error: ISCSI_TARGET_NO_ERROR
IQN: iqn.1999-02.com.nexsan:xxxxxxxxxxxxxx
IP Addr: 172.25.253.100
Port: 3260
Boot Lun: 0
Ping Stats: Success (12.599ms)

Session Info:
session_id: 0
host_number: 0
bus_number: 0
target_id: 0

 

I've double and triple checked that my initiator and target IQNs and IP addresses are right.  The iSCSI VLAN is native on the iSCSI-vnic, and the upstream switch can ping the storage array.

 

Any suggestions on what all else I need to explore to get this thing working would be greatly appreciated. Thank you in advance!  MM

2 REPLIES 2
Highlighted

Re: Troubleshooting iSCSI boot from UCS server... should be but not?

1. check LUN masking on the storage side - your initiators should be there.

2. see that your array sees the initiators logging into the array while you try to boot

The details depend on your array.

Cisco Employee

Re: Troubleshooting iSCSI boot from UCS server... should be but not?

Also check your lun number on the storage controller side.

Based on your ucsm output, the lun is assigned #0, so make sure it's also assigned 0 on the storage side.

 

Kirk...

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards