cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1095
Views
17
Helpful
12
Replies
Beginner

UCS 3.2(3d) Upgrade

I am running UCSM 3.1(3f) and am preparing to upgrade to 3.2(3d). Has anyone in the community made this jump? I'm looking for real-life examples of possible issues and successes.

Thanks in advance

12 REPLIES 12
Highlighted
Cisco Employee

Re: UCS 3.2(3d) Upgrade

Hello Gary,

I hope you would have reviewed your environment ( OS / HW / drivers ) against Compatibility

https://www.cisco.com/c/en/us/support/servers-unified-computing/unified-computing-system/products-technical-reference-li…

3.2 Release notes

https://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/release/notes/CiscoUCSManager-RN-3-2.html

Also, I would suggest you to go for the latest patch release ( 3.2.3e instead of 3.2.3d ) as it has additional bug fixes.

Finally, I have seen many customers upgrade to 3.2.3 release without an issue.

Let us know if you have specific questions or concerns regarding the upgrade.

Thanks

Padma

Beginner

Re: UCS 3.2(3d) Upgrade

Thanks Padma

I have checked the HCL and release notes. I've also logged a pre-emptive case with TAC. I was hoping to actual talk with someone that's had the hands on upgrade to share experience with me. I'll review the 3e release notes but I typically go with the Cisco recommended latest version.

Best regards.

Cisco Employee

Re: UCS 3.2(3d) Upgrade

I am in TAC and have successfully made this jump with customers multiple times. The auto-install script has a lot of tools built into it so you cannot mess up the upgrade. 3.1 to 3.2 is not much of a jump, so nothing to be concerned with.

The only possible issue we see is when customers acknowledge the reboot of the primary FI, before the subordinate has come back online. Make sure that all your faults have cleared before acknowledging the reboot of the primary FI. If you are really interested in testing failover, you can use fabric evacuation, but it is not required.

If you have any specific questions or concerns, I would be happy to answer.

Beginner

Re: UCS 3.2(3d) Upgrade

Good news Wesley, thanks for the input.

Beginner

Re: UCS 3.2(3d) Upgrade

Greetings,

 

I have been going back and forth with the TAC for a few days now regarding a Cisco UCS firmware upgrade from 3.1.3k to 3.2.3j.  So far every time I check the conformance of the package I get messages saying the System and Kernel of my FIs are not in conformance. It has been frustrating to say the least.  I have never had this much trouble performing a firmware update on UCS.  We have already verified I all the blades, infrastructure, and rack mounts are on 3.1.3.  They checked my parts for deprecated hardware which I had none.  Any recommendations?  

 

Cisco Employee

Re: UCS 3.2(3d) Upgrade

Can you message me the TAC case?

 

Can you provide an exact screen capture of the error message you are getting?

Beginner

Re: UCS 3.2(3d) Upgrade

I will send you the TAC case shortly.  I did just receive a message from the TAC that it is cosmetic in nature and I am safe to proceed.  See excerpt below.  Followed by screenshot.

 

"I wanted to update you on the case that we discussed this case with our next level escalation team and as per your discussion we tried to recreate the same issue in our lab and this issue seems to cosmetic in nature with no impact on production. We can upgrade the firmware and the issue will be dis appeared.

 

Regarding this concerns we are in process of filing a BUG with Cisco Development team and will keep you updated with further progress. This would be the action plan for now. Please let me know if still any further assistance or call is required."

 

UCS Firmware 3.2.3j conformance error.jpg

Cisco Employee

Re: UCS 3.2(3d) Upgrade

Thanks. I double checked and we have had quite a few cases opened for this, all resulted in successful firmware upgrades using auto-install.

 

We will proceed with opening a defect to outline this behavior and I will share back here once its publicly available.

 

 

Cisco Employee

Re: UCS 3.2(3d) Upgrade

Wanted to share this here after taking a look further:

 

When an endpoint is "In Conformance", it means that the endpoint is running on firmware which came as part of the package on which you invoked "Check Conformance". The reverse is also true. When an endpoint is "Not in Conformance", it means that the endpoint is not running on firmware which came as part of the package on which you invoked "Check Conformance".

 

We will work on updating the documentation to clarify this and avoid future confusion.

Re: UCS 3.2(3d) Upgrade

I am planning to upgrade my UCS from 3.1(2e) to 3.2(2E) , Is this an issue with the 3.2(3d) or should this matter when i am performing the upgrade

 

Cisco Employee

Re: UCS 3.2(3d) Upgrade

There is no issue. Check conformance is to see if your components are on the version you are checking for. If you are running 3.2.3e...you check conformance for 3.2.3e and it will let you know if you are running the correct version per the bundle.

Re: UCS 3.2(3d) Upgrade

Thank You Wes
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards