Showing results for 
Search instead for 
Did you mean: 

UCS C220 M3 Problem after installing ESXi 5.1.0 Cisco custom

Hi every one,

I´m using a Cisco UCS C220 M3 when I tried to install ESXi 5.1.0 Cisco Custom after complete all the process and restart the server. The ESXi did not start it appeared as if there no operating system.

Aditionally, before the ESXi installation I configured one HDD in RAID 0, initialized the virtual drive and selected as boot driver.

Hoping some one could help me.


Nope, that is what i did and it does not work.   ESXi is loaded on the FlexFlash, and works fine.  When you boot into ESXi, it does not see the Raid 10 drive, it only sees 4 physical drives.  

We had to find a RAID card and install that, now it works as expected.

Why Cisco would sell a UCS configuration that does not work with ESXi is beyond me. 

Is cause there are Operating Systems that are NOT a virtual platform and therefore don't face this situation.  We do not only support ESXi...



The only problem with this approach is if you run into any defects that requires a firmware upgrade, you will lose access to the storage again.

I've faced with this problem too. But...

Actualy, VMware Hipervisor didn't support embedded RAID controller (aka SW RAID).

If you see in BIOS Boot Order section, you couldn't see any HDD as Boot Device at all.

You need to select "Intel RST" in controller configuration section (BIOS>Advanced>South Brige)

Intel RST support SAS/AHCI feature for all HDDs and now you could select HDD with installed ESXi as Primary Boot device.

After ESXi instalation you can try to create RAID1 with 2 HDDs. In my case - all are works perfectly.

But, other HDDs you can only add to Hypervisor as LUNs without any RAID functionality. Or you can install any Guest OS (Like Linux), create RAID groups under this OS and then with raw device mapping translate this raw-partitions to hypervisor.


Even, if you can do that, the best possible solution (Ofcourse, if it's possible in case with financial reason) is to add HW RAID controller. 

I think you are missing the point-  You are to install ESXi on the FlexFlash in the UCS.  When you boot into EXSi, and try to use the RAID drive you created, ESXi will not see it.    


The software raid is not supported.

No, I haven't any FlexFlash. I've installed directly to my SAS 300Gb drive and than rebuild RAID between 2 HDDs. This process take up about 4 days :).

But, you are absolutelly right - with SW RAID I can't create any RAID with other drives and I can use it only as separates LUNs.

That is why I note, that best possible solution - add RAID-controller card


I hit this problem too. After trying steps mentioned by a.shishenkov, everything is fine.

Thank you so much

For future users... remember that having an unsupported configuration or hardware combination does not mean it wont work (it may) but it means that if for any reasons it stops working and you need to open a TAC case, TAC will very likely ask you to make your configuration/hardware combination, comply with what is specified to be supported before we continue troubleshooting.



Content for Community-Ad