Showing results for 
Search instead for 
Did you mean: 


UCS C220 M5 - M.2 SWRAID Error

Dear guys,


I am having a trouble with Cisco UCS C220 M5. When I  boot to CIMC, there is an error as picture "M.2 SWRAID configuration is not detected". I tried "Load Manufacturing default" but it did not work.


Please help me. Thanks a lotphoto6339182871050299543.jpg

Cisco Employee

Re: UCS C220 M5 - M.2 SWRAID Error

Do you have the M.2 controller installed? If so, I would reseat it and ensure the drive and controller are both secured on the motherboard.


Re: UCS C220 M5 - M.2 SWRAID Error

Yes, there is a M.2 controller with 2 SSDs on the motherboard. I tried reattached (or reseated) it but it still did not work. 


Re: UCS C220 M5 - M.2 SWRAID Error

Additionally, when I tried installing RHEL, the server recognized 2 SSDs and no RAID. So I think the error come from the absence of Embedded Software Raid Controller. Do you have any ideas about this error?

Cisco Employee

Re: UCS C220 M5 - M.2 SWRAID Error

Just to confirm, you have hit the <cntl> + M during post, for the megaraidSR config, and actually created a raid 1 virtual drive?

I've seen your exact same message for a new server out of the box that has no config for the embedded megaSR controller completed yet.




Re: UCS C220 M5 - M.2 SWRAID Error

Thanks for your reply.


Yes, I already created a raid 1 virtual drive last week. And I want to test the "mirroring" of raid 1 so I change the position of 2 SSDs in raid module :)). And after that, the error appear. 


This is my first question in this forum so maybe you mistake me with someone :))



Cisco Employee

Re: UCS C220 M5 - M.2 SWRAID Error

Check in BIOS if the SW RAID is enabled. 


Step 1 Boot the server and press F2 when prompted to enter the BIOS Setup utility.

Step 2 Choose the Advanced tab, and then choose Mass Storage Controllers Configuration .

Step 3 Set Onboard SATA Controller to Enabled .

Step 4 Set SATA Mode to SW RAID .

Step 5 Press F10 to save your changes and exit the utility.


Once you confirm that SW RAID is enabled launch the LSI Software RAID Setup Utility

Press Ctrl-M during verbose boot, and re-configure RAID. 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards