cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3801
Views
20
Helpful
13
Replies
Piotr Mlodawski
Beginner

UCS C240 M4S2 fans spinnig too fast

Hello Experts,

 

We have 3 UCS M4S2 servers (ordered as BE 7000 Bundle).

Version: 2.0(6d)

The servers have been running (without any load - just OS ESX 5.5 without VMs) for about one month without any problems.

After 1 month, fans in one server started spinning at 17000 - 18000 RPMs. (This speed can be normally observed, when the server is booting up.)

The tempereature is OK, and all the sensors show green. I do not see any failures in the logs.

I have switched the server off, disconnected the power cords and powered the server on again. The fans returned to tthe normal state of 7000-8000 RPMs.


A few days later the same situation ocuured on the second server. I have not rebooted it since then.

Are there any tdefects related tio this situation?

Please Help.

 

Regards

Piotr

 

 

13 REPLIES 13
Saurabh Kothari
Cisco Employee

Hello Poitr,

1) make sure that the server is kept in a cool and well ventilated room and is atleast 1RU distance from its neighbors.

2) how many and what PCIe cards are present?

3) how many CPUs?

If single CPU then check this bug:- CSCur74936

4) check the Fan policy

Server> Power Policies> Fan Policy.

Here is the explanation for each option:

http://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/c/sw/cli/config/guide/2-0/b_Cisco_UCS_C-Series_CLI_Configuration_Guide_201/b_Cisco_UCS_C-Series_CLI_Configuration_Guide_201_chapter_011.html#d68030e3845a1635

  • Balanced This is the default policy. This setting can cool almost any server configuration, but may not be suitable for servers with PCIe cards, since these cards overheat easily.
  • Performance This setting can be used for server configurations where maximum fan speed is required for high performance. With this setting, the fan speeds will run at the same speed or higher speed than that of the Balanced fan policy.
  • Low Power This setting is ideal for minimal configuration servers that do not contain any PCIe cards.
  • High Power This setting can be used for server configurations that require fan speeds ranging from 60 to 85%. This policy is ideal for servers that contain PCIe cards that easily overheat and have high temperatures. The minimum fan speed set with this policy varies for each server platform, but is approximately in the range of 60 to 85%.
  • Maximum Power This setting can be used for server configurations that require extremely high fan speeds ranging between 70% to 100%. This policy is ideal for servers that contain PCIe cards that easily overheat and have extremely high temperatures. The minimum fan speed set with this policy varies for each server platform, but is approximately in the range of 70 to 100%.

Thank you.

Regards,

Saurabh

 

*please rate all useful answers.

 

Hi,

Thank you for your answer.

1. The servers are cool and and the fans were also spinning fast when the VMs were off.

2. Following PCI cards are present in the server

3, There is a single CPU with 12 cores. Intel(R) Xeon(R) CPU E5-2680 v3 @ 2.50GHz

I have checked the bug  CSCur74936 , however it says

the affected release is 2.0(3e), it is fixed in 2.0(4c) and my current version is 2.0(6d), so it it does not seem to match.

4. The Fan policy is set to balanced.

Regards

Piotr

Piotr,

thank you.

did you update CIMC and BIOS to 2.0.6 using browser client and not HUU?

if yes then you probably should use 2.0.6 HUU and 'update-all' components.

Hi,

I did not update any Firmware yet.
We received the servers with this firmware from Cisco.

Piotr

Piotr,

do you still have the same issue?

did you try to reboot CIMC?

 

I am. See my top-level post. Details are very similar to Piotr's.

adam.miller
Beginner

I have this exact problem, on C240 M4SX. Running firmware 2.0(6f). Which I installed via the bootable ISO, and updated all firmware.

 

My fans started spinning faster the same day I got an odd fault in fault log, saying CPU2 isn't working properly. There is no CPU2. Here is the error:

 

I power cycled the C240, but did not unplug the cables. Did not fix fan issue. Support engineer's current recommendation is to re-seat the fan module. Will try it, but not optimistic about that idea.

 

Logging into CIMC, and forcing a reboot of CIMC has corrected the fan speed for now. TAC says this can happen if CIMC is unable to get some sort of information from the hardware components. In my case, CPU2. This triggers the fans to blow at top speed.

Adam,

That is true and it also has to do with your "Fan Control Policy" and what you set there.

http://www.cisco.com/en/US/docs/unified_computing/ucs/c/sw/gui/config/guide/1.5/b_Cisco_UCS_C-series_GUI_Configuration_Guide.151_chapter_011.html#concept_8CB787DF70304E98BE25D120466418B9

 

Pretty much if CIMC cannot get the temperature of an specific component, it rather be safe than sorry and pushes the fans to higher speeds

-Kenny

That makes sense to me. The problem is, my servers don't have a 2nd CPU. So the error which triggered the high fan speed should not have happened.

Agreed... Did they open a defect to fix that for you?

 

-Kenny

For those who still suffer from this defect.

There's a bug referenced in CSCux20012 which is fixed in version 2.0(8g).

And the feedbacks given on the bug page (5 stars in 3 reviews) let us understand that it truly solves the fans' speed issue.

Thanks for posting - this has helped me quickly identify why 2 servers I installed last year have suddenly gone very loud!

Regards,

Richard

Content for Community-Ad