Showing results for 
Search instead for 
Did you mean: 

UCS/Nimble iSCSI vNIC Question

Just to jump into it.

We have a 5108 w/ 5 Blades booting from SAN from a Nimble controller. We have the environment up and running but have run into a issue which is as follows;

If we are on the host of any of the servers and ping the hostname of the server itself of the server we are consoled into it always brings back one of the IPs from the iSCSI pool subnet (192.x.x.x), no matter what binding order we apply in win2k12 it will not bring back the IP on the subnet for the LAN (10.x.x.x). If we ping a hostname of one of the other servers from the one consoled into it resolves the correct IP from the LAN subnet. (10.x.x.x) . There is an application that's going to be used on the box which pings its hostname and with it coming back with the iSCSI subnet IP and not the LAN IP it fails the service since it doesn't think its running.

DNS is not setup on the 2 vNIC for the iSCSI, we've disabled NETBios xer TCP/IP, changed the bind ordering, changed the metric but to no avail.

I'm honestly not certain if this is a UCS or a Windows issue at this point.

Fairly new to the UCS world so any help/insight would greatly be appreciated!




  I am not seeing the issue you are having in my environment.  I have UCS B and C series server running Server 2012R2 and then have a lot of VM's on top of them with Hyper-V.  I use static addressing, not DHCP for my bare metal servers and only designate my lab management NIC to have DNS entries.  when I look in my AD servers running DNS I only see the lab management network having registered which is why it always responds with the proper IP for the name.  A few things I would suggest looking at is:

1 - I don't provide a default gateway on any NICs except the lab management NIC

2 - I don't have DNS entries on the 'other' NICs in my environment

3 - I have my lab management NIC ordered first in Windows

4 - It is not ordered first in UCS

and what I believe your issue will turn out to be is:

5 - in my DNS servers I have DNS enabled ONLY on the lab management NIC.  As such the other NICs can't reach DNS to register themselves.  As such I only see name/ip mappings in DNS for my lab management NIC.  To configure this, open the DNS manager, select the DNS server and right click and select properties.  On the interfaces tab change from all the IPs to select only the one you want.

Other's may question having only a single network with management though and I'd be interested to hear others solutions.

Good Luck!


Content for Community-Ad