cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

UCS Platform Emulator Firmware Bundles (includes firmware meta-data only)

44725
Views
38
Helpful
28
Comments

UCS PE supports uploading B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of stripped-down versions with only the firmware metadata (not the actual firmware binary).  The stripped-down versions of the firmware bundles for various B-Series and C-Series servers are attached below.

Comments
Beginner

Is there a reason I don't see firmware bundle for UCSM 3.1.2e??  I'm a stickler for details, and when I don't see what I expect to I have a breakdown.   

Is the firmware bundle above 3.1.2b the latest and greatest for the 3.1.2e Emulator? 

This is a great tool, but clearly the documentation and over all delivery to customers seems lacking.

Cisco Employee

3.1(2b) is the latest bundle for the Platform Emulator.  Since the firmware bundles are metadata only (no functionality provided), a version for 3.1(2e) was not created.

Beginner

thanks David - I'm seeing something finicky which I'm not sure is either because of the documentation not being right or because I haven't applied this firmware metadata package..

When I try to configure a breakout port, the breakout port options is greyed out, I only see the following:

Cisco Employee

Hi Ken,  There's limited support for breakout ports in the Platform Emulator since not all port characteristics are modeled.  I can check what is possible though - can you let me know what FI type and port you are trying to configure?

Beginner

6332 16UP.   For now I just went with uplink ports, but thankfully I am taking the time to walk through the documentation and noticed the specifics for configuring the breakout ports, otherwise, if I just relied on the options in the emulator I would be in trouble because I would have configured our 40GB breakout ports as standard uplinks ports. 

Beginner

Hi David - I'm still toying with the emulator, and I have errors in the IO modules on all 4 fabric ports,  along with errors showing on each server, its all stating I need to update firmware, however, the firmware showing in the running state is in fact  3.1(2b).    Also, note, UCSM for the emulator is running 3.1(2e).  

Can you advise please?

Ken

Cisco Employee

The IO errors are a known issue in the emulator due to its modeling of adapters with FW issues at 40G. Unfortunately there’s not a way to avoid the errors, although they do not have any impact on emulator functionality. We will try to resolve the errors in the next release of the emulator.

Let me know of any other questions.

Beginner

Is Cisco still actively publishing these meta-data files?

The PE is at  3.2.3e yet the latest firmware meta-data file version is 3.1.2b.

 

If the Infrastructure firmware version must match or be newer than the server firmware version why is there no meta-data file for infrastructure?

 

My objective is to test updating the firmware for both infrastructure and the servers. Can the PE be used for this or is it restricted to the point that it is not possible to use the PE to test an update?

 

Thanks

Cisco Employee
UCSPE can be used to test Host Firmware Package settings with the meta-data only server bundles, but update operations cannot be tested since the underlying HW is emulated and infrastructure FW versions are fixed to the specific UCSPE release. UCSPE 3.2(3e) can be used with the 3.1(2b) FW bundles to test Host Firmware Package settings.

A server bundle meta-data update should happen with the 4.0 release of UCSPE, but the timeline for that release is not yet set.
Beginner

I am trying to use the UCSPE for an HX-Demo, during the HX-Installer Config Validations, I am getting errors regarding Firmware.

Can you get an updated version for 3.2? 

UCSPE.png

Beginner

I am not seeing Firmware versions 3.X or above. Where can I obtain them? I am hitting an issue with the HX-Installer.

 

Thanks

 

~Allen

 

UCSPE.png

Cisco Employee

The HX installer is not compatible with the current emulator due to limits on the emulated HW and FW versions.  A server bundle meta-data update should happen with the 4.0 release of UCSPE, but the timeline for that release is not yet set.  We will also work to qualify HX installs once that version is released.

Beginner
No worries I don’t use the emulator any longer. It was helpful but honestly kind of a pain to get set up with the hardware interface. And it doesn’t support break out cable configurations. But it was a good platform for some up front learning before the real deal was shipped and in place in our datacenter.
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards