cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3031
Views
25
Helpful
15
Replies
Highlighted
Enthusiast

UCS support of VMware Virtual Volumes (VVOL) - HBA driver update?

Hi guys,

 

  I finally got a chance to try and play with Vmware Virtual Volumes (VVOL) today (available in vsphere/vcenter 6.0) and discovered that the UCS doesn't seem to support it.

I have a Nimble storage array (think SmartStack) that is running the software required for VVOL support (2.3.4). 

We enabled everything on the array but then ran into an issue where the hosts couldn't connect to the VVOL volume. 

It turns out that there needs to be an additional capability present on the HBA.  It is called second level lun ID (SLLID).

None of the VIC adapters seem to support this feature with the drivers I have.  I checked the release notes and found nothing.

Is there a target date when this feature will be added to the VIC drivers? I assume that it will be added considering the large number of customers running vmware on UCS (Flexpod, Vblock, Smartstack).

 

Vmware KB on the issue.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2114975

Output from my UCS that shows there are no capabilities listed.

[root@ssc-rcn-esxi-101:/var/log] esxcli storage core adapter list
HBA Name  Driver  Link State  UID                                   Capabilities  Description
--------  ------  ----------  ------------------------------------  ------------  ----------------------------------------------------------
vmhba0    mptsas  link-n/a    sas.51cdf0ffbeefe000                                (0000:01:00.0) LSI Logic / Symbios Logic LSI1064E
vmhba1    fnic    link-up     fc.20000025b5201000:20000025b5201a01                (0000:10:00.0) Cisco Systems Inc Cisco VIC FCoE HBA Driver
vmhba2    fnic    link-up     fc.20000025b5201000:20000025b5201b01                (0000:11:00.0) Cisco Systems Inc Cisco VIC FCoE HBA Driver

 

15 REPLIES 15
Highlighted
Cisco Employee

Hi Kris,

I helped you about a month ago on this ticket but I just wanted to go ahead and post the answer here for other members of the support forum incase they get stuck on this situation. Below is the summary of the ticket we had open and I made a nice little guide over VVOL for anyone interested.

VMware Virtual Volumes (VVOL) within UCS

Introduction

 

VMware just released a new feature called VMware Virtual Volumes (VVOL) (available in VSphere/VCenter 6.0). This document will help you and the customer understand what it is and how it is supported within UCS. VVol is highly dependent on storage and not so much on compute. So at first we needed to verify if the storage vendor supports it.

 

Problem Description

 

Customers have been trying to connect to the VVOL but have not been able to.  It turns out that there needs to be an additional capability present on the HBA.  It is called second level lun ID (SLLID). This Article will go through how to check if their VIC adapters have this feature available and how to enable it.

 

Solution

 

Release notes for the VIC adapters at the moment have no documentation over SSLID and if they support it or not. We have reached out to the alias to add this documentation to the release notes since a large number of customers are running VMware on UCS (Flexpod, Vblock, Smartstack). VMware has a KB on this issue located below;

 

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=211497...

 

This article gives you a command “esxcli storage core adapter list” which will verify if your adapter has the capability of Second Level Lun ID.

 

 

VVOL support is not dependent on a particular compute platform, one of the driver features needed by VVOL is. This results in Cisco having only 4 HBA / CNA adapters that can support VVOL. Based on the VMware compatibility guide (link is also below) it is shown that these are only supported by Cisco 1GigE I350 LOM, UCS VIC P81E, VICm81KR, and VIC-1285 adapters. What was odd are these are all old adapters.

 

http://www.vmware.com/resources/compatibility/search.php?deviceCategory=io&productid=10474&deviceCat...

 

However, The VIC 1340 (in the guise of the MLOM in the b200-M4) shows support for the Second Level Lun ID feature. They just aren’t on the VMware list. This implies that all vics that use the fnic driver will have that support, though this requires more testing. What it boils down to is that our drivers support the feature, but VMware’s HCL is not up to date on that fact. We are in the process of helping them get the HCL updated.

Highlighted

Thanks Qiese,

The support of SLLID on the VICs is for iSCSI only or is Fiber Channel supported as well?

Highlighted

An Enhancement for FC has been submitted. I will keep you up to date on that.

Highlighted

Can we get some additional details regarding this?

If not can you post the update here when it happens?

Thanks,

Jared

Highlighted

I have been trying to get them to include support for SLLID for over a year. There is a bug/enhancement you can track  CSCux64473. I would also suggest opening a TAC case referencing that bug so that Cisco knows how many people would like this feature.

Highlighted

Any word on the enhancement request?  

I would love to be able to implement VVols, but I can't until the SLLID support is included in the firmware.

Highlighted

Cisco did contact me and said would be early next year.  No details on server or hba models were given. I also heard from our rep, that if needed soon an RPQ would need to be opened with your account team if you need it sooner. 

I would like to implement VVols too, but I also want the feature working properly before it gets released. 

Highlighted

How is it that there is nothing new under the sun about this issue?  I have searched extensively and cannot find a new word one about this issue.  VMware has released 6.5 already and Nimble is at least 4-5 revisions from their vvols support.  More than a year later and info from Cisco is nowhere.

When can we expect official support for vvols and UCS?  This is a major feature of all the platforms but appears to be being overlooked.  There are plenty of other servers out there that have this support.  

Highlighted

VVol support should be coming in 3.1.3 release of UCSM.

-Wes

Highlighted

I have this exact same issue currently.

I have a B200-M4 with VIC1340 that shows secondary lun ID capable but still do not see the PE.

I also tried on a B230-M2 with M81KR with newer drivers that should have the new capability and do not.

vmkload_mod module information
input file: /usr/lib/vmware/vmkmod/fnic
Version: Version 1.6.0.17a, Build: 1331820, Interface: 9.2 Built on: May 13 2015

I found one issue with the SMS keystore where the key was expired, I recreated it, verified, and still no PE and VASA shows disconnected.

Getting frustrated that I am reading so many users are able to use this needed feature on HP branded servers and Cisco is a no go...at least so it appears.

Any help would be greatly appreciated.

Highlighted

Please add this VVOL feature in the Interop matrix

http://www.cisco.com/c/dam/en/us/td/docs/unified_computing/ucs/interoperability/matrix/b_hcl_B_rel2-26.pdf

Urgent request for PM !

Highlighted

Thanks for the link, it appears that I am running firmware 4.1 where I need to be running 4.8...now I need to figure out where that firmware version exists for downloads...

Wishing there was another column that would tell you the earliest release of that firmware version for the adapter...

Highlighted

I followed the document and I had to go to version 2.2.6e to get the 4.8 firmware.

Intersting point is:

- ESX 6.0 U1 VMware Release on old 2.2.3d firmware

* Shows the capabilities I need, but no PE available

* Confirmed I was running an old NIC driver

- ESX 6.0 U1 Cisco Custom on 2.2.6e firmware

* No secondary capabilities...thus no PE available

I'm at a lost at this point, as far as I know it should be working but is not.

Highlighted

I understand the frustration here. I created a new bug for this to have more documentation in regards to VVOL support within UCS on which adapters and more importantly for them to upload that in the release notes.

I have also reached out to our technical writers to see if I can gather more information for you.

Content for Community-Ad