cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
AMA event- Migrating Existing Networks to Cisco ACI
1935
Views
3
Helpful
7
Replies
Beginner

UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Hi

I would like to upgrade the UCSM infra setup from 2.2(3b) to 3.2(1b).

So please can someone help/guide  me that below steps are correct to achieve my upgrade task.

->First Upgrade UCSM from 2.2(3b) to 3.1(3c) and then upgrade blade firmware to 3.1.3c.

->Then upgrade from 3.1(3c) to 3.2(1b) and then upgarde blade firmware  to 3.2.1d

Additional Info : The UCSM Infrastructure running with ESXi host with 5.5 and also please find attached screen shot to know details of my setup with firmware versions

However I have one question that if I upgrade UCSM from .2(3b) to 3.1(3c) and then 3.2(1b),does my current Adapter(VIC 1240)  supports the target version since I m not finding this adapter version under  Adapter minimum software versions for adapter table, so I’m in confusion state .(see Table 14 in release notes )

Release Notes for Cisco UCS Manager, Release 3.1 https://www.cisco.com/c/en/us/td/docs/unified_computing/ucs/release/notes/CiscoUCSManager-RN-3-1.html

Adapters

Adapters

Minimum Software Version

UCS 6200 Series FI

Minimum Software Version

UCS 6332, 6332-16UP

Minimum Software Version

UCS 6332, 6332-16UP

Recommended Software Version

UCS 6200 Series FI

UCS 6332, 6332-16UP FI

UCS-IOM-2204

UCS-IOM-2208

UCS-IOM-2204

UCS-IOM-2208

UCS-IOM-2304

UCS-IOM-2204

UCS-IOM-2208

UCS-IOM-2304

UCSC-PCIE-C40Q-03

UCSC-MLOM-C40Q-03

  1. 2.2(7b)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCS-VIC-M82-8P

UCSB-MLOM-40G-01

UCSB-MLOM-PT-01

  1. 2.2(1b)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSB-MLOM-40G-03

UCSB-VIC-M83-8P

UCSC-MLOM-CSC-02

  1. 2.2(3a)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSC-PCIE-CSC-02

  1. 2.2(1b)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSC-F-FIO-1000MP

UCSC-F-FIO-1300MP

UCSC-F-FIO-2600MP

UCSC-F-FIO-5200MP

  1. 2.2(3a)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSB-FIO-1600MS

UCSB-FIO-1300MS

  1. 2.2(3a)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSC-INVADER-3108

UCSC-NYTRO-200GB

  1. 2.2(3a)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCSC-MLOM-C10T-02

UCSC-PCIE-C10T-02

UCSC-F-FIO-785M

UCSC-F-FIO-365M

UCSC-F-FIO-1205M

UCSC-F-FIO-3000M

UCSC-F-FIO1000PS

UCSC-F-FIO1300PS

UCSC-F-FIO2600PS

UCSC-F-FIO5200PS

UCSC-F-FIO-6400SS

UCSC-F-FIO-3200SS

  1. 2.2(4b)
  2. 3.1(1e)
  3. 3.1(1e)
  4. 3.1(3c)

UCS-MEZ-QLG-03

UCSB-MEZ-ELX-03

N20-AQ0102

N20-AE0102

  1. 2.2(3a)

  1. 3.1(3c)

2

UCS-PCIE-E14102B

  1. 2.2(7b)

  1. 3.1(3c)

UCSC-PCIE-IQ10GF

UCSC-PCIE-ID10GF

UCSC-PCIE-ID40GF

  1. 3.1(2b)
  2. 3.1(3c)

UCSC-F-I80010

UCSC-F-I12003

UCSC-F-I160010

UCSC-F-I20003

UCS-PCI25-40010

UCS-PCI25-8003

UCS-PCI25-80010

UCS-PCI25-16003

UCSC-F-H19001

UCSC-F-H38001

UCS-SDHPCIE800GB

UCS-SDHPCIE16TB

UCS-PCI25-38001

  1. 3.1(2b)
  2. 3.1(3c)

UCSC-PCIE-QD32GF

N2XX-AQPCI05

UCSC-PCIE-Q2672

UCSC-PCIE-BD32GF

UCSC-PCIE-BS32GF

UCSC-PCIE-E16002

N2XX-AEPCI05

UCSC-PCIE-ID10GC

  1. 3.1(3a)
  2. 3.1(3c)

Table 14 Minimum Software Versions for Adapters

Looks forward your help.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Hi Shankrappa,

you will not loose both FI at the same time.  if you use the automated method only one FI will get the update at a time.

you will get kick out of management for a while but that's all. if all your Blades are properly configures and have all there multi-path enable (network and Storage) your covered.  one path will drop during the update but that's all.

if your running esx just make sure all your hba and nic are dual or that you enable failover in the UCSM (there is that possibility to but I prefer to let the esx handle its failover) and in window if you have any installed on blades you have to be sure that vnic and hba have there dual path configured properly (most of the wintel world folk know about hba multi pathing but less about the Ethernet dual nic bounding)

if you cover this your A ok!

We do our upgrade from ucs Central automatically just by pushing a update policy of the UCS firmware and all of our 200 Blades just live trough it without issue.

so if you check all the base stuff it will work out.

Steph.

Stephane Beausoleil

virtualisation architect

CGI

View solution in original post

7 REPLIES 7

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

the latest version is 3.1.3c and it does support the vic1240.

you should also make sure you use the Cisco oem esx iso to upgrade your host to keep the esx platform compliant.

as for 3.2 I am not there yet.

Stephane Beausoleil

virtualisation architect

CGI
Highlighted
Beginner

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Thanks Stephane for your information.

However i have one more query that, does both FI's will lost connection after upgrade of UCSM to 3.1.3c and before starts of upgrading of FI"s (i would be preferring manual way of upgrading each components) since as per below release notes, minimum Software version for FI would be 2.5(1a),but current FI's running with 2.2(3b

Current  FI's are 6248 UP with  below versions

kernel version : 5.2(3) N2(2.23b)

System version : 5.2(3) N2(2.23b)

Package Version : 2.2(3b)

Fabric Interconnect

Fabric Interconnect

Minimum Software Version

Recommended Software Version

UCS 6248UP

2.5(1a)

3.1(1l)

UCS 6296UP

2.5(1a)

3.1(1l)

Thanks

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Hi Shankrappa,

you will not loose both FI at the same time.  if you use the automated method only one FI will get the update at a time.

you will get kick out of management for a while but that's all. if all your Blades are properly configures and have all there multi-path enable (network and Storage) your covered.  one path will drop during the update but that's all.

if your running esx just make sure all your hba and nic are dual or that you enable failover in the UCSM (there is that possibility to but I prefer to let the esx handle its failover) and in window if you have any installed on blades you have to be sure that vnic and hba have there dual path configured properly (most of the wintel world folk know about hba multi pathing but less about the Ethernet dual nic bounding)

if you cover this your A ok!

We do our upgrade from ucs Central automatically just by pushing a update policy of the UCS firmware and all of our 200 Blades just live trough it without issue.

so if you check all the base stuff it will work out.

Steph.

Stephane Beausoleil

virtualisation architect

CGI

View solution in original post

Beginner

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Thanks for your information stephane

But actually my concern is when I do upgrade manually ,first I will upgrade UCSM to 3.1 and then will go for  upgrading FI’s,So before actually upgrade of FI’s, does UCSM 3.1 supports existing FI ( As per release notes of 3.1, minimum FI for FI is 2.5(1a)),but my existing /current FI’s have 2.2(3b) version

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Hi Shankrappa,

There is just one step you misunderstood.  Upgrading the UCSM to 3.1 Will upgrade the First FI to.  the Manager/gui is part  of the FI's, so when you do you upgrade it will upgrade the FI's at the same time this is not a separate process.

And frankly you should not do the process manually.  the automated install is working properly.

Stephane Beausoleil

virtualisation architect

CGI

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Thanks for your response stephane.

Beginner

Re: UCSM infra setup upgrade from 2.2(3b) to 3.2(1b)

Can  any one please help/direct me on upgrade path for UCSM

Thanks

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.