cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3209
Views
0
Helpful
10
Replies
TIM MUNN
Beginner

vSphere DPM and IPMI not talking

I've followed the instructions in Integrating Cisco UCS with vSphere Distributed Power Management on one of the hosts in my new UCS cluster but I cannot get vCenter to update the IPMI info without throwing a:

Connection Error:The request failed because the remote server 'vcenter' took too long to respond. (The command has timed out as the remote server is taking too long to respond.)

Error Stack

Call "HostSystem.UpdateIpmi" for object "vmhost8.rx.umaryland.edu" on vCenter Server "vCenter.rx.umaryland.edu" failed.

I've check the account/pwd vmware/cisco123 are pretty easy to type so I'm reasonably comfortable I haven't repeated a typo.

sudo nmap -sU -p 623 134.192.XX.XX

[sudo] password for xxxxxx:

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2012-10-03 11:34 PDT

Interesting ports on 134.192.XX.XX:

PORT    STATE         SERVICE

623/udp open|filtered unknown

but an

ipmitool -H 134.192.XX.XX -U vmware -P cisco123 sel

Error: Unable to establish LAN session

Get SEL Info command failed

I'm kind of at a lost as to what to try next. I'd love to get DPM setup but seem to have run into a wall here.

Any suggestions or guidance would be greatly appreciated.

-

Tim

2 ACCEPTED SOLUTIONS

Accepted Solutions

Let me test with ESX 5.1 and get back to you.

Stay tuned.

Robert

View solution in original post

Have you configured IPMI policy service profile after it was associated to the blade?

If I am not mistaken, changes to IPMI policy would not take place after association. Try to re-associate your service profile to the blade.

Eugene

View solution in original post

10 REPLIES 10
Robert Burns
Cisco Employee

TIm,

I assumed you created an IPMI user and policy and applied to the service profile?

Have you assigned a Management IP to the Service profile (not the static blade IP either)?

Have you enabled IPMI in vCenter for the host and assigned the same username & password?

The IPMI address you should be targeting is the management IP (assigned to the CIMC) correct not the host IP?

Robert

Believe so. See below:

Have you enable Power Management with the Cluster DRS settings?

Is this the whitepaper you followed?

https://supportforums.cisco.com/docs/DOC-8582

Robert

Which version of UCS and VMware are you using?

I just tried this in my lab with ESX 5, and it works.

Robert

2.02q for UCS and ESXi 5.1

I may be doing something wrong but at this point I really don't know what and I'm not getting much in the way of error messages or any other debugging info.

Yes on the white paper.

DRS is set to manual.

The is Power Management is set to manual with DRS

Let me test with ESX 5.1 and get back to you.

Stay tuned.

Robert

View solution in original post

Have you configured IPMI policy service profile after it was associated to the blade?

If I am not mistaken, changes to IPMI policy would not take place after association. Try to re-associate your service profile to the blade.

Eugene

View solution in original post

As it turns out, I was getting intermittent, seemingly spurious, fan alerts related to an I2C bus defect. To resolve this I was asked to reseat all the fans, PSUs and IOMs in my chassis. I ended up reseating my blades too and that reapplied the service profile. Lo and behold I was able to add the IPMI info successfully without a hitch and I'm happily sending hosts into Standby Mode without a problem.

Thanks for the help.

-

Tim

Content for Community-Ad