cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
545
Views
0
Helpful
1
Replies
Highlighted
Cisco Employee

ASR920 QoS multiple match

Hi everyone,

We want to apply a service policy with a different match in different classes. I have read all the restrictions on this link:

 

https://www.cisco.com/c/en/us/td/docs/routers/asr920/configuration/guide/qos/16-9-1/b-qos-guidelines-xe-16-9-asr920.html

 

and it seems that this kind of configuration should works.

 

This is the config:

 

ip access-list ext QOS_ACL_TEST
 112 permit ip 10.196.27.216 0.0.0.7 any
!
!
class-map match-any QOS_XY1
  match vlan 51

!
class-map match-any QOS_TEST
 match access-group name QOS_TEST

!
!
class-map match-any QOS_XY2
  match vlan 2 
!
class-map match-any QOS_XY3
  match vlan 3 
!

!
!
policy-map QOS_IN
  class QOS_XY1
    set dscp EF
    set qos-group 5
!
  class QOS_XY2
    set dscp CS5
    set qos-group 4
!
  class QOS_TEST
    set dscp CS6
    set qos-group 6
!
  class QOS_XY3
    set dscp CS2
    set qos-group 2
!
  class class-default
   set dscp default
   set qos-group 0
!

interface Port-channel10
service instance 16 ethernet
service-policy input QOS_IN
QoS: Configuration failed. Invalid match in class QOS_TEST
QoS: Configuration errors for policymap QOS_IN

 

but when we apply the policy on the interface, there's this error.

If i apply the policy,matching only vlan or access list it works.

 

Do you have any suggestions?

 

Tks

 

 

 

 

Everyone's tags (4)
1 REPLY 1
Highlighted
VIP Expert

Re: ASR920 QoS multiple match

ip access-list ext QOS_ACL_TEST
112 permit ip 10.196.27.216 0.0.0.7 any

 

class-map match-any QOS_TEST
match access-group name QOS_TEST

 

???

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey

This widget could not be displayed.