cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
137
Views
0
Helpful
0
Replies
Highlighted

Cisco gateway AS5400 H323 Avaya

Hi everybody,

Please, i have an issue with h323 between my gateway Cisco As5400 and an Avaya CM PBX.

From Cisco to Avaya, the calls work perfectly in H323

But from Avaya to the Cisco Gateway using H323  i have a problem, the call does not connect.

The output in my Cisco of the "debug cch323 all" is as follows:

*********************************************************************

May 8 10:13:56.458: cch323_ct_main: SOCK 0 Event 0x1
May 8 10:13:56.462: cch323_get_new_ccb: ccb (0x672D1170) is in use
May 8 10:13:56.462: cch323_ct_main: SOCK 2 Event 0x1
May 8 10:13:56.462: [1]towner_data=0x64B595C8, len=308, msgPtr=0x66D4D1A0
cch323_gw_process_read_socket: received msg for H.225
cch323_h225_receiver: parse error or status enquiry 12

May 8 10:13:56.462: cch323_cleanup_xport: IP_entry is NULL, returning.

May 8 10:14:06.487: cch323_ct_main: SOCK 2 Event 0x1
May 8 10:14:06.487: [1]towner_data=0x64B595C8, len=46, msgPtr=0x6555EE04
cch323_gw_process_read_socket: received msg for H.225
validate_crv: No CCB for crv: 0x8921
May 8 10:14:06.487: cch323_h225_receiver: parse error RXDATA_NONE

May 8 10:14:06.487: cch323_cleanup_xport: IP_entry is NULL, returning.

May 8 10:14:06.487: cch323_ct_main: SOCK 2 Event 0x1Keepalive ignore timeout = 0
May 8 10:14:06.487: h323_gw_clean_send_blocked_watch: fd 2
May 8 10:14:06.487: CCH323: Dispatch 0x2D internal event to H225 SM
May 8 10:14:06.487: run_h225_sm: received event H225_EV_CONN_LOST while at state H225_IDLEcch323_call_generic_cleanup: for callID FFFFFFFF disconnected flag 0

May 8 10:14:06.487: cch323_cleanup_xport: IP_entry is NULL, returning.

 

Please what does it means?, what's the problem?

************************************************************************

The output "debug ip TCP Transactions":

************************************************************************

May 6 15:02:11.946: TCB67049508 created
May 6 15:02:11.946: TCP0: state was LISTEN -> SYNRCVD [1720 -> 172.19.0.41(30677)]
May 6 15:02:11.946: TCP0: Connection to 172.19.0.41:30677, received MSS 1460, MSS is 516
May 6 15:02:11.946: TCP: sending SYN, seq 826789918, ack 1470392881
May 6 15:02:11.946: TCP0: Connection to 172.19.0.41:30677, advertising MSS 536
May 6 15:02:11.950: TCP0: state was SYNRCVD -> ESTAB [1720 -> 172.19.0.41(30677)]
May 6 15:02:11.954: TCB643A17CC accepting 67049508 from 172.19.0.41.30677
May 6 15:02:11.954: TCB67049508 setting property TCP_PID (8) 6452CEEC
May 6 15:02:11.954: TCB67049508 setting property TCP_NO_DELAY (1) 6452CEF0
May 6 15:02:11.954: TCB67049508 setting property unknown (15) 6452CF6C
May 6 15:02:11.954: TCB67049508 setting property TCP_NO_DELAY (1) 6452CF44
May 6 15:02:11.954: TCB67049508 setting property TCP_ALWAYSPUSH (17) 6452CF44
May 6 15:02:26.954: TCP0: state was ESTAB -> FINWAIT1 [1720 -> 172.19.0.41(30677)]
May 6 15:02:26.954: TCP0: sending FIN
May 6 15:02:26.954: TCP0: state was FINWAIT1 -> FINWAIT2 [1720 -> 172.19.0.41(30677)]
May 6 15:02:26.958: TCP0: FIN processed
May 6 15:02:26.958: TCP0: state was FINWAIT2 -> TIMEWAIT [1720 -> 172.19.0.41(30677)]
May 6 15:02:26.958: TCP: sending RST, seq 826789920, ack 0
May 6 15:02:26.958: TCP: sent RST to 172.19.0.41:30677 from 10.0.61.252:1720
May 6 15:03:26.958: TCP0: state was TIMEWAIT -> CLOSED [1720 -> 172.19.0.41(30677)]
May 6 15:03:26.958: TCB 0x67049508 destroyed

************************************************************************

 

From the Avaya side, they send the:

"CS:  H225 the setup OpenLogicalChannel"

with all the data: Calling number, Called number, etc

But there is no answer from Cisco GW. So Avaya sends a release complete because of timeout.

 

Source ip and destination ip are correct, both machines see each other

 

Both dial-peers voice in Cisco are ok, the patterns are ok and simple,  i put also in the  interface FastEthernet0 the command:

h323-gateway voip bind srcaddr 10.0.61.252  (but still doesn't work)

interface FastEthernet0/1.615

description Conexion xxxxxxxxx
encapsulation dot1Q 615
ip address 10.0.61.252 255.255.255.0
no cdp enable
h323-gateway voip bind srcaddr 10.0.61.252


please any help will be appreciated, the Cisco gateway is in real production and has hundreds of calls both-ways real perfect calls with other PBX in Sip and other Cisco GW, none is Avaya)

 

The version of my cisco is :

 

Cisco Internetwork Operating System Software
IOS (tm) 5400 Software (C5400-IS-M), Version 12.3(10), RELEASE SOFTWARE (fc3)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 17-Aug-04 02:33 by kellythw
Image text-base: 0x60008AFC, data-base: 0x61700000

ROM: System Bootstrap, Version 12.2(1r)1, RELEASE SOFTWARE (fc1)
BOOTLDR: 5400 Software (C5400-BOOT-M), Version 12.3(13a), RELEASE SOFTWARE (fc2)

AS5400 uptime is 25 weeks, 2 days, 8 hours, 59 minutes
System returned to ROM by reload at 08:29:19 GMT+2 Wed Nov 13 2019
System restarted at 05:53:48 GMT+2 Wed Nov 13 2019
System image file is "flash:c5400-is-mz.123-10.bin"

cisco AS5400 (R7K) processor (revision T) with 262144K/65536K bytes of memory.
Processor board ID JAE063407QM
R7000 CPU at 250MHz, Implementation 39, Rev 1.0, 256KB L2, 2048KB L3 Cache
Last reset from IOS reload
Channelized E1, Version 1.0.
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
Manufacture Cookie Info:
EEPROM Type 0x0001, EEPROM Version 0x01, Board ID 0x31,
Board Hardware Version 3.33, Item Number 800-5171-02,
Board Revision B0, Serial Number JAE063407QM,
PLD/ISP Version 2.2, Manufacture Date 25-Aug-2002.
Processor 0x14, MAC Address 0x09E818497A
Backplane HW Revision 1.0, Flash Type 5V
2 FastEthernet/IEEE 802.3 interface(s)
254 Serial network interface(s)
276 terminal line(s)
8 Channelized E1/PRI port(s)
512K bytes of non-volatile configuration memory.
32768K bytes of processor board System flash (Read/Write)
8192K bytes of processor board Boot flash (Read/Write)

Configuration register is 0x2102

 

Note: Using SIP it works good but i cannot use it because of a "branch" parameter issue in the INVITE and the incompatibility with the old version of my Cisco. In that case calls from Cisco to Avaya fails because Avaya waits the branch and this Cisco version can't send it. From Avaya to Cisco works except for the hung up release from the outside to Avaya.

 

Thanks a lot.

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey

This widget could not be displayed.