cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
979
Views
0
Helpful
3
Replies

One-way voice problem

Hassan Yanaghi
Beginner
Beginner

Scenario is:

I have a cisco router 2811 with NM-HDV that I use it as a voice gateway. 8 PSTN lines and one E1 - PRI are connected to this router which this router has to pass them on SIP to asterisk server.

FXO ports  work well, and the other hand everything thing about E1 port seem to be ok due to it  can handle ring  either inbound or outbound but unfortunately voice between them is  one-way for instance when I make call from outside to E1 number after pick up from inside, voice inside can’t be hear from outside.

I have error on my E1 controller,  SLIP error increase specially.

And the other hand whan i want to config encapsulation ppp on my serial E1  i can not do it

SIPxchangeGW(config)#interface serial 1/0/0:15

SIPxchangeGW(config-if)#encapsulation ppp

%Hardware does not support ISDN data calls; encapsulation not set.

my E1 voice call is :NM-HDV

My configuration is :

version 12.4
service nagle
service timestamps debug datetime msec
service timestamps log datetime
no service password-encryption
!
hostname SIPxchangeGW
!
boot-start-marker
boot system flash c2800nm-ipvoicek9-mz.124-5.bin
boot-end-marker
!
logging console informational
!
no aaa new-model
!
resource policy
!
clock timezone IRST 3 30
clock summer-time IRST recurring
network-clock-participate slot 1
voice-card 0
no dspfarm
!
voice-card 1
no dspfarm
!
!
!
ip cef
!
!
no ip domain lookup
isdn switch-type primary-net5
!
!
template mon
!
!
no voice call carrier capacity active
!
voice service voip

sip
!
!
!
!
!
!
!
!
!
!
!
!
username navid privilege 15 secret 5 $1$dBqi$RmzGUV1Fgo/Jo4jzEhpnH1
username kamran privilege 15 secret 5 $1$9TmB$h0sW4W7LHjhEROoKF3ylB.
archive
log config
  hidekeys
!
!
controller E1 1/0/0
framing NO-CRC4
pri-group timeslots 1-31
!
controller E1 1/0/1
shutdown
!
!
!
interface FastEthernet0/0
ip address 192.168.210.20 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0/0:15
ip unnumbered FastEthernet0/0
encapsulation hdlc
dialer idle-timeout 500000
isdn switch-type primary-net5
isdn incoming-voice modem 64
no cdp enable
!
interface Group-Async0
physical-layer async
no ip address
encapsulation slip
no ip route-cache
no group-range
!
no ip classless
!
no ip http server
no ip http secure-server
!
no cdp run
!
!
!
control-plane
!
!
!
voice-port 0/0/0
connection plar 104
!
voice-port 0/0/1
supervisory disconnect anytone
output attenuation -3
echo-cancel coverage 32
compand-type a-law
cptone GB
timeouts call-disconnect 5
timeouts wait-release 5
connection plar 105
impedance complex2
description ***Konoba 345713***
caller-id enable
!
voice-port 0/0/2
connection plar 106
!
voice-port 0/0/3
connection plar 107
!
voice-port 0/1/0
supervisory disconnect anytone
signal groundStart
cptone DE
connection plar 100
impedance complex2
caller-id enable
!
voice-port 0/1/1
connection plar 101
caller-id enable
!
voice-port 0/1/2
connection plar 102
!
voice-port 0/1/3
connection plar 103
!
voice-port 1/0/0:15
input gain 4
output attenuation -6
echo-cancel coverage 24
no vad
cptone DE
bearer-cap Speech
!
!
no mgcp timer receive-rtcp
!
!
dial-peer cor custom
!
!
!
dial-peer voice 102 voip
destination-pattern 102
session target sip-server
codec g711ulaw
!
dial-peer voice 103 voip
destination-pattern 103
session target sip-server
codec g711ulaw
!
dial-peer voice 104 voip
destination-pattern 104
session target sip-server
codec g711ulaw
!
dial-peer voice 105 voip
destination-pattern 105
session target sip-server
codec g711ulaw
!
dial-peer voice 106 voip
destination-pattern 106
session target sip-server
codec g711ulaw
!
dial-peer voice 107 voip
destination-pattern 107
session target sip-server
codec g711ulaw
!
dial-peer voice 101 voip
destination-pattern 101
session target sip-server
codec g711ulaw
!
dial-peer voice 11001 pots
preference 1
destination-pattern .T
direct-inward-dial
port 1/0/0:15
forward-digits 11
!
dial-peer voice 100 voip
destination-pattern 100
session target sip-server
codec g711ulaw
!
dial-peer voice 11002 voip
destination-pattern .T
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
codec g711ulaw
!
sip-ua
sip-server ipv4:192.168.210.9:5060
!
alias exec his show call history voice br
alias exec scb show call active voice br
alias exec code1 show call active voice  | i CodecBytes=
alias exec cpu show proces cpu his
alias exec actt show voice call sum
alias exec ac show call active voice brief
alias exec hi show call history voice brief
alias exec acip show call active voice brief  | incl IP
alias exec acdur show call active voice brief | incl dur
alias exec hidur show call history voice brief | incl dur
alias exec hiip show call history voice brief | incl IP
alias exec acp show call active voice brief | incl Tele
alias exec hip show call history voice brief | incl Tele
alias exec sd show dial-p voice summary
alias exec zv show call active voice brief  | incl Orig
alias exec hizv show call history voice brief | inc
alias exec iac sh isdn active
alias exec e1 show call active voice br | in
alias exec e2 show  voip rtp connections
!
line con 0
logging synchronous
line aux 0
line vty 0 4
exec-timeout 0 0
logging synchronous
login local
!
scheduler allocate 20000 1000
ntp clock-period 17179672
ntp source FastEthernet0/0
ntp server 192.168.210.7
!
end
--More--

Scenario is:

I have a cisco router 2811 with NM-HDV that I use it as a voice gateway. 8 PSTN lines and one E1 - PRI are connected to this router which this router has to pass them on SIP to asterisk server.

FXO ports  work well, and the other hand everything thing about E1 port seem to be ok due to it  can handle ring  either inbound or outbound but unfortunately voice between them is  one-way for instance when I make call from outside to E1 number after pick up from inside, voice inside can’t be hear from outside.

I have error on my E1 controller,  SLIP error increase specially.

my configuration is :

3 Replies 3

Daniele Giordano
Collaborator
Collaborator

Use the command network-clock-select for SLIP problem and try this config for serial interface:

*** voice config, no data ***

interface Serial1/0/0:15

no ip address

encapsulation hdlc

no logging event link-status

no snmp trap link-status

isdn switch-type primary-net5

isdn overlap-receiving T302 4000

isdn incoming-voice voice

isdn map address transparent

isdn send-alerting

isdn negotiate-bchan

isdn sending-complete

no isdn outgoing display-ie

no cdp enable

Regards.

Thank's Daniele for your answer but unfortunately my problem still exist same as before. the serial of the router was configured exactly like your suggestion.when i call from inside to outside, outside sound can be heard from inside but the sound of inside it isn't heard by inside . Please help me for solving this problem as soon as possible.

Add the output of "debug ccsip message" and "debug voice ccapi inout".

Regards.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers